Open Bug 199387 Opened 17 years ago Updated 8 years ago

[RFE] "Totally fullscreen" fullscreen mode.

Categories

(SeaMonkey :: UI Design, enhancement)

enhancement
Not set

Tracking

(Not tracked)

People

(Reporter: ticmanis, Unassigned)

References

(Depends on 4 open bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

It would be cool if fullscreen mode could be modified (or an additional mode
added) in such a way that 100% of the screen pixels are assigned to showing page
content. I.e. the scrollbars and the location bar should disappear until you
touch the borders with the mouse pointer. To avoid confusing users a warning
explaining this behavior (and with a "do not show again" checkbox) could be
displayed the first time it is used.

Reasoning: Full screen has one purpose: Fitting more of the page on the screen.
So let there be as little as possible a part of the screen be dedicated to
anything else - and as little as possible is 0%.

What do you think?

Reproducible: Always

Steps to Reproduce:
1. Switch to fullscreen
Actual Results:  
Scrollbars and location bar are still there

Expected Results:  
100% of the screen real estate should've been dedicated to page content.

*** This bug has been marked as a duplicate of 3341 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
There is a bug that more closely matches what he wants. It is about having 
hideable menubars that only appear when you move your mouse to the corner of 
the screen. 
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Hendikins: Since you spammed everyone in that bug, I think its only fair that 
you find the correct dupe for this bug. ;-)
Status: UNCONFIRMED → NEW
Ever confirmed: true
GUI feature, not GFX. Reassigning.
Assignee: kmcclusk → blaker
Component: GFX → XP Apps: GUI Features
QA Contact: ian → paw
Target Milestone: --- → Future
If we're going to implement a completely fullscreen feature as requested, then
we really ought to look into supporting project-media styles as well-- as Opera
does with "OperaShow."  That feature has me using Opera to produce all of my
presentation slideshows these days, and if Mozilla hd a "MozShow" of some kind,
I'd switch to it in a second, especially if it worked cross-platform (OperaShow
is Windows-only, or at least non-Mac).
(In reply to comment #2)
> There is a bug that more closely matches what he wants. It is about having 
> hideable menubars that only appear when you move your mouse to the corner of 
> the screen. 

that's bug 126718
(In reply to comment #5)
> If we're going to implement a completely fullscreen feature as requested, then
> we really ought to look into supporting project-media styles as well-- as Opera
> does with "OperaShow."  That feature has me using Opera to produce all of my
> presentation slideshows these days, and if Mozilla hd a "MozShow" of some kind,
> I'd switch to it in a second, especially if it worked cross-platform (OperaShow
> is Windows-only, or at least non-Mac).
> 

That's bug 120398
Product: Core → Mozilla Application Suite
Assignee: bross2 → guifeatures
QA Contact: pawyskoczka
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures
Component: XP Apps: GUI Features → UI Design
OS: Windows 98 → All
Hardware: x86 → All
Target Milestone: Future → ---
You need to log in before you can comment on or make changes to this bug.