Latest Mozilla (2003-03-29-08) causes "jumpy" calendar display

RESOLVED FIXED

Status

Calendar
Sunbird Only
--
minor
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: David A. Cobb, Assigned: Mike Potter)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030329
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030329

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030329
Calendar xpi installed today (3/30)

The first time I loaded Calendar after installing, the display appeared
'jittery' to the point of being unuseable.  To be more specific, the frame (?)
displaying the current events above the month view kept resizing from about
1/4-in to 1-in and back.  The month view, of course, kept rescaling to match. 
REAL UGLY!

I was about to file this bug as just a calendar problem, when I happened to
visit an unrelated site <http://cygwin.com/faq/> that also uses frames (Quirks
Mode).  Curiously, the upper frame was tiny compared to the lower frame - even
thought all the meat was in the upper with just a few related links showing in
the lower frame.  I just grabbed the frame-divider and dragged it down to
something more reasonable - and doing so made "the penny drop."

I opened the calendar and played bat-the-gopher with the moving frame divider
until I could grab it and pull it down about an inch.  VOILA!  The display
stabilized and I could see how big the upper frame needed to be to show what was
there.  Now it looks just fine.

SO, here's my theory.  (1) There is a layout bug affecting the way frames are
sized / scaled; and (2) Calendar doess some really bad handling of whatever
condition is caused by #1.  I'm assuming the cyclic resizing is caused by
something in Calendar because the other frame site was stable (just unsightly).

Reproducible: Didn't try

Steps to Reproduce:
1. You must, I suspect, have an active calendar with enough holidays, etc., that
the upper "current events" frame has a couple of lines of content.

2. Install Mozilla 3002-03-29-08-trunk (Win32)
3. Install Calendar-xpi


Actual Results:  
Jumpy Display as described above.


NOTE: I've classified this as Minor because the workaround is simple -- but only
so if you know about it because it's not all that obvious.
(Reporter)

Comment 1

15 years ago
Filed http://bugzilla.mozilla.org/show_bug.cgi?id=199907 for the layout issue.
(Assignee)

Comment 2

15 years ago
*** Bug 205634 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

15 years ago
*** Bug 206135 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
*** Bug 210194 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
I confirm the bug (based on on duplicates and observations).
The problem occurs for me when there is only one event (I finally observed it
when I created a new profiles). So, only the new calendar users are affected :
this is bad, really.
The problem is somewhere in the code. Does somebody knowns how to determine what
part of the code is executed during the constant resizing observed. I don't
known how to do this with Venkmann.
I found a workaround which consists in giving a minimum size to the unifinder
window tree through CSS.
A patch will be posted below. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

15 years ago
Created attachment 127343 [details] [diff] [review]
workaround which impose a minimum size to the tree view through CSS

tested with classic theme.

Updated

15 years ago
Attachment #127343 - Flags: first-review?(mikep)
(Assignee)

Comment 7

15 years ago
Does this stop the top list from being collapsed?
(Assignee)

Comment 8

15 years ago
It looks OK to me, checked into cvs.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 9

15 years ago
*** Bug 213969 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
*** Bug 214585 has been marked as a duplicate of this bug. ***
Comment on attachment 127343 [details] [diff] [review]
workaround which impose a minimum size to the tree view through CSS

Patch was checked in
Attachment #127343 - Flags: first-review?(mikeypotter)

Comment 12

14 years ago
*** Bug 220398 has been marked as a duplicate of this bug. ***
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.