Enable URLBar autofill with "browser.urlbar.autoFill" property

RESOLVED FIXED in Firefox1.0beta

Status

()

Firefox
Location Bar
RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: eric lindvall, Assigned: eric lindvall)

Tracking

({fixed-aviary1.0})

unspecified
Firefox1.0beta
fixed-aviary1.0
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed0.9)

Attachments

(1 attachment, 1 obsolete attachment)

2.32 KB, patch
mconnor
: review+
Details | Diff | Splinter Review
(Assignee)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030423 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030423 Mozilla Firebird/0.6

This is a small change to enable the "browser.urlbar.autoFill" property to turn
on and off auto-fill on the urlbar.

Reproducible: Always

Steps to Reproduce:




This won't function properly without the patch from bug #203754:
http://bugzilla.mozilla.org/attachment.cgi?id=121989&action=view
(Assignee)

Comment 1

14 years ago
Created attachment 121990 [details] [diff] [review]
Patch to enable autoFill for URLBar

This allows for the auto-fill to be set via a preference.
(Assignee)

Updated

14 years ago
Attachment #121990 - Flags: review?(hewitt)
(Assignee)

Updated

14 years ago
Depends on: 203754

Comment 2

14 years ago
I'll confirm this one and bug #203754 so the devs can have a look on it...

=> confirming and setting All/All
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 3

14 years ago
Taking QA. Sorry for the bugspam
QA Contact: asa → davidpjames

Updated

14 years ago
Depends on: 186136

Updated

14 years ago
Blocks: 186136
No longer depends on: 186136

Comment 4

14 years ago
After applying the patch (with fuzz) and building Firebird the pref
browser.urlbar.autoFill does not show up in about:config as I would have
expected. If I put that pref into my user.js and set to true it does indeed
enable autofill in the url bar (yay). Perhaps a change to all.js is needed as
well? If that's the case then the appropriate place for that change is bug
186136, since a decision on true/false would have to be made. If not and
something else needs to be changed then the appropriate place is here.
(Assignee)

Comment 5

14 years ago
i'll have to update the patch do add it to the all.js.

Comment 6

14 years ago
--> Brian Ryner
Assignee: hewitt → bryner

Comment 7

14 years ago
Comment on attachment 121990 [details] [diff] [review]
Patch to enable autoFill for URLBar

Brian: Can you take a look at this and decide if we want this? Both IE and Moz
have it, so I suspect so.
Attachment #121990 - Flags: review?(hewitt) → review?(bryner)
Comment on attachment 121990 [details] [diff] [review]
Patch to enable autoFill for URLBar

passing over to ben.
Attachment #121990 - Flags: review?(bryner) → review?(bugs)

Updated

14 years ago
Flags: blocking0.8?

Comment 9

14 years ago
Ben:

Could you take a look at this patch and decide if we want this?
Assignee: bryner → bugs

Comment 10

14 years ago
I've wanted FB to have inline autocomplete for a while, but I don't like this patch.

It makes sense for the drop-down autocomplete to be the most recently or most
often viewed pages, or perhaps all matching pages in alphabetical order. But I
think IE did a better job with inline autocomplete in that it only autocompletes
up to the first "/". If you want more filled in after, you hit right-arrow and
start typing more, and it then fills in to the next "/". Otherwise, if you want,
for example, www.amazon.com, and you get an address with a whole string of ****
after that, it's a pain to then have to get rid of that **** to finally get to
the page you want.

I dunno if this is feasible for FB, but I thought it might just be something to
think about.

Comment 11

14 years ago
Lisa wrote:

> If you want more filled in after, you hit right-arrow and
> start typing more, and it then fills in to the next "/". Otherwise, if you want,
> for example, www.amazon.com, and you get an address with a whole string of crap
> after that, it's a pain to then have to get rid of that crap to finally get to
> the page you want.

You're obviously only familiar with IE implementation, not with the much wiser
one in Mozilla Seamonkey. When using the latter only the most common URL is
displayed in the address bar, in your case, that would be www.amazon.com without
any additions. Try it, and you'll be amazed at how useful it is (it's still one
of the only bugs that keep me from upgrading to Firebird)

Prog.

Comment 12

14 years ago
i don't have the time at the moment to go monkeying around with another browser,
so i'll take your word for it, Prog. Still, it's clear this patch to give FB
inline autocomplete is not quite on par with other methods out there. But that
raises the question: if Seamonkey can do it so well, why can't FB have the exact
same functionality?

Another thing I noticed with it is that it doesn't like to remember links you
click, only you type. Though as my amazon example showed, it has no problem
remembering links you're redirected to. Not a great combination, in my mind.

Comment 13

14 years ago
This patch, along with setting:

user_pref("browser.urlbar.autocomplete.learning.mode", 2);

to enable the learning machine provides the same functionality that Mozilla has,
which is far superior to what IE provides.
(Assignee)

Comment 14

14 years ago
Seems like your complaint is a little off-topic.

This patch merely enables filling in the first result from the drop-down in the
URL bar.

If the order of the URLs in the URL bar are sub-optimal, that seems like a
seperate bug.

I agree that the ordering should be fixed, but it just confuses the issue to
talk about it on this bug.

Comment 15

14 years ago
It wasn't off topic at the time, because I was talking about making the
autocomplete function behave differently from the drop down menu, which *would*
be considered an issue with the autofill patch. But you're probably right. Are
there already any plans that you know of to monkey with the ordering of the drop
down menu?

Thanks, Robert, for pointing out the learning mode. I have a feeling FB
autocomplete will work a lot better for me now.

Comment 16

14 years ago
There are plenty of other Autocomplete bugs:
http://bugzilla.mozilla.org/buglist.cgi?product=Firebird&component=Autocomplete&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED

Bug 186136 Comment 17
[bug 186136] is now about adding a UI access point to browser.urlbar.autoFill and
whether or not to set it on by default. Bug 203756 is about adding the pref itself.

not a blocker, this doesn't even have a decision on whether it is going to be
supported period
Flags: blocking0.8? → blocking0.8-

Comment 18

14 years ago
David P James, your patch has a "bryner: review?" flag for more than 8 months.
How about asking someone else to review it? with 26 votes, this is a highly
wanted feature that shouldn't be Seamonkey-only.

Prog.

Comment 19

14 years ago
Redirecting my suggestion to Eric Lindvall who is the cretor of the patch. 

Sorry for the spam, but since a patch *is* available and waiting for review, I'd
hate to see it lost in oblivion.

Prog.

PS.
Also related: Bug 186136 ("best match as you type"/inline autocomplete is
missing in Firebird) -> 32 votes
(Assignee)

Comment 20

14 years ago
I don't know who i should be giving this to.

Everyone I've tried to review it hasn't ever responded.

Comment 21

14 years ago
Try http://www.mozilla.org/owners.html and if that doesn't help, then the
quickest way to find out would be mozilla at irc://moznet

Prog.

Comment 22

14 years ago
You don't need to reviewer-shop.  Someone will get to it when they have time. 
Each developer has a long bugzilla queue and some things are higher priority.
(Assignee)

Comment 23

14 years ago
Should I wait until it's been 1 year? 2 years?

Comment 24

14 years ago
It is called bitrot and it is known to happen.  Your best bet is to try to catch
someone on IRC.  Just changing the flag won't make anything happen.
Comment on attachment 121990 [details] [diff] [review]
Patch to enable autoFill for URLBar

r=ben@mozilla.org
Attachment #121990 - Flags: review?(bugs) → review+
(Assignee)

Comment 26

14 years ago
So what do i need to do about it now? =)
Comment on attachment 121990 [details] [diff] [review]
Patch to enable autoFill for URLBar

This is going to cause the JS observer to stay alive until the browser shuts
down, since you never call removeObserver.  This will mean the JS global object
will also leak.  You need to call removeObserver in an appropriate place.  (You
can double-check this with the ++DOMWINDOW and --DOMWINDOW printfs in debug
builds.)
Attachment #121990 - Flags: superreview-
(Assignee)

Comment 28

14 years ago
Created attachment 144469 [details] [diff] [review]
improved patch

This patches against the latest firefox tree and makes required calls to
removeObserver().
Attachment #121990 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #144469 - Flags: review?(bugs)

Updated

14 years ago
Flags: blocking0.9?

Comment 29

13 years ago
*** Bug 240155 has been marked as a duplicate of this bug. ***

Comment 30

13 years ago
not a blocker but we'll try to get to this for beta. 
Flags: blocking0.9? → blocking0.9-
Target Milestone: --- → Firefox1.0beta

Updated

13 years ago
Flags: blocking1.0?
Comment on attachment 144469 [details] [diff] [review]
improved patch

good work, r=mconnor@myrealbox.com
Attachment #144469 - Flags: review?(bugs) → review+
will check this in with some cleanup of indenting soon
Assignee: bugs → eric
Whiteboard: checkin0.9
+ since there is a patch. 
Flags: blocking1.0? → blocking1.0+
checked in, branch and trunk, 2004-05-05 16:25
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Summary: Patch to enable URLBar autofill with "browser.urlbar.autoFill" property → Enable URLBar autofill with "browser.urlbar.autoFill" property
Whiteboard: checkin0.9 → fixed0.9

Comment 35

13 years ago
I don't see inline autocomplete in the May 6th or 7th builds, and I do have
browser.urlbar.autoFill = true in my config.  Is there something I'm doing wrong?
(Assignee)

Comment 36

13 years ago
(In reply to comment #35)
> I don't see inline autocomplete in the May 6th or 7th builds, and I do have
> browser.urlbar.autoFill = true in my config.  Is there something I'm doing wrong?

You're correct. I realize now there isn't an entry in the config js (is that
all.js?)

you'll have to set it in your user.js:
user_pref("browser.urlbar.autoFill", true);

or via about:config

Comment 37

13 years ago
Not sure what you mean, but anyway, I've removed the reference from prefs.js and
put it into user.js, but no difference.

Comment 38

13 years ago
Mike Coppins,

I just downloaded and installed 20040508 for Windows.  Inserted the
browser.urlbar.autoFill property via about:config.  It works fine for me. 
Perhaps you want to try a clean install with fresh profiles?

As a side note, is it possible to extend this functionality to all the fields
(e.g. search bar, web forms)?

Comment 39

13 years ago
Yup, thanks, found the problem.

Comment 40

13 years ago
*** Bug 186136 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Flags: blocking0.9-
Flags: blocking0.8-
Keywords: fixed-aviary1.0

Updated

11 years ago
Depends on: 334863

Updated

11 years ago
No longer depends on: 334863
You need to log in before you can comment on or make changes to this bug.