Duplicate accesskeys in Bookmarks Manager toolbar/menu

RESOLVED FIXED in Firefox1.0beta

Status

()

P3
minor
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: nparks, Assigned: mconnor)

Tracking

(Blocks: 1 bug, {access, fixed-aviary1.0})

unspecified
Firefox1.0beta
access, fixed-aviary1.0
Points:
---
Bug Flags:
blocking0.9 -
blocking-aviary1.0PR +
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6

(See also bug 171545).

Alt-F should open the File menu.  But in the bookmark manager, it creates a new
folder instead.  

Pressing Alt first and then F opens the file menu.



Reproducible: Always

Steps to Reproduce:
1. Open bookmark mgr and press Alt-F.
(Reporter)

Updated

16 years ago
OS: other → Windows ME
The problem is that the toolbar uses mnemonic keyboard shortcuts, which of
course it shouldn't.

Confirming and changing summary.
Blocks: 204402
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows ME → All
Hardware: PC → All
Summary: Alt-F in bookmark mgr creates new Folder sted opening File menu → Bookmark Manager toolbar shouldn't use accesskeys

Comment 2

16 years ago
What's wrong with using mnemonic keyboard shortcuts (accesskeys)?  Couldn't we
just change "New Folder" to not use 'F' as its accesskey?

Comment 3

16 years ago
yup, there is another conflict with alt-S (search and new separator)
Suggestions are welcomed!
It's just my opinion that mnemonic keyboard shortcuts doesn't have a place in
toolbars, which are for mice, not keyboards. Remember, these are not command
buttons.

If you can point me to other programs that uses mnemonic shortcuts, maybe I
could change my position in this regard.

Comment 5

16 years ago
This is not about this, but close

File>Export and Edit use the same access key but Alt+E brings up Edit

Comment 6

16 years ago
How come the summary is like that?

Removing toolbar doesn't fix it does it?

[F]ile and File>New [F]older would still use Alt+F even if accesskeys removed
from toolbar

Maybe it should be

Alt+E, Alt+F, Alt+S are shared by more than 1 menu item each

Comment 7

16 years ago
David, your response to this bug is that the problem is that the toolbar
shouldn't use accesskeys. 

That wouldn't fix 
Alt+F= File>New [F]older    but not [F]ile 
Alt+S= [S]earch             but not File>New [S]eparator
Alt+E= [E]dit               but not File>[E]xport



(Assignee)

Comment 8

16 years ago
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 9

16 years ago
*** Bug 214365 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
comment 6 and comment 7:
If you hide the toolbar (View-Toolbar), Alt-F opens the File menu.
If you want to create a new folder, you've got to press F a second time, while
the file menu is open.
If you want to create a separator, you've got to press S while the file menu is
open.
If you want to export, you've got to press E while the file menu is open.

Therefore, it's Alt-F-F, Alt-F-S and Alt-F-E.

Therefore everything will be fine if the toolbar doesn't take over Alt-F but let
you open the file menu. David is right.
(Assignee)

Comment 11

16 years ago
David is right in that if you removed all of the toolbar keybindings, it'd be
resolved.  Of course it would, but that doesn't mean its necessarily the right
answer for those people who want keyboard access in this screen.

Obviously we need to have two new keys mapped, but no one has made a suggestion
yet.  (Mozilla fixed this a little while back already)

The other option is to have keyboard shortcuts that aren't accesskeys:
Ctrl-F: New Folder
Ctrl-B: New Bookmark
Ctrl-S: New Separator
Ctrl-K: Search (parity with the search bar shortcut in the browser)

This would also be better parity with how other apps behave, since the functions
would work even with the toolbar disabled.
Summary: Bookmark Manager toolbar shouldn't use accesskeys → Duplicate accesskeys in Bookmarks Manager toolbar/menu
(Assignee)

Comment 12

15 years ago
*** Bug 233992 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

15 years ago
*** Bug 237942 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

15 years ago
*** Bug 245183 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
This has been rather glaringly visible for quite some time. Worth a 0.9 fix, or
perhaps 1.0?

(using FF 20040531 on Win32)
Flags: blocking0.9?
(In reply to comment #11)
> David is right in that if you removed all of the toolbar keybindings, it'd be
> resolved.  Of course it would, but that doesn't mean its necessarily the right
> answer for those people who want keyboard access in this screen.

I certainly didn't mean disabling keyboard access. But the fact is, a toolbar is
a mouse aid, not a keyboard aid, and toolbars don't have mnemonic keyboard
shortcuts. Menus and controls do, however. All functions in the Bookmark Manager
are accessible with the keyboard already, but it could help having keyboard
shortcuts for important features, so here is my suggesion:

1. Remove all mnemonic keyboard shortcuts from the toolbar.

2. Add (at least) the following important keyboard shortcuts to the menu:

  * Ctrl+F: New Folder
  * Ctrl+B: New Bookmark

And no, bugs like this don't block releases. Ever.
Severity: normal → minor
Flags: blocking0.9? → blocking0.9-
(Assignee)

Comment 17

15 years ago
(In reply to comment #16)
> And no, bugs like this don't block releases. Ever.

not 0.5, but 1.0, yes, we should fix this to meet accessibility standards.

Assignee: p_ch → mconnor
Flags: blocking1.0+
Keywords: access
Target Milestone: --- → Firefox1.0beta
(In reply to comment #17)
> (In reply to comment #16)
> > And no, bugs like this don't block releases. Ever.
> 
> not 0.5, but 1.0, yes, we should fix this to meet accessibility standards.

Then I assume [meta] bug 204402 is a 1.0 blocker too?

Comment 19

15 years ago
Ctrl+F is usually the shortcut for Find.  I don't think we should be
special-casing that one for this window.

What about using Ctrl+N for the more common function, being New Bookmark?
(In reply to comment #19)
> Ctrl+F is usually the shortcut for Find.  I don't think we should be
> special-casing that one for this window.
> 
> What about using Ctrl+N for the more common function, being New Bookmark?

Sound good, but what about New Folder then?

Comment 21

15 years ago
Next-available consonant?  Ctrl+L?
(Assignee)

Comment 22

15 years ago
*** Bug 247752 has been marked as a duplicate of this bug. ***

Comment 23

15 years ago
I've got a patch for the original issue, the duplicate 'F' access key, in bug
246431.  For the record, my opinion is that if there are text labels on toolbar
buttons then it's perfectly fine, and for me preferable, to have access keys.
Flags: blocking-aviary1.0RC1+

Comment 24

15 years ago
I was going to change this to 'l', but I notice on the branch that it's already
'o'.  In my opinion, this is the wrong access key.  MS's, and I believe Apple's,
access key guildelines support consonants over vowels.

Comment 25

15 years ago
Our accesskey guidelines
<http://www.mozilla.org/projects/ui/accessibility/accesskey.html> say to avoid
'l' as an accesskey.

Comment 26

15 years ago
I stand corrected.  Thanks Jesse.  Adding fixed-aviary1.0 keyword.
Keywords: fixed-aviary1.0
(Assignee)

Comment 27

15 years ago
not fixed yet, we still need an access key for separator/search

any objections to t for separator? if I get nothing in three hours, it'll go in
on branch/trunk so we can close this out.
Keywords: fixed-aviary1.0
(Assignee)

Comment 28

15 years ago
ok, NOW, its fixed-aviary.
Status: NEW → ASSIGNED
Keywords: fixed-aviary1.0
in bookmarks toolbar and bookmarks manager context menus, these two accesskeys
conflict (redundant S):

New _Separator
_Sort by Name

tested with 2004100609-0.9+ (linux fc2). should another bug be filed for this?
(Assignee)

Updated

14 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 30

13 years ago
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.