Closed Bug 204733 Opened 20 years ago Closed 20 years ago

[Mac] Use Pinstripe Theme for Mac OS X Firebird

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firebird0.8

People

(Reporter: noririty, Assigned: hyatt)

References

Details

(Keywords: platform-parity, polish)

Firebird default theme doesn't match with Mac OS X Aqua UI.
Thus we need more Mac OS X-specific CSSes as Mozilla.
reassigning mac bugs, sorry for the spam.
Assignee: blake → nobody
noririty, is this a theme change? if so, please reassign to Arvid, otherwise
hyatt, thanks
Mozilla's dialog button
http://bugzilla.mozilla.gr.jp/attachment.cgi?id=1604&action=view

Firebird's dialog button
http://bugzilla.mozilla.gr.jp/attachment.cgi?id=1603&action=view

Mac OS X shoudn't have those focus dotted square.

arvid:
Could you take a look at this?
Assignee: nobody → arvid
Keywords: polish
Summary: Separate CSS needed for Mac OS X Aqua UI → [Mac] Separate CSS needed for Mac OS X Aqua UI
The plan is to use the Pinstripe theme as Firebird's default on Mac.  Qute will be the 
theme for Windows and Linux.  This frees up Arvid to focus on Win32 and Linux, and lets 
us get a Mac theme guy on board (Kevin Gerich) to help split up the load.

I'm accepting this bug and targeting for 0.7.
Assignee: arvid → hyatt
Status: NEW → ASSIGNED
Summary: [Mac] Separate CSS needed for Mac OS X Aqua UI → [Mac] Use Pinstripe Theme for Mac OS X Firebird
Target Milestone: --- → Firebird0.7
Severity: enhancement → normal
How are we going to deal with the UI-changes for Panther ? Will Pinstripe use
Panther's bare-metal look, or Aqua's pinstripes ?
Aqua is not going away in Panther for third-party apps. It's only switching to
brushed-metal for Apple's own programs, so they can distinguish their apps from
everyone elses.
Target Milestone: Firebird0.7 → Firebird0.8
*** Bug 217784 has been marked as a duplicate of this bug. ***
QA Contact: asa
Blocks: 204479
See also bug 193052.
resolved.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.