If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

download remove from list fails with java error

RESOLVED DUPLICATE of bug 201697

Status

SeaMonkey
Download & File Handling
--
major
RESOLVED DUPLICATE of bug 201697
15 years ago
13 years ago

People

(Reporter: Jim Brown, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; OSF1 alpha; en-US; rv:1.4b) Gecko/20030526
Build Identifier: Mozilla/5.0 (X11; U; OSF1 alpha; en-US; rv:1.4b) Gecko/20030526

Cannot use 'Remove from List' or delete key to delete a completed download entry.
Bug was introduced by change 1.25 to download.js on May 23, 2003 by
checkins/changes for bug 205378.

This (new) code is not working in download.js:

var ds = window.arguments[0];
ds.beginUpdateBatch(); // fails on this line

Reproducible: Always

Steps to Reproduce:
1. Build from trunk on or after 2003-05-23
2. Try to delete a completed download using 'Remove from List' button or with
delete key
3. See error in JavaScript Console window

Actual Results:  
Get following error in JavaScript Console window when click 'Remove from List'
or pressing delete key.

Error: gDownloadManager.onStartBatchUpdate is not a function
Source File: chrome://communicator/content/downloadmanager/downloadmanager.js
Line: 272


There are other open bugs complaining about download manager problems.
They are bug 200663 and bug 173370.
I did not have any problems with download manager prior to 03-05-23.
(Reporter)

Updated

15 years ago
Flags: blocking1.4?

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 201697 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Flags: blocking1.4?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.