Closed Bug 208017 Opened 19 years ago Closed 10 years ago

Add labels to separators on bookmarks menu

Categories

(SeaMonkey :: Bookmarks & History, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 711351

People

(Reporter: rick, Unassigned)

References

Details

(Whiteboard: [2012 Fall Equinox])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529

I really like the idea of the labels for seperators, but I think they're a bit
useless as you can't see them in the bookmarks menu. So, and sorry if this has
already been proposed - I couldn't find anything, I would really like to see
them by the seperator. Maybe they could be left or centre aligned, and perhaps
there could be an option to not show them at all for those who don't want this
feature?

Reproducible: Always

Steps to Reproduce:
Here's a quick example I knocked up of what I'd like. The first seperator shows
a left aligned label, and the second has a centre aligned one. I think I prefer
the second myself.

I think some other app like MS Office has these kind of things.
We have labels with separators since bug 121053, but they can only be seen in
the bookmark manager, not in the menubar or in the toolbar-popups. That was
mentioned in bug 121053 comment 7.

Confirmed in build 2003060208 on Mac OS X 10.2.6

PS : we might get them in toolbar-popups, but I doubt that we'll see them in
menubars. AFAIK, they can only be created in Windows, but not on Mac OS X or in GTK.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Could we not just support them in Windows only then? Also aren't the menus
custom ones, not native Operating System ones? If so it can't be too hard to
modify the code for the separators, can it?
Summary: Add labels to seperators on bookmarks menu → Add labels to separators on bookmarks menu
This is closely related to bug 203233 (or almost a duplicate).
Depends on: 203233
*** Bug 237329 has been marked as a duplicate of this bug. ***
Comment on attachment 124756 [details]
An example of what I think it should look like

what's the logic that defines wether a label is flush left or centered?
Are you asking why there are two different alignments? It's just to let the
developers decide which one they would prefer to implement - i.e. there would
only be one or the other, not both centre and left alignments.
Product: Browser → Seamonkey
Reassigning as per Bug #32644
Assignee: p_ch → nobody
Status: NEW → RESOLVED
Closed: 10 years ago
OS: Windows 2000 → All
Hardware: x86 → All
Resolution: --- → DUPLICATE
Whiteboard: [2012 Fall Equinox]
Duplicate of bug: 711351
You need to log in before you can comment on or make changes to this bug.