On startup, Mozilla crashes with the message, "INTERNAL ERROR on Browser End: No manager for initializing factory?"

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: Gus Fantanas, Assigned: Joshua Xia)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507

Upon startup, 1.4RC2 for Linux crashes with the message INTERNAL ERROR on
Browser End: No manager for initializing factory? <NEW LINE> System error?::
Success". This problem does NOT occur if the latest version of Java (1.4.2 beta,
found through the link on the release notes) is NOT linked to a file in
../plugins/. The previous 1.4 version does NOT have this problem.

Reproducible: Always

Steps to Reproduce:
1.Install the new Java 1.4.2 runtime environment.
2.Create a soft link in ../plugins to libjavaplugin_oji.so. For example, in my
case, cd to the ../plugins directory and issue 'ln -sf
/usr/java/j2re1.4.2/plugin/i386/ns610/libjavaplugin_oji.so  .' (watch the period
in the end!).
3.Try to start the browser and watch it crash with the above error message.

Actual Results:  
I got the following error message:
INTERNAL ERROR on Browser End: No manager for initializing factory?

System error?:: Success

Expected Results:  
Browser should have started normally.

I am running Linux on an Intel machine. Only the Java link seems to create this
problem. This problem does not occur in the previous 1.4 release (with the same
Java link).
.
Assignee: general → joshua.xia
Component: Browser-General → OJI
QA Contact: general → dsirnapalli

Comment 2

15 years ago
does it work when linking to ns610gcc32 ?
Keywords: crash

Comment 3

15 years ago
*** Bug 209937 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
Same problem here. Changing the plugin link to the ns610-gcc32 file causes the
following error, but mozilla does start up. Java doesn't work though.

LoadPlugin: failed to initialize shared library
/usr/java/j2re1.4.2/plugin/i386/ns610-gcc32/libjavaplugin_oji.so [libgcc_s.so.1:
cannot open shared object file: No such file or directory]

This is redhat 7.3 which does not have gcc3. That java plugin is dynamically
linked to it and requires libgcc_s.so.1

$ ldd /usr/java/j2re1.4.2/plugin/i386/ns610-gcc32/libjavaplugin_oji.so
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x40062000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x400af000)
        libdl.so.2 => /lib/libdl.so.2 (0x40184000)
        libc.so.6 => /lib/i686/libc.so.6 (0x42000000)
        libgcc_s.so.1 => not found
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x40187000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x4018f000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
(Assignee)

Comment 5

15 years ago
Pete, please check this bug, thanks!
(Reporter)

Comment 6

15 years ago
I forgot to mention in my initial description that I am running SuSE 8.2 with
2.4.20 kernel. 'gcc -v' responds with a 3.3 version. Also, the previous,
trouble-free version, I am talking about referes to Mozillan(1.4b). Mozilla 1.4b
does NOT have any problem with the latest version of Sun Java in my environment.

Comment 7

15 years ago
I also have RH7.3 box and had the same problem with 1.4rc2. I have
j2re-1.4.2 and have linked to ns610-gcc32/libjavaplugin_oji.so in the
plugins directory.  Copying or linking libgcc_s.so.1 into mozilla
installation directory cured the problem.  I don't have Gcc3 but
instead used libgcc_s.so.1 from OpenOffice installation.

Comment 8

15 years ago
The ns610-gcc32 directory contains OJI Plugin for Mozilla compiled with GCC 3.2.
It has a dependency to libgcc_s.so.1 as many Linux RPMs. So if you system does
not have libgcc_s.so.1, install it. If you installed that shared object library
in a private location, set LD_LIBRARY_PATH to point to it.

I don't have any problem to use the plugin on either Redhat 7.3 or even Redhat 9.

Comment 9

15 years ago
No rpms on my redhat 7.3 system require gcc-3.2. Redhat does not provide this
version of gcc for redhat 7.3. Where did you get libgcc_s.so.1 from? What rpm?
From what source? Not from Redhat.

Here's the problem. Mozilla is now being compiled and linked with gcc 3.2. Which
I gather means that plugins need to be compiled and linked with gcc 3.2. Mozilla
has been linked statically, so the the shared version of the library need not be
installed. Therefore it will work on redhat 7.3. The java plugin has not been
linked statically and therefore requires the shared library. Many systems,
including redhat 7.3, do not provide this shared library. Since the gcc 3.2 java
plugin is now required for mozilla, it should also be statically linked, so that
java will work on systems such as redhat 7.3.
(Reporter)

Comment 10

15 years ago
OK, OK. I guess this not a bug per se. I think the problem is with the
documentation rather than the actual code. I followed the suggestion to link to
the same module but in the ........./n610-g32/ directory (for example, cd to
<Mozilla_1.4-RC2 install path>/plugins and run 'ln -sf
/usr/java/j2re1.4.2/plugin/i386/ns610-gcc32/libjavaplugin_oji.so .' and don't
forget the period in the end of the command). IT SEEMS TO BE RUNNING FINE NOW.

I ran into this problem because I followed the linking instructions for Unix in
the release notes. I think the release notes should make it clear that it is 
the ...../ns610-gcc32/libjavaplugin_oji.so that should be linked to in Linux,
not the ......./ns610/libjavaplugin_oji.so.

In light of this new development, I think it is the release notes that need to
be modified so that this point is clear. Furthermore, I think that the 1.4.2
version of Sun's Java is really nice becaue it respects the arts sound server;
previous versions of Java "monopolized" the sound output making it impossible
to, say, play an MP3 if Java had been activated (even if it did not use sound),
unless you shut down the broeser completely (or individually killed the Java tasks).

I would very much like to change the resolution of this bug to "FIXED," but I
don't know whether I have such authority.

Comment 11

15 years ago
The default GCC for Redhat 7.3 is GCC 2.96 and we don't really support Mozilla
compiled using GCC 3.2 which does not come from the system itself. That is to
say, if Mozilla is compiled on Redhat 8.0 using the default GCC(3.2) there and
we bring it to Redhat 7.3, that won't work since libgcc_s.so.1 is not in the
system. In other word, we don't support Mozilla build which has been tweaked by
using different compiler other than the system provided.

Comment 12

15 years ago
Then I think you need to get with the mozilla.org folks and discuss this. Up
until 1.4RC2, mozilla.org was not using gcc-3.2 for their builds and the java
plugin worked fine (using ...plugin/i386/ns610/libjavaplugin_oji.so). With
v1.4RC2 they started using gcc-3.2, but they did it statically so that platforms
without gcc-3.2 would still be supported using their binaries. I'm quite sure
they would expect that the java plugin (which now needs to be the ns610-gcc32
one) would also continue to work with their supplied binaries.

The java plugin no longer working with mozilla.org supplied binaries on Redhat
7.3 is a serious regression IMHO.

Comment 13

15 years ago
The purpose of adding gcc 32 support of Java Plugin is to support those GCC 3.2
compiled Mozilla browser which comes as the default browser on the system such
as SuSE 8.1. As I mentioned in the last comment, we are not providing the
support for  the browser built with gcc 3.2 and installed into the old Redhat
system.

If there is a strong business case to do so, please escallate to Sun's CTE team
and we can fix it. Otherwise, we don't feel a need to do so.

Comment 14

15 years ago
Just had this bug, v. worrying.
I think this should be a 1.4 blocker.

Kenneth, maybe the libgcc_s.so.1 problem should be raised as
a seperate bug?

Comment 15

15 years ago
per comment 10, we should close this one and file another bug for libgcc_s.so.1
problem on old system like RedHat7.3. And we need to update the release notes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 16

15 years ago
Release notes for mozilla1.4rc2 has been updated.
*** Bug 211191 has been marked as a duplicate of this bug. ***
*** Bug 211957 has been marked as a duplicate of this bug. ***

Comment 19

15 years ago
*** Bug 212645 has been marked as a duplicate of this bug. ***

Comment 20

15 years ago
*** Bug 231915 has been marked as a duplicate of this bug. ***

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.