Closed Bug 117967 Opened 21 years ago Closed 17 years ago

[RFE] accept and autocomplete names of bookmarks in url bar

Categories

(SeaMonkey :: Autocomplete, enhancement)

x86
All
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 101642
Future

People

(Reporter: hakon_, Assigned: hewitt)

References

Details

(Whiteboard: p-iewin)

In MSIE it's possible to type a "bookmark name" in the location bar, e.g.
"Mozilla homepage" for mozilla.org.
In the same manner, could it be so that if typing a string in the location bar,
the  uppermost alternative in the autocomplete dropdown list would be the
corresponding bookmark, disregarding whether the search string is in the actual URL.
I like that idea. Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: RFE: first alternative in dropdown is the bookmark with same name as string → [RFE] First alternative in dropdown is the bookmark with same name as string
Status: NEW → ASSIGNED
Target Milestone: --- → Future
changing qa to claudius.
QA Contact: blaker → claudius
This sounds close enough to something that I want.  I have a custom keyword for
my Bugzilla queries, and it is named 'bug'.  When I type 'bug 123456' in the URL
bar, I expect to see the closest matches to what 'bug 123456' will complete as.
 So, if I have visited bug 123458 recently, I'd like to see the full URL as one
of the completion choices.
Fixing this bug would make the "custom keyword" field unnecessary.  It would
also make creating keyword-like bookmarks take fewer steps.  Internet Explorer
does this but only for top-level favorites.
Summary: [RFE] First alternative in dropdown is the bookmark with same name as string → [RFE] accept and autocomplete names of bookmarks in url bar
Whiteboard: p-iewin
See also bug 82938, add Search Bookmarks to browser menus.
*** Bug 151041 has been marked as a duplicate of this bug. ***
Bug 101642 is for the bookmark URL instead of the bookmark name, but bug 101642
comment 3 also requests the bookmark name.

dupe this bug to bug 101642?
We have a pair of long-standing bugs (101642 and 117967 plus possibly others I
haven't found myself?) here both addressing the same really basic functionality
(but arguably not quite dupes of each other) that is missing from Mozilla at the
moment.

If this issue is not considered important enough to be fixed, then perhaps one
should consider that the whole concept of "bookmarks" is being undermined, since
the most desirable and natural way to use them (it would seem from comments on
these bugs and their dupes) is currently denied to users.

Perhaps merging these bugs into a new bug (taking comment #9 from bug 101462 as
the starting point) would help focus the seriousness of the usability problem(s)?

Also, merging the concept that BOTH names (from bookmarks/all other sources) and
URL's should be subject to this...

(quoting comment #9 since I'm applying this same comment to both bugs):

"Autocomplete should optionally include any subset of the following:
bookmarks, history, location bar, URLs actually ever *typed* into the
location bar. Its a mystery to me what the current behavior is using."
Cross-references for integrating autocomplete and bookmarks:

Include in the Autocomplete list ...

Bug 101642 - Bookmark URLs, and list them on top
Bug 117967 - Bookmark names/titles
Bug 155320 - Bookmarks user clicks on
Bug 212605 - Bookmark Keywords, and don't prepend previously
	     typed keywords with 'http://'
I have what must be at least 2500 bookmarks accumulated. How does that compare
with typical history sizes and what impact might it have on autocomplete
performance?

Re: Comment #4, I like being able to assign a shorthand name for a frequently
used bookmark, and would still find it useful even if the full names were
included in autocomplete, especially when one is set up to take a parameter.
Product: Core → Mozilla Application Suite
This bug has been open for a long time...

Until someone fixes this I have managed to get part of this bug solved through
an extension.

Here is its info:

AutoMarks  version 0.1

Install URL: http://www.ticklespace.com/AutoMarks/automarks.xpi

compatible with : Firefox 0.9 - 1.0 & latest Mozilla.

small description: Autocomplete in the Location bar with URLs from your bookmarks.

long description: The Location bar currently uses data in your history to
perform auto-complete of urls as you type them in. If you dont have much
history, the autocomplete feature starves and provides you little or no results.
This extension allows you to add your bookmarks so they are included in the
Autocomplete search.

website: http://www.ticklespace.com/
(In reply to comment #4)
> Fixing this bug would make the "custom keyword" field unnecessary.  It would
> also make creating keyword-like bookmarks take fewer steps.  Internet Explorer
> does this but only for top-level favorites.

The main advantage of the keyword field is being able to specify keyword
searches (e.g. so you can type "bugzilla <bug no.>" and it will go to the
appropriate bug). If this functionality is added (which would be useful), we
should still keep the keyword field.
This would be a REALLY useful feature if it gets off the ground. At the moment 
when I go to a web site, before I click on anything, I have to decide whether I 
know the URL well enough to type it into the address bar from memory, or if 
I'll have to go trawling through my bookmarks folder for the saved link. In 
some cases it even works out quicker to search for the thing on a search 
engine, rather than find it in my bookmarks.

With this extra functionality I could start all my browsing (except for maybe 
the most frequently-used links in the "links" bar) from the address bar. It'd 
drastically speed up the way a user can reach saved pages. It's the one last 
thing I could want for in a browser! =)
No longer depends on: 101642

*** This bug has been marked as a duplicate of 101642 ***
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
I'm proud to annouce the public release of version 1.0 of the Autocomplete Manager, which fixes this bug by means of an extension! The extension provides advanced features for the address Autocomplete framework in Firefox. Features include:
- matching against page titles
- matching against bookmark addresses and bookmark names
- matching any part of the domain name
- various sorting criteria for suggested entries, including alphabetical, most-frequently-visited and most-recently-visited
- resorting the suggestion list on the fly according to different criteria
- showing/hiding page titles and visit counts
- setting the number of visible entries on the popup
- define the truncation for long addresses
- numerous fixes for Autocomplete-related bugs

The extension can also function as a rudimentary History Manager. More details, as well as the installation package, are available at http://www.cs.ucla.edu/~nikitas/acmanager

Please let me know of any suggestions/bugs.

Thank you!
You need to log in before you can comment on or make changes to this bug.