Mozilla menubar reappears when no open windows (Thunderbird, similar to bug 204418)

VERIFIED FIXED in Thunderbird0.4

Status

Thunderbird
Mail Window Front End
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: Jo Hermans, Assigned: Scott MacGregor)

Tracking

unspecified
Thunderbird0.4
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Mozilla Thunderbird 0.1 (build 20030727) on Mac OS X 10.2.6

Similar to bug 204418 (for Firebird)

When you close the last window on a Mac, you don't have any windows left, but
the menubar is still functional. But it's the Mozilla toolbar that you see, not
the Thunderbird one. Most items are non-functional, but some surprises were
found, depending on what's still left inside Thunderbird :

- history window
- javascript console
- composer (!!! fully functional)
- password manager
- page info (on a non-exisiting page ?)

I was even able to surf using the view-source tab of the composer - a bit
awkward, but it works.

Yes, I know why we can find a complete composer and browser inside Thunderbird.
That's what you get when you have to put a HTML-viewer and a HTML-composer
inside your mailer. I just wanted to show that there might be a few places that
we still can remove from T-bird. Even though most of them will end up shared anyway.
(Reporter)

Comment 1

15 years ago
*** Bug 214136 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

15 years ago
macdoc doesn't know it yet, but he's going to help come up with the fix for this
=). Don't worry Don, I'll help you.
Status: NEW → ASSIGNED
(Assignee)

Comment 3

15 years ago
See:

http://bugzilla.mozilla.org/show_bug.cgi?id=204418

for information on the firebird issue.
(Assignee)

Comment 4

15 years ago
Don, to fix this issue we need to create a thunderbird specific version of
hiddenWindow.xul. This is the chrome loaded when there are no open windows on
the mac.

http://lxr.mozilla.org/seamonkey/source/xpfe/global/resources/content/hiddenWindow.xul

Start with a copy of this file, put it in mozilla\mail\base\content. Add a line
to mail\base\jar.mn which will export your version of hiddenWindow.xul,
overwriting the existing version. Something like the following example:

*+  content/communicator/askViewZoom.xul            (content/askViewZoom.xul)

Then you need to look in mail\base\content\mailWindowOverlay.xul and maybe
messenger.xul to see what menu items and such you want in the hidden window.

Comment 5

15 years ago
Scott,

I noticed in http://bugzilla.mozilla.org/show_bug.cgi?id=204418c5 there is a
recommendation to use the XUL preprocessor to generate the hiddenWindow.xul file
from an existing file.

What do you think? Shouldn't Thunderbird be doing this as well?

If so, is there a link for info on doing this?

Placing myself on the cc list for this one.
(Assignee)

Comment 6

15 years ago
the xul pre-processor is only enabled for firebird and thunderbird. You will
break seamonkey if you do that. Besides, we are going to be putting a bunch of
mail specific chrome in our version of hiddenWindow.xul. I doubt we want to add
mail code to a generic file like hiddenwindow.xul that is shared by the rest of
mozilla.

We should just fork the file in mozilla\mail\base

Comment 7

15 years ago
*** Bug 215184 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
*** Bug 214451 has been marked as a duplicate of this bug. ***

Updated

15 years ago
QA Contact: asa

Comment 9

15 years ago
*** Bug 220282 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
This bug appears to be fixed in the latest Thunderbird builds.
(Assignee)

Comment 11

15 years ago
yes we fixed this.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird0.4
cleanup:
Verified with Mac Tbird trunk build 2005-08-04-09-trunk
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.