IMAP folders (e.g. Trash) will not work without trailing "/" in prefs

RESOLVED FIXED

Status

MailNews Core
Networking: IMAP
RESOLVED FIXED
15 years ago
9 years ago

People

(Reporter: Joseph Simmons, Assigned: Bienvenu)

Tracking

({regression})

Trunk
PowerPC
All
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

2.67 KB, patch
(not reading, please use seth@sspitzer.org instead)
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
(not reading, please use seth@sspitzer.org instead)
: approval1.5+
Details | Diff | Splinter Review
1.16 KB, patch
(not reading, please use seth@sspitzer.org instead)
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
(not reading, please use seth@sspitzer.org instead)
: approval1.5+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: Thunderbird 0.1 (20030727)

When setting up an account, if you neglect to add the trailing "/", any 
function that requires movement of a message from one folder to another will 
fail.  The error will read "

Reproducible: Always

Steps to Reproduce:
1. Tools -> Account Settings -> Server Settings -> Advanced -> IMAP server 
directory
2. Enter IMAP directory without trailing "/"
3. Save settings and restart application
4. Attempt action which moves a message from one folder to another, ie. 
deleting it.
5. Program will generate error: The current command did not succeed.  The mail 
server responded: [TRYCREATE] UID COPY Failed: No such destination mailbox.

Actual Results:  
Program generates error.

Expected Results:  
Program should have intelligence added to assume that if a trailing "/" isn't 
present that it should implicitly place one.

Comment 1

15 years ago
Just ran into this with the 0.1 release! Shockingly, it wasn't broken in the
previous release I was using, which I thought was the 0.1 cadidate. Oh well.

I's say it's not really 'minor' since I just switched builds only to find it
completely failed to access any of my IMAP folders! (--> normal)

Updating summary, since this affects all IMAP folders.
Severity: minor → normal
Keywords: regression
OS: MacOS X → All
Summary: Trash will not work if trailing "/" is not appended to imap server directory → IMAP folders (e.g. Trash) will not work without trailing "/" in prefs

Comment 2

15 years ago
Duplicate of 214284.

Comment 3

15 years ago
*** Bug 214284 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird0.2
(Assignee)

Comment 4

15 years ago
I didn't realize this used to work, actually...
Assignee: scott → bienvenu
Status: ASSIGNED → NEW
(Assignee)

Comment 5

15 years ago
Created attachment 130664 [details] [diff] [review]
proposed fix

this adds back the hierarchy delimiter if not included in the online dir.
(Assignee)

Comment 6

15 years ago
Scott, you might want to try this patch for thunderbird.

Comment 7

15 years ago
checked into the 0.2 branch. if we do another respin we'll pick this up.

will leave open since it isn't in the trunk yet
(Assignee)

Comment 8

15 years ago
*** Bug 216963 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

15 years ago
Created attachment 130683 [details] [diff] [review]
add special folder handling

This code fixes the case where we're trying to save to the sent folder or
drafts, and the online dir is the same as the personal namespace. We used to
create a folder called INBOX.INBOX.Sent which caused some strange problems.
(Assignee)

Comment 10

15 years ago
*** Bug 217569 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
FYI, I put this 2nd patch into the 0.2 branch as well.
(Assignee)

Comment 12

15 years ago
*** Bug 217960 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

15 years ago
*** Bug 218194 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

15 years ago
changing product - this is a problem with the core code.
Component: Preferences → Networking: IMAP
Product: Thunderbird → MailNews
Target Milestone: Thunderbird0.2 → ---
Version: unspecified → Trunk
Comment on attachment 130683 [details] [diff] [review]
add special folder handling

r/sr/a=sspitzer
Attachment #130683 - Flags: superreview+
Attachment #130683 - Flags: review+
Attachment #130683 - Flags: approval1.5+
Comment on attachment 130664 [details] [diff] [review]
proposed fix

r/sr/a=sspitzer

shouldn't

(PL_strlen(ns->GetPrefix()) != 0)

just be

(strlen(ns->GetPrefix())
Attachment #130664 - Flags: superreview+
Attachment #130664 - Flags: review+
Attachment #130664 - Flags: approval1.5+
(Assignee)

Comment 17

15 years ago
fix checked in - I was getting a lot of dups filed on this, not to mention IM's :-)
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 18

15 years ago
*** Bug 218334 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 19

15 years ago
*** Bug 218657 has been marked as a duplicate of this bug. ***

Comment 20

15 years ago
*** Bug 218060 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.