Seamless Profile and Data Migration [MAC]

RESOLVED FIXED

Status

()

Firefox
General
P3
enhancement
RESOLVED FIXED
14 years ago
5 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Unassigned)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

Get user settings from Mozilla, Netscape 4.x, IE etc when they install Firebird.

Updated

14 years ago
QA Contact: asa

Updated

14 years ago
Depends on: 225284

Updated

14 years ago
Depends on: 234426
Target. 
Severity: normal → enhancement
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → Firefox0.9
Depends on: 235360
Depends on: 235361
Depends on: 235364
*** Bug 225284 has been marked as a duplicate of this bug. ***
No longer depends on: 225284
*** Bug 235743 has been marked as a duplicate of this bug. ***
Depends on: 236300
Depends on: 236301
Depends on: 236302
Depends on: 236303
Depends on: 236304
Depends on: 236305
Depends on: 236307
Depends on: 236308
Depends on: 236309

Comment 4

14 years ago
I just happened to take a look at nsSafariProfileMigration.cpp. I'm wondering
where character encodings to language mapping used there come from. 

http://lxr.mozilla.org/mozilla/source/browser/components/migration/src/nsSafariProfileMigrator.cpp#244

Is the mapping Safari-specific? If not, why don't you use GetCharsetLangGroup at 
http://lxr.mozilla.org/seamonkey/source/intl/uconv/idl/nsICharsetConverterManager.idl#121
?

Comment 5

14 years ago
bustage of Firefox BeOS build:
bug 236687

Updated

13 years ago
Flags: blocking1.0?
Blocking 1.0 - pretty much done on Windows, needs better Mac and Linux hookup.
Flags: blocking1.0? → blocking1.0+
Priority: P1 → P3
Depends on: 257445
Flags: blocking-aviary1.0mac+
Flags: blocking-aviary1.0-
Flags: blocking-aviary1.0+
OS: All → MacOS X
Hardware: All → Macintosh

Comment 7

13 years ago
*** Bug 235056 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
moving blocking1.0mac bugs to Firefox1.1 Target Milestone.
Target Milestone: Firefox0.9 → Firefox1.1
Flags: blocking-aviary1.0mac+
Flags: blocking-aviary1.0-
Keywords: meta
Target Milestone: Firefox1.5 → ---
Summary: Seamless Profile and Data Migration → Seamless Profile and Data Migration [MAC]
Assignee: bugs → nobody
Status: ASSIGNED → NEW
QA Contact: general
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.