Last Comment Bug 215294 - move NNTP news (news.mozilla.org) to mozilla.org server
: move NNTP news (news.mozilla.org) to mozilla.org server
Status: RESOLVED DUPLICATE of bug 173864
:
Product: mozilla.org Graveyard
Classification: Graveyard
Component: Server Operations: Projects (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Dave Miller [:justdave] (justdave@bugzilla.org)
: Justin Fitzhugh
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-06 10:55 PDT by Myk Melez [:myk] [@mykmelez]
Modified: 2015-03-12 08:24 PDT (History)
27 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Myk Melez [:myk] [@mykmelez] 2003-08-06 10:55:48 PDT
NNTP news needs to be moved to a mozilla.org server as part of the process of
transitioning mozilla.org to the Mozilla Foundation, f.e. by completing
configuration of smaug (or its replacement) and then moving that machine into
the mozilla.org colo space.
Comment 1 Jacob Steenhagen 2003-08-08 08:50:13 PDT
Will the newsgroups still be netscape.public.mozilla.*?
Comment 2 Dave Miller [:justdave] (justdave@bugzilla.org) 2003-08-08 09:19:25 PDT
From the sound of things at the last transition meeting I got the impression
that the "netscape.public." part was going to get dropped off the front (because
MF isn't Netscape anymore).
Comment 3 Markus Baur 2003-08-08 14:33:06 PDT
For now let's leave everything under netscape.public.mozilla until we get an
official mozilla.* newsgroup hierarchy approved. I think we have enough to do as
it is.
Comment 4 Chris Ilias [:cilias] 2004-04-01 22:40:58 PST
(In reply to comment #3)
> For now let's leave everything under netscape.public.mozilla until we get an
> official mozilla.* newsgroup hierarchy approved. I think we have enough to do as
> it is.

Is this the list:
http://www.mozilla.org.uk/newsgroups.txt

Has it been approved? If not, where can I send feedback?

Is there anything I can do to help?
Comment 5 fantasai 2004-04-07 16:06:55 PDT
From bug 62228: 

The situation is that we are currently still using Netscape's news server. We
have hardware for our own news server, but no resources to spare to set it up,
create the new groups, work out a transition plan and so on.

This bug would be far more likely to happen if an experienced news server admin
stepped forward and was able to commit to doing that work for us, and looking
after the server going forward. (This is really bug 215294). So there's a
challenge for anyone who wants to see this happen. :-|

Gerv
Comment 6 Frank Wein [:mcsmurf] 2004-04-27 23:16:05 PDT
So should there now be a new news hierarchie mozilla.* as per
http://www.mozilla.org.uk/newsgroups.txt or should everything be left under
netscape.public.mozilla.*?
Comment 7 fantasai 2004-04-28 10:28:49 PDT
There should be a new hierarchy under mozilla.* similar to the one in
newsgroups.txt, but not exactly -- that plan is a bit outdated and needs some
revision.
Comment 8 Jungshik Shin 2004-05-02 03:30:25 PDT
I had administered INN at my school until a few years ago. It's been a while so
that I have to refresh my memory. A couple of questions:

 - Do we have control over the netscape news server? 
 - Have we decided which news server software to use on our new server? 
 
Perhaps, we have to write a set of custom-scripts/programs to retrieve articles
from the netscape server via NNTP, to rename newsgroup names in newsgroups
header  (while probably keeping article IDs) and to feed them to our new server.

I don't have much free time, but I'm willing to help. 
Comment 9 Frank Wein [:mcsmurf] 2004-05-03 06:25:00 PDT
(In reply to comment #8)
> Perhaps, we have to write a set of custom-scripts/programs to retrieve articles
> from the netscape server via NNTP, to rename newsgroup names in newsgroups
> header  (while probably keeping article IDs) and to feed them to our new server.

IMHO the old server with it's groups should just be left alone and the groups
rmgroup'ed. Then we can open the new mozilla.* hierarchy on the new server.
Comment 10 Frank Wein [:mcsmurf] 2004-05-12 11:04:22 PDT
Another issue that came to my mind (please point me to some comment/newsgroup
posting in another Bug if this has been already discussed to some final
conclusion): Should the mozilla.* hierarchy only be distributed to
news.mozilla.org or also to other news servers (i would say dev groups no, user
groups yes)?
Comment 11 Kenneth Herron 2004-08-18 11:06:27 PDT
I've been corresponding with Gerv Markham about helping to set up the new news
server since april, after seeing the project mentioned in some meeting minutes.
Gerv eventually directed me to Myk Melez, who directed me to Markus Baur. Markus
hasn't answered the email I sent him, and Gerv hasn't yet responded to a recent
message I sent him.

I have a lot of time to work on this next week, but I need a point of contact
who can set up the access I need and discuss the exact scope of work.
Comment 12 jay garcia 2004-10-17 20:20:29 PDT
Seeing as how DevEdge and developer.netscape.com are effectively dead, I am now
concerned that the Netscape Server - Ports 119/563 is headed the same way. And
so goes that server so goes news.mozilla.org.

Somebody close to the project should maybe make some noise over at AOL/Netscape,
yes?
Comment 13 Myk Melez [:myk] [@mykmelez] 2004-10-18 12:24:52 PDT
Yes, and we have been and are continuing to do so.
Comment 14 Kenneth Herron 2004-10-23 18:49:04 PDT
These last two comments seem to be saying you're waiting on AOL to do something.
I thought the goal here was to set up a news server independent of AOL. How is
some inaction by AOL holding that up? Why did the foundation call for a
volunteer news administrator last april when it wasn't ready to move forward
with the project?
Comment 15 jay garcia 2004-10-23 19:56:44 PDT
(In reply to comment #14)
> These last two comments seem to be saying you're waiting on AOL to do something.

You have to consider AOL's past history of dealing with things "Netscape". They
purchase the company, terminate the employees effectively killing further
development of the application, close the offices, etc. The Netscape News
Server's fate is now in a state of uncertainty now that AOL has killed
developer.netscape.com and DevEdge. So, what makes one think that the news
server will somehow miraculously be spared the same fate? Personally I don't
think that AOL will do this to the Foundation.

And then AOL releases NS 7.2 and is slated to release another update/upgrade in
January(?) which makes me think that the server is on the proverbial "hot seat"
so to speak, all the more reason to spin the news.mozilla.org groups elsewhere.
From what I gather up to this point is that the physical server is ready to go
in it's physical location but an admin is needed before it will go online. I
believe it was Gerve (?) that made the point that the admin should be in from
the start able to give input on the new groups list as it's written at the
moment and it would be unfair to "hire" an admin to NOT have this input. That's
what I gather at least ...

I've been having a running dialog with an AOL Web Properties Programming Manager
who is supposed to be putting me in touch with a Netscape team manager. My
concern is Netscape Support that we Netscape Champions have been providing on
that server since it came online in 1995. And since news.mozilla.org is also
hosted on that server, the fate of both is a twofold concern, you lose one you
lose both.

I would of course be most willing to combine resources and lend a hand to M.O

Someone mentioned Markus Bauer (News Server Admin) in a previous reply. I've
known Markus for many years and assisted him with the admin of the server. From
past experience, don't hold your breath waiting for an email reply. I emailed
him wanting to add n.p.m.firefox in order to move the discussions away from
.firebird .. Been over 4 months now waiting for a reply. Sorry Markus, gotta
tell it like it is.

Comment 16 Chris Ilias [:cilias] 2004-10-25 20:18:40 PDT
(In reply to comment #14)
> These last two comments seem to be saying you're waiting on AOL to do something.

If anything, the uncertainty of news.mozilla.org should add a sense of urgency
to this bug, and give it more priority.
Comment 17 Dave Miller [:justdave] (justdave@bugzilla.org) 2005-12-15 23:42:14 PST

*** This bug has been marked as a duplicate of 173864 ***

Note You need to log in before you can comment on or make changes to this bug.