Bug 173864 (giganews)

migrate news.mozilla.org out of AOL

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations: Projects
P2
normal
RESOLVED FIXED
15 years ago
2 years ago

People

(Reporter: myk, Assigned: justdave)

Tracking

Details

(Reporter)

Description

15 years ago
news.mozilla.org should be migrated over to smaug, our "new" (i.e.
two-years-old) news server which was obtained for that purpose.
(Reporter)

Updated

15 years ago
Priority: -- → P2

Updated

15 years ago
Target Milestone: --- → mozilla1.0

Comment 1

15 years ago
punting to myk now that antitux is gone.
Assignee: antitux → myk

Updated

15 years ago
Target Milestone: mozilla1.0 → ---
ok, smaug is an ancient Solaris box that we don't have tolerance for dealing
with anymore. :)

Kerz had hardware he was going to donate, but his hardware has ended up
misbehaving and he doesn't trust it anymore.

We have a Dell PowerEdge 750 at the OSUOSL Colo that's collecting dust which
would be good for this.  cshields is in the process of loading the machine with
RHEL 4 for us, it'll hopefully be on the net tomorrow sometime.
Assignee: myk → justdave
Summary: migrate news.mozilla.org to smaug → migrate news.mozilla.org to chameleon

Comment 3

13 years ago
I don't think Dave knows what "ancient" means ;)

I wouldn't call an E220 ancient.

And one more thought for consideration: Do we want to keep the SSL server? The
Mozilla champions like it because newsgroups are not setup to propagate from
there and hence there is a lot less spam on these. Plus there are not many SSL
capable autoposters.
(In reply to comment #3)
> I wouldn't call an E220 ancient.

Heh, ok, the box isn't ancient.  The OS that's running on it is just... 
difficult. :)
chameleon wound up getting swiped for the update.mozilla.org cluster the day
after it got set up.

Rodan is probably our next best choice for now.  It'll be shared with other
stuff, but there's disk space, and we can shuffle things around if we need once
there's more machines (probably 3 to 4 weeks).
(In reply to comment #5)
> Rodan is probably our next best choice for now.  It'll be shared with other
> stuff, but there's disk space, and we can shuffle things around if we need once
> there's more machines (probably 3 to 4 weeks).

OK, inn is installed on rodan now, who wants to go set it up?
Summary: migrate news.mozilla.org to chameleon → migrate news.mozilla.org to rodan
Blocks: 252462
ok, nobody ever got to this, and we have the new servers now, so if it happens
now, it doesn't need to be Rodan anymore.  We do have some other possibilities
as well.
Summary: migrate news.mozilla.org to rodan → migrate news.mozilla.org out of AOL
Assignee: justdave → justdave
Component: Server Operations → Server Operations Projects
QA Contact: myk → justin
*** Bug 215294 has been marked as a duplicate of this bug. ***
Blocks: 34101
Blocks: 63735
No longer blocks: 239931
Current status: we have an agreement with GigaNews to host this for us (those who have been paying attention to the newsgroup page on the website probably noticed their name show up there a month or so ago).  The newsgroups will be migrating to their news servers with new names under the mozilla.* hierarchy, and at the same time, the mailing lists will be migrating to a new list server running a newer OS and a newer version of MailMan hosted by us.  The migration will be happening over the next few weeks.  Messages will be posted to each affected list a week or two in advance telling how that group will be affected and the date that group will be migrating.
If you have questions beyond what I just posted, Gerv has already blogged about this here:
http://weblogs.mozillazine.org/gerv/archives/2005/08/new_newsgroups_1.html
and here:
http://weblogs.mozillazine.org/gerv/archives/2005/09/new_newsgroups_2.html
Alias: giganews
Blocks: 296201
No longer blocks: 296201
Blocks: 150645
Done!  Yay!

We haven't migrated all the mail gateways to the new group names yet, but we are operating off the new server now.

You can still access the old AOL server via news://oldnews.mozilla.org/ if you have a need to.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
No longer blocks: 150645
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.