Closed Bug 218557 Opened 16 years ago Closed 11 years ago

Turn off Extra Send Progress Window by Default

Categories

(Thunderbird :: Mail Window Front End, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 440794

People

(Reporter: Peter, Assigned: mscott)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030905 Firebird/0.6.1+ StumbleUpon/1.84
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030905 Firebird/0.6.1+ StumbleUpon/1.84

Turn off Extra Send Progress Window by Default

Now that Thunderbird is not "linked" to Netscape anymore, it is time to change
this silly default. The information is already in the statusbar; and there is no
need to spam the user with a redundant pop-up window.

Fix: Simple! Change this setting to "false":

user_pref("mailnews.show_send_progress", false);


Reproducible: Always

Steps to Reproduce:
1. send an e-mail

Actual Results:  
watch annoying pop-up window tell you message is being sent (the same info as in
the status bar)

Expected Results:  
No Extra Send Progress Window
QA Contact: asa
Bug 137048 is the same bug for Seamonkey (I think).
See also bug 228410 for making it a visible pref.
QA Contact: front-end
Unless Seamonkey needs the popup progress dialog for any progress display I nominate it be deleted from the codebase.  The existing progress indicator in the Tbird status bar is functioning as a universal indicator for functions of message send and print processing.

An additional reason is valid if the dialog is modal and it's display blocks user activity other than dismissing the dialog.

Deletion from the codebase during the refactoring for TB 3.0 would be a low hanging fruit opportunity.
In general, I agree w/ deleting the dialog.  There are some minor issues w/ just switching the pref,such as the fact that in "sending" mode, the window doesn't given enough clues that sending is in progress. The cursor still blinks, navigation is still possible, etc.  I wonder what low hanging fruit could help with that - maybe a semi-transparent overlaid "screen" of some sort?

The longer term fix is probably to seriously rethink user feedback overall, and implement an Outbox-like concept like Mail.app -- it leads to a much faster workflow in my experience.  It's also probably not that low-hanging fruit.
We currently have an Unsent Mbox, but it is for delayed sending.  Old NC4 called that "Outbox"  I agree that a transient Outbox that functions as a send spooler would be a great feature.  I wonder, is it desirable to give the folder pane Outbox folder a display a visability toggle to show while transmission is in progress. 

Well Gecko can process CSS opacity if we have to keep an option for the dead center on screen box we now get. What about a fluctuating opacity shift? 

Another thought is reallocate the Throbber to display an animated image related to which activty is active. An Out arrow for send, In arrow for receive, and scolling paper for printer pre-processing.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 440794
This is not a duplicate of bug 440794. This bug needs to be fixed, regardless of whether we "Leverage Offline capabilities". The dialog needs to go.

IMO, they are not even really dependent on each other. But I could live with that more than burying it as a duplicate of a non-identical bug.

Please REOPEN.

PS. This bug is still assigned to Scott. Isn't he mostly gone now?
I believe that bug 440794 will solve this problem despite its Dilbertesque summary.  See bug 440794 comment 0.
You need to log in before you can comment on or make changes to this bug.