Closed Bug 21920 Opened 20 years ago Closed 20 years ago

<font size=1> rendered too big {font} {ll}

Categories

(Core :: Layout, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED DUPLICATE of bug 28766

People

(Reporter: navidazizi, Assigned: karnaze)

References

()

Details

(Keywords: testcase, verifyme, Whiteboard: [TESTCASE])

Attachments

(1 file)

15.42 KB, application/x-zip-compressed
Details
One of the most frequented sites in Canada is not displayed corrrectly by
Mozilla.

Even when I feed the IE version to Mozilla the layout is distorted.
Assignee: rickg → karnaze
Chris -- the only real problem I see on this page is nested table (gray) that
contains the title "On TSN". That section is too wide vertically. Please take a
look.
See bug #22328 for a bug that I split off from this bug. Bug #22328 covers
the misalignment in the images at the very top of the screen. [However, I'm
beginning to think that the root cause are one and the same -- and also the
same as bug #21560 (espn.com -- 'excess line-height causing overlaps of text').
There are two problems with this page, one is with alignment at the top and
another one is with the tables at the bottom.

Here are the test cases for the first one.

Attached is a file with a bad.htm and a good.htm.

The bad.htm in Mozilla has the left image too low (the right image is too low as
well, but it is harder to see) compared to the rest of the images.  The good.htm
fixes
this problem by eliminating the text labeled "bottom".  I guess Mozilla renders
the font too big thus enlarging the bottom table cell which should be set at
'15'.  When the cell height is enlargened, the two images at the corners which
span three rows and are valigned at the bottom became unmatched with the rest of
the image.

So in conclusion, the problem is that Mozilla renders <font size=1> too big.

The second problem is basically the same, if the font tags are replaced using
style sheets with font sizes set with points the page renders correctly.
Status: NEW → ASSIGNED
Target Milestone: M15
Whiteboard: [TESTCASE]
No change to the bug except added [TESTCASE] to Status line to get it off the
BugAThon list.

Gerv
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
Erik: This looks like another font size bug... Would this be fixed by Todd's
algorithm as per bug 18136?
Keywords: 4xp
Summary: Page is displayed completely wrong → <font size=1> rendered too big {font} {ll}
It may be fixed if Pierre checks in his code based on Todd's proposal.
Is that an RFC2119 "may"? ;-)

# 5. MAY   This word, or the adjective "OPTIONAL", mean that an item is
#    truly optional.
   - http://info.internet.isi.edu/in-notes/rfc/files/rfc2119.txt
Marking DUP of master <font size=1> bug.
Top people are working on this as we speak.


*** This bug has been marked as a duplicate of 28766 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Keywords: verifyme
VERIFY duplicate
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.