<font size=1> is bigger in Mozilla than in legacy browsers

VERIFIED WORKSFORME

Status

()

Core
Layout
P3
major
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: Hixie (not reading bugmail))

Tracking

({compat, meta, top100})

Trunk
compat, meta, top100
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
This is a meta (tracking) bug to track the problem of text in <font size="1"> 
tags renders slightly bigger in Mozilla than it does in Netscape 4 and IE.

For example:
   <font size=1> A </font>
The "A" will be about 1px bigger in Moz than in Nav4.

This should be fixed by a combination of the implementation of Todd's algorithm
for font sizes (bug 18136) and the changing of the font size rounding code (bug
24005). Adding those dependencies. Also ccing various interested parties.
(Assignee)

Comment 1

18 years ago
This should possibly be nominated for beta1, but since it will be fixed by 
fixing 18136 and/or 24005, and those are both beta1 already, I won't bother.
Depends on: 18136, 24005
Keywords: 4xp, meta, top100
Summary: <font size=1> is bigger in Mozilla than in legacy browsers → <font size=1> is bigger in Mozilla than in legacy browsers {compat}
Target Milestone: M14
(Assignee)

Comment 2

18 years ago
*** Bug 21920 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

18 years ago
*** Bug 18756 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

18 years ago
*** Bug 14033 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

18 years ago
Will try to look to check this is indeed fixed within the next few hours. It
looks fixed based on a quick comparison, but I need to do some pixel-for-pixel
work first.
Status: NEW → ASSIGNED
(Assignee)

Comment 6

18 years ago
Test case is fixed (screenshot coming up).
<font> in dup bug 21920 is now fixed.
layout of 18756 is now identical to IE's.
The fonts in 14033 are now identical too.

Marking WORKSFORME. This was fixed by the work on bug 18136 and bug 24005.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

18 years ago
Created attachment 6622 [details]
Screenshots of test case in Mozilla, Nav4 and IE5.
(Assignee)

Updated

18 years ago
Keywords: compat, verifyme
Summary: <font size=1> is bigger in Mozilla than in legacy browsers {compat} → <font size=1> is bigger in Mozilla than in legacy browsers

Comment 8

18 years ago
That screenshot is a masterpiece!
(Assignee)

Comment 9

18 years ago
What can I say. I have this project report to write, and spending a few minutes
in Corel Photo-Paint is infinitely more enjoyable, so... ;-)

Comment 10

18 years ago
Verified worksforme.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.