mail is sent as HTML by default

VERIFIED FIXED in M14

Status

P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: dbaron, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

I just took my first foray into mail-news (using a debug build from this
morning), set up an account (without giving POP info), hit "New Msg", typed my
own email address into the "To:", and sent myself a message.  I don't think I
changed any mailnews prefs before.  I read my email (with mailx, since reading
mail is one of those things I think shouldn't have a UI - I'm old fashioned),
and what do I see?  HTML.  To be exact, I see:

From dbaron@fas.harvard.edu  Sat Dec 18 23:01:40 1999
Date: Sat, 18 Dec 1999
23:01:36 -0500
From: David Baron <dbaron@fas.harvard.edu>
User-Agent: Mozilla 5.0 [en-US] (Linux; I)
To: dbaron@fas.harvard.edu
Subject:
Test

<html><head></head>
<body>Test</body>
</html>


Mail shouldn't be sent as HTML by default.  This is incompatible with lots of
other systems.  If Mozilla is to be a "polite" user-agent on the Internet, it
won't let newbies accidently shoot HTML mail off all over the place without
knowing that they could be antagonizing their recipients.
This also happens when I click a mailto: link to myself on my own webpage.
That's bad too :-(

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
We plan to use similar (if not exactly the same) HTML sending rules as 4.x does.

*** This bug has been marked as a duplicate of 17072 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
verified duplicate of the overall feature bug.
(Assignee)

Comment 4

19 years ago
I reopen this bug for tracking the change I plane to do about the default 
behavior when sending an HTML message (see bug 17072 for more info).
Status: VERIFIED → REOPENED
Keywords: beta1
Resolution: DUPLICATE → ---
Target Milestone: M14
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED

Comment 5

19 years ago
Joining cc list, since not being able to send plaintext easily has been one of
the issues stopping me from using mozilla mail.
(Assignee)

Comment 6

19 years ago
Here is the easy fix:

Index: nsMsgCompose.cpp
===================================================================
RCS file: /cvsroot/mozilla/mailnews/compose/src/nsMsgCompose.cpp,v
retrieving revision 1.138
diff -r1.138 nsMsgCompose.cpp
2127d2126
<     noHTMLArray->GetCount(&nbrRecipients);
2128a2128
>     noHTMLArray->GetCount(&nbrRecipients);
2131c2131
<         if (i > 0)
---
>         if (! recipientStr.IsEmpty())
2135c2135,2144
<     }     
---
>     }
>     //Remaining recipients which do not have an entry in the AB are considered as non HTML compliant
>     array->GetCount(&nbrRecipients);
>     for (i = 0; i < nbrRecipients; i ++)
>     {
>         if (! recipientStr.IsEmpty())
>             recipientStr += ',';
>         array->StringAt(i, getter_Copies(emailAddr));
>         recipientStr += emailAddr;
>     }

Index: MsgComposeCommands.js
===================================================================
RCS file: /cvsroot/mozilla/mailnews/compose/resources/content/MsgComposeCommands.js,v
retrieving revision 1.68
diff -r1.68 MsgComposeCommands.js
783c783
<         var newsgroups;
---
>         var noHtmlnewsgroups;
790c790,791
<             noHtmlRecipients = "";
---
>             var msgCompFields = msgCompose.compFields;
>             noHtmlRecipients = msgCompFields.GetTo() + "," + msgCompFields.GetCc() + "," + msgCompFields.GetBcc();
792c793,794
<         
---
>         dump("DetermineHTMLAction: noHtmlRecipients are " + noHtmlRecipients + "\n");
> 
795c797
<             newsgroups = msgCompose.GetNoHtmlNewsgroups(null);
---
>             noHtmlnewsgroups = msgCompose.GetNoHtmlNewsgroups(null);
798c800
<            newsgroups = msgCompose.compFields.GetNewsgroups();
---
>            noHtmlnewsgroups = msgCompose.compFields.GetNewsgroups();
801c803
<         if (noHtmlRecipients != "" || newsgroups != "")
---
>         if (noHtmlRecipients != "" || noHtmlnewsgroups != "")
807c809
<             if (newsgroups == "")
---
>             if (noHtmlnewsgroups == "")
OS: Linux → All
Hardware: PC → All
Whiteboard: Fix in hand
(Assignee)

Comment 7

19 years ago
Fixed and checked in
Whiteboard: Fix in hand
(Assignee)

Comment 8

19 years ago
I mean fixed.

No, every time you send an HTML message and if one of the user isn't defined in the address book (for now, only 
personnal addressbook and history addressbook) or the property "Send email as plain text (no html)" is on, we will 
popup a dialog asking you what to do. You can change the behavior by changing the preference <Mail and Newsgroup/
Formatting> or by selecting a format from the compose window menu options/format.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Updated

19 years ago
QA Contact: lchiang → fenella

Comment 9

19 years ago
This bug is dependent of bug 28093 (unable to edit Address book), in which the
fix is in tomorrow's build. Will re-test this bug using tomorrow's build.

Comment 10

19 years ago
When bug 28093 is fixed, I will re-visit the following Intelligent Send bugs to
ensure these bugs no longer exist.
bug 17215
bug 17273
bug 20233
bug 22141
bug 25771

Comment 11

19 years ago
This bug contains many scenarios. I am in the process of testing each of them on
all 3 platforms.
When sening HTML message, (using the HTML composer), HTML dialog should come
up..
1. if the receipient is NOT listed in the Address Book
2. Or the Receipient in the Address Card with "Send Mail as Plain Text" turned
on,
3. Or in the Compose window, select Option|Format Ask Me.
(Assignee)

Comment 12

19 years ago
...and only if the format pref. say "Ask Me" (menu 
edit/preferences/mail and newsgroup/formatting).

Updated

19 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 13

19 years ago
Win32 (2000-02-21-09 M14)
Mac (2000-02-21-07 M14)
Reopen bug Summary: For scenario #2 mentioned above, all 3 platforms work fine.
For scenario #1: Linux works fine.  But  for Mac and Win_nt 4.0: HTML dialog
does not come up when receipient is NOT listed in the Addr. Book
Steps to reproduce:
1. From Address Book Collected Address, remove fenella@nsmail-2 
2. Set preferences/mail and newsgroup/formatting to "Ask Me"
3. Using the HTML editor, compose a message and address  it to fenella@nsmail-2
4. Click Send.

Actual result: HTML dialog does not come up. Message was sent in the HTML format
on Win32. But on Mac, I got a empty content (bug 28704), separate bug.

Expected result: HTML dialog should come up.

Re-open the bug. 

This problem occurs on Mac and Win_nt 4.0. Linux works fine.

Comment 14

19 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]

Comment 15

19 years ago
Win32 (2000-02-23-08 M14)
Mac (2000-02-23-08 M14) 
I re-tested this bug using new profiles. The bug is gone
 
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 16

19 years ago
Mark it verified
Status: RESOLVED → VERIFIED
This has regressed in the past week or so.  Reopening.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
I'm tempted to add a dogfood nomination since I won't risk embarassing myself
using the browser for email if this bug exists.  But I don't normally use
it anyway, so I won't add the nomination.
Keywords: mozilla0.9
(Assignee)

Comment 19

18 years ago
Please don't reopen an old bug that has been fixed and verified. Instead, file a
new one. Thanks
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Keywords: mozilla0.9, nsbeta1
Resolution: --- → FIXED
(Assignee)

Comment 20

18 years ago
verified (again)
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.