optionally add unread,total, and size columns to thunderbird folder pane, controlled by pref

VERIFIED FIXED

Status

Thunderbird
Mail Window Front End
VERIFIED FIXED
15 years ago
8 years ago

People

(Reporter: Sandra Brasch, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Thunderbird/0.3

The feature that displays the unread and total email messages is on the wrong 
part of the display window.  The feature should be on the Folders section NOT 
the individual email display area. (It is available on the individual email 
messages display pane but it doesn't work.)

Reproducible: Always

Steps to Reproduce:
1.Cannot activate this feature in the folders section
2.
3.



Expected Results:  
Should display the number of unread and/or total email messages.
(Assignee)

Comment 1

14 years ago
I think this is a request to get the total and unread folder pane columns back.
Scott, should we use this for the work I'm doing? And make it an m4 dependency?

Comment 2

14 years ago
sure david
Blocks: 227205
(Assignee)

Comment 3

14 years ago
taking, patch upcoming
Assignee: mscott → bienvenu
Summary: Unread and Total emails are in the wrong place → optionally add unread,total, and size columns to thunderbird folder pane, controlled by pref

Comment 4

14 years ago
There's already a similar enhancement request (bug 215576) with a long cc list,
could you either use that one or mark it as a dupe?
(Assignee)

Comment 5

14 years ago
thx, I looked, but didn't find that bug.  This was the first one I found. I'll
mark that as a dup since this one has a patch and an sr request.
(Assignee)

Comment 6

14 years ago
*** Bug 215576 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
Thanks David for attempting to revive this long missed feature.  I do believe
that the duped bug (215576) wanted the same functionality as is in SeaMonkey.
(Assignee)

Comment 8

14 years ago
Created attachment 137379 [details] [diff] [review]
proposed fix
(Assignee)

Updated

14 years ago
Attachment #137379 - Flags: superreview?(mscott)

Comment 9

14 years ago
Comment on attachment 137379 [details] [diff] [review]
proposed fix

looks good david. i'll expose the pref in the prefs UI after you check it in
Attachment #137379 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 10

14 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
I found user_pref("mailnews.ui.threadpane.version", 5); in my prefs.js.
So I added pref("mail.showFolderPaneColumns", true); in user.js.
Then Unread/Total column has revived!

First barrier for me to migrate to Thunderbird has been defeated at last.
Thanks a lot, David.

Comment 12

14 years ago
13.12.2003: "i'll expose the pref in the *prefs UI* after you check it in". 

14.12.2003: "fix checked in."

Scott: Should I file a *new bug* or *reopen* this one for the "last step" of
this bug?

PS. Shouldn't this be hardware/OS: all/all?
(Assignee)

Comment 13

14 years ago
Scott already checked in the pref ui, under advanced settings.

Comment 14

14 years ago
> Scott already checked in the pref ui, under advanced settings.

True, found it. Yikes, sorry for bugspam then. :-[

Why does this need to be a pref, and especially a UI pref? The little dropdown
button takes up no used space (just a little more space than the scrollbar - if
present). Wouldn't it be saner to have the button exposed by default, and have
the collumns off by default? Then an about:config pref (no UI) would suffice.

Comment 15

14 years ago
*** Bug 230798 has been marked as a duplicate of this bug. ***
v.
Status: RESOLVED → VERIFIED
OS: Windows XP → All
Hardware: PC → All
You need to log in before you can comment on or make changes to this bug.