Thunderbird should act as an RSS/Atom newsreader, too

VERIFIED FIXED

Status

enhancement
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: gkn, Assigned: Bienvenu)

Tracking

({fixed-aviary1.0})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(8 attachments, 2 obsolete attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.6b) Gecko/20031109 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.6b) Gecko/20031109 Firebird/0.7+

I'm no expert (and I'm probably missing something vital :), but it seems that
Thunderbird could be fairly simply extended to read RSS newsfeeds too.

The "Add account" dialogue could have a third option, "Newsfeed account (RSS)"
perhaps. All RSS feeds could be automatically placed into a folder, "RSS feeds";
the user could, of course, make their own subfolders in order to categorise feeds.

The main display could work a lot like the current handling of newsgroups;
except Subject would be named Title; Sender, Author; and so on.

It'd be a hell of a nice new feature; possibly even unique?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
Yes, I've been thinking about an RSS extension to thunderbird and what such an
extension should do recently as well.

Comment 2

16 years ago
Dupe of bug 171453?
(Reporter)

Comment 3

16 years ago
Bug 171354 is for the browser; related, though.

Comment 4

16 years ago
can this bug be voted on?
(Reporter)

Comment 5

16 years ago
re: comment 4: that's bug 214124

Comment 6

16 years ago
The way Scott MacGregor describes how RSS feeds could be integrated into
thunderbird works already with Opera's mailclient M2 (the beta Opera 7.5 at
least has it...)

It's completely integrated, and works just the way e-mail works... it can also
be filtered; copied to mail folders, very interesting.

I've added an screenshot of M2 displaying an rss feed for better illustration.

Comment 7

16 years ago
verycool. thanks for the screen shot. 

Comment 8

16 years ago
(In reply to comment #5)
> re: comment 4: that's bug 214124

The funny thing is that You can't even vote for bug 214124 ;-(

Comment 9

15 years ago
+1 vote :p
(Assignee)

Updated

15 years ago
Assignee: mscott → bienvenu
(Assignee)

Comment 10

15 years ago
initial backend work, starting from Seth's patch, and some stuff added...
(Assignee)

Comment 11

15 years ago
I've also checked in some initial code for a thunderbird extension to work with
this backend code, in mail/extensions/newsblog - it's basically myk's forumzilla
extension code with a few changes to use the new backend rss server, and I've
added a js component that the rss server code can use to update/download a feed.
There's a lot of duplicate code between the js component and the extension. I
think the duplication will be removed by moving more code into the js component,
and calling the js component from the extension js, but I need to get a much
better idea of what the interface(s) will look like.

I've added the destination folder for the feed to the subscription ds -
currently, it will always be the folder with the feed name under the news &
blogs server, but  in the future, that will allow us to be flexible about where
the feed gets downloaded.

The next thing I'm going to do is write some code to make unsubscribe work - if
the folder is under the news and blog server, and there are no other feeds
feeding into that folder, then the folder should be removed.

Comment 12

15 years ago
This checkin broke my SeaMonkey build since I don't have the xmlextras extension
enabled.  Can we disable this feature if xmlextras isn't being built?

Do you thought about the feature to write comments to a newsfeed?
(Assignee)

Comment 14

15 years ago
(Assignee)

Updated

15 years ago
Attachment #151025 - Flags: superreview?(sspitzer)
(Assignee)

Updated

15 years ago
Attachment #151025 - Attachment is obsolete: true
(Assignee)

Updated

15 years ago
Attachment #151025 - Flags: superreview?(sspitzer)
(Assignee)

Updated

15 years ago
Attachment #151026 - Flags: superreview?(sspitzer)
Perhaps we could repurpose the notification code used by mail into something
more generic.

That way, a user can ask to be notified if a feed is updated.  Perhaps use a
different sound, and color/icon for the popup notification.
(Assignee)

Updated

15 years ago
Attachment #151065 - Flags: superreview?(sspitzer)
Attachment #151026 - Flags: superreview?(sspitzer) → superreview+
Attachment #151065 - Flags: superreview?(sspitzer) → superreview+
(Assignee)

Comment 18

15 years ago
need to make set flags set flags_inited flags so we won't crunch the result of
an initial setFlags.
(Assignee)

Updated

15 years ago
Attachment #151466 - Flags: superreview?(sspitzer)
(Assignee)

Comment 19

15 years ago
this change also removes the onload timer stuff, which I'm not sure of the need
for (perhaps because the folder pane in tbird does a delayed load - perhaps we
need to make sure the accounts get loaded in our onload.
(Reporter)

Comment 20

15 years ago
Adding Atom to summary - if we can do RSS, we can do Atom
Summary: Thunderbird should act as an RSS newsreader, too → Thunderbird should act as an RSS/Atom newsreader, too

Comment 21

15 years ago
Even *Ximian Evolution* has had integrated RSS feeds for months!!!  Its kind of
buried, though.  You might never find it if you didn't know it was there (.  Now
you know - go check it out ('Tools | Settings | Summary Preferences'. 'News
Feeds' tab).  Article titles appear in the 'Summary'.  In Mozilla/Thunderbird,
I'd suggest adding a 'News Feed' folder, in addition to 'Junk', 'Sent',
'Drafts', etc.  I see no need to make a user add an account, as has been
previously suggested here.  Possibly allow the user to drag-and-drop URLs to the
folder to add new feeds.  Provide a selection of useful feeds.

Since a screenshot of Opera has been posted, I'll try to post one of Evolution,
but since I'm in Windows now, I'll have to do it from another computer.

Comment 22

15 years ago
Shows feed/article titles in summary and setup dialog.
Note that a new version (0.5.1) of Forumzilla, the extension upon which this
code is based, has been released at:

http://forumzilla.mozdev.org/

Highlights since 0.5.0 include:

    * a new subscriptions manager for maintaining your feed subscriptions;
    * the option to download stories into any local/POP folder;
    * no need for a separate "News & Blogs" account;
    * a link for opening stories in your web browser;
    * a fix for the bug that caused Forumzilla to redownload stories
      after you deleted them;
    * some performance improvements;
    * a bunch of other bug fixes.

Note that the patches in this bug are forked from an early version of 0.5.1 and
thus may have a version of some of these enhancements.
(Assignee)

Comment 24

15 years ago
this patch adds a new interface to nsIMsgLocalMailFolder to add a message, and
switches the newsblog extension to use the interface. This makes it so mail
filters will now work on newsblog messages. I'm seeing an anomaly with "Fr"
displayed before the message, that might be related to this change, though
everything looks OK in the mailbox, and in the message source.
(Assignee)

Updated

15 years ago
Attachment #152456 - Flags: superreview?(mscott)

Comment 25

15 years ago
Comment on attachment 152456 [details] [diff] [review]
make filters work on rss messages

I'll speak up if I start seeing your FR issue after I update with this change
:)
Attachment #152456 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 26

15 years ago
the message size is off by 2, I'm pretty sure - 2 bytes too big. I'll try to
figure out why. I'm just throwing the data at the parser - not sure it's getting
the message size wrong.
(Assignee)

Comment 27

15 years ago
this fixes the problem I mentioned before...
Attachment #152456 - Attachment is obsolete: true

Updated

15 years ago
Component: Mail Window Front End → RSS

Comment 28

15 years ago
When will this be included with the nightly aviary branch builds?
(Assignee)

Comment 29

15 years ago
it will be when mscott turns it on, which should be any day now, if it hasn't
already happened.

Comment 30

15 years ago
As with Forumzilla, the integrated RSS reader doesn't handle special characters
(like ä, ö, ü) correctly, instead it only displays a question mark. Two feeds
where you can see this behaviour:

http://www.heise.de/newsticker/heise.rdf
http://photodb.kicker.de/library/rss091/kicker.xml

Will this issue be "tackled" in the near future? :)

Comment 31

15 years ago
this has been adressed as a problem in the seperate bug 253807

Comment 32

15 years ago
What is the trick to have Thunderbird display the <description/>?

Works here:
http://www.internet-nexus.com/rss.xml

Doesn't work here (shows webpage directly):
http://photodb.kicker.de/library/rss091/kicker.xml
(Assignee)

Comment 33

15 years ago
marking fixed - please open new bugs for remaining issues. Scott and I (mostly
Scott :-) )have got it basically working.

Neither Scott or I are planning on porting this to Seamonkey, but that doesn't
mean someone else can't or won't.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Blocks: 255834

Comment 34

15 years ago
I filled bug 255834 for Seamonkey port.
(Assignee)

Updated

15 years ago
Keywords: fixed-aviary1.0
v.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 36

14 years ago
Comment on attachment 151466 [details] [diff] [review]
allow new flag to be set from js

clearing old request
Attachment #151466 - Flags: superreview?(sspitzer)

Updated

10 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.