[FEATURE] Cut, copy, paste, & select all in content area

VERIFIED FIXED in M14

Status

SeaMonkey
UI Design
P1
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: don, Assigned: Simon Fraser)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdt+]Waiting for 14026 to be fixed)

(Reporter)

Description

19 years ago
Chris, this is a place holder to make sure we actually get clipboard support
working in the browser content area.  It's the other half of bug #4722 which
Radha currently owns.
(Reporter)

Updated

19 years ago
Priority: P3 → P1
Target Milestone: M13
(Reporter)

Comment 1

19 years ago
*** Bug 6253 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

19 years ago
*** Bug 16740 has been marked as a duplicate of this bug. ***

Updated

19 years ago
QA Contact: paulmac → elig

Updated

19 years ago
Depends on: 14026

Updated

19 years ago
Blocks: 24206
(Reporter)

Updated

19 years ago
Target Milestone: M13 → M14
(Reporter)

Comment 3

19 years ago
Moving to M14 ...

Comment 4

19 years ago
don will track this.
Assignee: mcafee → don
(Reporter)

Comment 5

19 years ago
Nominating as "beta1" blocker.
Keywords: beta1
Whiteboard: Waiting for 14026 to be fixed

Updated

19 years ago
Whiteboard: Waiting for 14026 to be fixed → [pdt+]Waiting for 14026 to be fixed

Comment 6

19 years ago
Normally, pressing the key on the keyboard called Print Scrn will causse the
screen (actually the desktop) to be copied in Windows, or if you press Alt -
Print Scrn, only the window in focus will be copied.  If you go into MS Word or
Netscape Messenger 4.7 and you press Shift-Insert, the desktop or window in
focus you copied earlier will be pasted into the email/news message you are
trying to write.  In the Mozilla Composer nightly build 2/12/00, pasting in is
not working.
(Reporter)

Comment 7

19 years ago
Yep, this works now.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

19 years ago
Actually, I fixed this, so I'm grabbing this bug for posterity.  ;)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

19 years ago
Grabbing
Assignee: don → sfraser
Status: REOPENED → NEW
(Assignee)

Comment 10

19 years ago
I fixed it.
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
Verified fixed on 2.17.00 builds on Win32/Linux/Mac OS by ~20 minutes of ad hoc

testing. (Also checked the dupes.)



Wrote bug #28331, "Select All -> Browser scrolls to bottom of window", which I

discovered in verifying this bug.



Also, View Source copying remains blocked by 12460.

Updated

18 years ago
No longer blocks: 24206
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.