Closed Bug 227331 Opened 21 years ago Closed 12 years ago

Abnormal shutdown truncates (large) bookmarks.html [crash, bsod]

Categories

(SeaMonkey :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: guanxi_i, Unassigned)

References

Details

(Keywords: dataloss)

Attachments

(1 file)

173.30 KB, application/octet-stream
Details
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

I've seen this a few times now, over a couple years:

1.  Mozilla open
2.  BSOD
3.  On reboot, my bookmarks.html is truncated

This time, I has been heavily editing the bookmarks in bookmark manager, and I
believe the focus was on the bookmarks sidebar, where I was pushing the mouse. 
The BSOD was in my IBM Thinkpad mouse driver, syntp, though I doubt that makes a
difference.

My Bookmarks.html is relatively large: probably over 600K for earlier occurances
of this bug, and over 800K now.  I'll attach the corrupted version from today
(zipped up).

This bug may be related to bug 193749, but my preferences weren't affected and
the bookmarks were only truncated, not lost.
Here's my truncated bookmarks.html, zipped up.

Truncated version:     704K
Un-truncated version: ~837K

It's truly truncated: As far as I can tell, no bookmarks are missing before the
end of the file.
fixing typo, adding search terms ... sorry for the spam
Summary: Abnomral shutdown truncates (large) bookmarks.html → Abnormal shutdown truncates (large) bookmarks.html [crash, bsod]
bug 193749 seems related ...

A cross-reference field (e.g. "Related bugs") in Bugzilla would be helpful.
I don't see how this is any different to that bug actually

*** This bug has been marked as a duplicate of 193749 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
That bug says, 

"Mozilla starts without any bookmarks, no
Personal Toolbar and with all preferences reset to defaults. Personal toolbar
cannot be reconstructed, even after importing previously saved (exported)
bookmarks."

Yes, there's a crash and something happens to the bookmarks, but that probably
describes many bugs.  

I'm guessing this bug is caused by the fact that bookmarks are being edited when
the system crashes, and it truncates them.  The other is a complete wipe of
prefs and bookmarks under different circumstances.

Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Similiar bug is Bug 233015.
Blocks: failsafe
*** Bug 263344 has been marked as a duplicate of this bug. ***
I recently experienced this bug as well. I had a large bookmarks file which I
was not actively editing, BSOD hit while I was using firefox and when I
rebooted, Firefox had no bookmarks. Preferences, extensions, cookies, etc were
unaffected.

Firefox users experiencing this bug might want this extension, Bookmark Backup.
 It backs up your bookmarks each time you close Firefox:

http://www.extensionsmirror.nl/index.php?showtopic=13

I don't know much about it, except it seems to work well for me.
*** Bug 264034 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
*** Bug 271742 has been marked as a duplicate of this bug. ***
I recently experienced the same bug as depicted by comment #8, on my Windows XP
Professional/Firefox 1.0.1. My relatively large bookmarks file was open when
BSOD hit. When rebooted, Firefox bookmarks was all gone. Cookies were unaffected.

I haven't reproduced it.
Reassigning as per Bug #32644
Assignee: p_ch → nobody
Status: REOPENED → NEW
I've had this problems for both Mozilla and Seamonkey.  It seems the bookmark manager doesn't make a backup as it opens, so if there is a unanticipated shutdown, ALL bookmarks are lost.

It would be very helpful, if bookmarks were backed up at open, so at least you only loose the new bookmarks.
Peta, please cite version.
is your loss with version 1.x, or 2.x?  
dataloss should be substantially reduced, or gone.
Keywords: dataloss
This bug concerns the old bookmarks.html code in XPFE. Both Firefox and SeaMonkey have been using the (new) Places implementation for some time now. Closing this obsolete bug.
Status: NEW → RESOLVED
Closed: 20 years ago12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.