If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Ctrl+Tab doesn't work in failed (gray, completely blank) tab

VERIFIED FIXED in Firefox1.0beta

Status

()

Firefox
Toolbars and Customization
P2
normal
VERIFIED FIXED
14 years ago
11 years ago

People

(Reporter: Ben Hollis, Assigned: Blake Ross)

Tracking

({fixed-aviary1.0, testcase})

unspecified
Firefox1.0beta
x86
All
fixed-aviary1.0, testcase
Points:
---
Bug Flags:
blocking-aviary1.0PR +
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

This might be related to Bug 210952 - If a tab in a tabset (from bookmarks)
fails to load a page (blahblah page not found) and you try to Ctrl+Tab through
all the tabs, the cycle will stop at that failed tab. You'll be tabbing along,
and suddenly - stopped. Not a very major bug, but it's there.

Reproducible: Always

Steps to Reproduce:
1. Make a bookmark folder that includes a site that fails to load for some
reason. (DNS trouble, whatever)
2. Load all the bookmars into tabs as a tabset.
3. Ctrl+Tab through the tabs. 

Actual Results:  
It'll stop cycling at the failed page.

Expected Results:  
Continued to cycle through tabs.

Comment 1

14 years ago
Dup of bug 112337 or bug 177030?  Fixed for zombie pages, but not for tabs that
haven't had any pages in them, in bug 110718.

Comment 2

14 years ago
Something strange: Ctrl+Tab doesn't work in failed tabs, but many keyboard
shortcuts (Ctrl+W, Ctrl+N) do work.
Summary: Ctrl +Tab stops cycling through tabs at failed page from tabset → Ctrl+Tab doesn't work in failed (gray, completely blank) tab

Comment 3

14 years ago
*** Bug 230907 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
I still see this bug in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20040128 Firebird/0.8.0+
so it's not a dup of any of the bugs I mentioned in comment 1.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

14 years ago
See also bug 232770, "Tab-switching shortcuts don't work when address bar has
focus (Ctrl+Tab, Ctrl+PgDn)".

Comment 6

14 years ago
*** Bug 216258 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
Jesse-
Why did an earlier bug get marked a dupe of this one instead of vice versa?

Comment 8

14 years ago
alan: because this bug is cross-referenced and has a slightly better summary.

Updated

14 years ago
Assignee: blake → hyatt
Component: General → Toolbars
QA Contact: bugzilla

Comment 9

14 years ago
This is not only a Windows XP problem.  I'm using Firefox 0.8 under Linux here
and I can reproduce it.

However, not only Ctrl+Tab, but *no* key works.  This is really bad, because it
makes keyboard navigation impossible and forces the user to use the mouse.

It furthermore is not necessary to use bookmarks -- every time that gray page
appears (I think it's when a server doesn't respond), the keyboard navigation
completely stops working, until mouse-clicking into the gray page or elsewhere.

I do not think that this is only a minor bug.  It really should be fixed, as it
is very annoying.

Updated

14 years ago
OS: Windows XP → All

Comment 10

14 years ago
Felix: sounds like you're hitting bug 223675, which is Linux-specific.  Ctrl+Tab
is broken for failed pages on all platforms, but other shortcuts like Ctrl+W are
only broken on Linux.

Comment 11

14 years ago
Another way to reproduce the problem (or is it another problem):

1. Open some page in a tab
2. Open another tab with the URL http://serber.chsc.dk/misc/ctrltab/
3. Notice that CTRL+TAB does not work, but only when that tab is active
4. Wait 30 seconds.
5. Notice that CTRL+TAB now works again.

http://serber.chsc.dk/misc/ctrltab/ is a regular HTML page, that includes a
stylesheet file. The stylesheet is actually a PHP file that sleeps for 30
seconds before outputting anything.

If you access http://serber.chsc.dk/misc/ctrltab/sleep.php?seconds=30 directly,
CTRL+TAB still works. In other words, if an include file is loading slowly,
CTRL+TAB gets disabled until the include file is loaded. This is the case with
both external stylesheets and Javascript includes.

Comment 12

14 years ago
Adding blocking1.0? - I experience this bug several times a day.

Very annoying if you open a lot of tabs in the background - when you cycle
through the tabs to get to the one that completes loading first, you may get
stuck at a tab that loads slowly.
Flags: blocking1.0?
Keywords: testcase
Flags: blocking1.0? → blocking1.0+
Assignee: hyatt → bugs
Severity: minor → normal
Priority: -- → P2
Target Milestone: --- → Firefox1.0beta
Assignee: bugs → sspitzer
Flags: blocking-aviary1.0RC1+
(Assignee)

Comment 13

13 years ago
-> me
Assignee: sspitzer → firefox
(Assignee)

Comment 14

13 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 15

13 years ago
WFM in a current branch build
Status: RESOLVED → VERIFIED
Keywords: fixed-aviary1.0

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.