Page doesn't display correctly the first time. Clicking on any link, then clicking the back button gives a correct display

VERIFIED DUPLICATE of bug 219220

Status

()

VERIFIED DUPLICATE of bug 219220
15 years ago
15 years ago

People

(Reporter: phil, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031107 Debian/1.5-3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031107 Debian/1.5-3

The list of products is cut off at the bottom of the screen, and should continue
downwards, but no scrollbar appears to allow the user to scroll the screen.
Following a link and then hitting Back, or resizing the mozilla window, seems to 
fix the problem & the whole page is rendered together with the necessary scrollbar.

I suspect the list is being built dynamically & Mozilla isn't spotting that
the rendered page is now longer that the screen height & is therefore
failing to provide the scrollbar to allow the user to view the rest of the
page.

The full redraw can also be triggered by resizing the mozilla window.

Reproducible: Always

Steps to Reproduce:
1. Load link
http://www.dabs.com/uk/templates/Channels/ProductResults/ProductResults1.aspx?NRMODE=Published&NRORIGINALURL=%2fuk%2fchannels%2fhardware%2fmodemsandadslhardware%2fproducts%2ehtm%3fcatid%3d128&NRNODEGUID=%7bCADF940B-BC90-40CC-9610-2BD0131A3336%7d&NRCACHEHINT=Guest&catid=128
(or any other dabs list of products)
3. Observe that the list is cut off at the bottom of the page, yet no
scrollbar appears
4. click on a link.
5. After that page has loaded, click Back.
6. Observe that the list of products is now correctly displayed with a scrollbar
on the RHS.

Actual Results:  
Correct display of the page

Expected Results:  
Displayed the full list the first time.

Comment 1

15 years ago
*** Bug 230680 has been marked as a duplicate of this bug. ***
Assignee: parser → nobody
Component: HTML: Parser → Layout
QA Contact: core.layout
*** Bug 218705 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
I see this also on LInux 200401808

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 219220 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Comment 6

15 years ago
*** Bug 246479 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.