Closed Bug 230693 Opened 20 years ago Closed 19 years ago

Missing reload within view source window

Categories

(Toolkit :: View Source, enhancement)

enhancement
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.8final

People

(Reporter: whimboo, Assigned: bugzilla.mozilla.org-3)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

Starting page reload inside view-source window doesn't work. If I have opened
the source window within a new tab I can reload with shift+ctrl+r only. Ctrl+r
seams to load the data from cache. If I have a separate window I can't start any
reload with this two combinations.

Always fixed for Seamonkey (Bug 85908) but missing for Firebird.
-> QA
QA Contact: bugzilla
-> view source.
Assignee: p_ch → bugs
Component: General → View Source
QA Contact: bugzilla → firefox.view-source
*** Bug 256229 has been marked as a duplicate of this bug. ***
*** Bug 258389 has been marked as a duplicate of this bug. ***
*** Bug 263108 has been marked as a duplicate of this bug. ***
Severity: normal → enhancement
This adds four different shortcut keys to the reload function: Ctrl+R,
Ctrl+Shift+R, F5 and Ctrl+F5.

In a regular browser Ctrl+R and F5 do a reload from cache and Ctrl+Shift+R and
Ctrl+F5 do a force reload from network. In view source reloading from cache
doesn't make much sense (or am I missing something), so I hooked up all four
keys to force reload.

I added Reload to the View menu. I don't know if this bloats the UI too much.

I renamed BrowserReload() to ViewSourceReload(). The former name was chosen in
xpfe so that the function could be called by an overlay used by both view
source and the regular browser, but there doesn't seem to be such an overlay in
toolkit.
Attachment #180265 - Flags: review?(mconnor)
Attached patch New patchSplinter Review
Attachment #180266 - Flags: review?(mconnor)
Attachment #180265 - Flags: review?(mconnor)
Attachment #180265 - Attachment is obsolete: true
Comment on attachment 180266 [details] [diff] [review]
New patch

diff -up8 is a goodness.  Regardless of that, r=me.
Attachment #180266 - Flags: review?(mconnor) → review+
Thanks for the review. Could you (or somebody else) check this in for me?
Mike, could you help me getting this checked in? I don't have CVS access myself.
Thanks :-)
Assignee: bugs → bugzilla.mozilla.org
Hardware: PC → All
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox1.1
Version: unspecified → Trunk
(In reply to comment #10)
> Mike, could you help me getting this checked in? I don't have CVS access myself.

I am not sure that mconnor got that message, since he is not cc:ed

Mike, could you help me getting this checked in? I don't have CVS access myself.
Thanks :-)
Attachment #180266 - Flags: approval-aviary1.1a2?
Comment on attachment 180266 [details] [diff] [review]
New patch

a=shaver
Attachment #180266 - Flags: approval-aviary1.1a2? → approval-aviary1.1a2+
Checking in toolkit/locales/en-US/chrome/global/viewSource.dtd;
/cvsroot/mozilla/toolkit/locales/en-US/chrome/global/viewSource.dtd,v  <-- 
viewSource.dtd
new revision: 1.4; previous revision: 1.3
done
Checking in toolkit/components/viewsource/content/viewSource.js;
/cvsroot/mozilla/toolkit/components/viewsource/content/viewSource.js,v  <-- 
viewSource.js
new revision: 1.13; previous revision: 1.12
done
Checking in toolkit/components/viewsource/content/viewSource.xul;
/cvsroot/mozilla/toolkit/components/viewsource/content/viewSource.xul,v  <-- 
viewSource.xul
new revision: 1.22; previous revision: 1.21
done
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
There are still some shortcut issues to fix for that part. Therefor I filed bug
299683.

v.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.