Open Bug 23207 Opened 21 years ago Updated 4 years ago

Options in Save As (location of saved images, choice of filenames)

Categories

(Firefox :: File Handling, enhancement, P5)

x86
Windows 98
enhancement

Tracking

()

People

(Reporter: webmaster33, Unassigned)

References

Details

Save as... feature should be extended in following ways:
1) Save only the current file e.g. filename.html (this is feature currently used
in Netscape)

2) Save page with all files including graphics, javascript files, java classes
 2.a(option1): the graphics & other files should be placed in same as the
selected directory
 2.a(option2):  or to create a directory for it with name: file_name_files
 2.b(option1): to use file name as filename
 2.b(option2):  or to use Page Title as filename
Severity: normal → enhancement
Assignee: nobody → shuang
Component: Browser-General → UE/UI
Priority: P3 → P5
Summary: Save as... extented features suggestions → [enh] Save as... extented features suggestions
More Wish List thoughts for your pile...
yes this is probably wish list for now. assign it to german to take a look for 
later. 
Assignee: shuang → german
Target Milestone: M20
*** Bug 26366 has been marked as a duplicate of this bug. ***
Summary: [enh] Save as... extented features suggestions → Save as... extented features suggestions
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback
Bug 11632 was opened on this issue, and is ASSIGNED to a C.S. class 
project ... last heard from in 1999 10.

This is a feature of IE5 (& possibly IE4), where the UI is a choice between
"Web page, complete" and "Web page, HTML only" in the "Type" part of the dialog.
The former seems to be the default. Marking as 4xp for that reason.

To accomplish this in a useful way, relative URLs need to be adjusted in the
same way that composer uses so that the ancillary files downloaded
are actually used.

As pointed out in bug 25756, "[RFE] Enhanced `file-> save as'", with XML,
keeping stylesheets for saved pages is no longer optional, unless one
wants to pretend that Mozilla is a teletype that doesn't know what to do
with carriage returns.
Keywords: 4xp
Summary: Save as... extented features suggestions → Save as... extended features suggestions (images, stylesheets, etc, with page)
QA Contact: nobody → mpt
Thankyou, sidr ...


*** This bug has been marked as a duplicate of 11632 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
Verified dupe
Status: RESOLVED → VERIFIED
Keywords: verifyme
Depends on: 82118
I created a tracking (meta) bug 82118 to track these kinds of bugs and to unify
the efforts.

Maybe a few duplicates will also become aparent this way - then we can assign
the keyword MostFreq.
Removing dependancy to bug 82118 as it should be the other way round (bug 82118
depends on this bug).
No longer depends on: 82118
Blocks: 82118
Did you mention my file naming suggestions as options of Save as...?:
 2.b(option1): to use file name as filename (Original filename)
or
 2.b(option2): to use Page Title as filename (Page Title)

This feature is still missing, so I reopened the bug. Or would be better to post
a new bug with the above suggestions?

My opinion is, that someone wants the original file name to save, and someone
want the page title as file name to save. Therefore I suggest an option a
choosable with radio buttons.
Is it possible to place radio buttons or click button to switch between options?

Example for Save Page as... choosable naming feature:
File name: ___________________
(o) Original filename (o) Page Title

Keep up the good job!
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Summary: Save as... extended features suggestions (images, stylesheets, etc, with page) → Save as... extended features suggestions (images, stylesheets, etc, with page) + options to choose original filename or Page Title as filename
.
Assignee: german → law
Status: REOPENED → NEW
Component: User Interface Design → File Handling
QA Contact: mpt → sairuh
You may also check my Comment #150 in the bug 115176.
I worked out a complete suggestion for the Save as ... file naming feature.
I do not know yet, if it was implemented in v1.2 or not.
What about a new feature: "Save link under default name"?
No context menu item necessary, just add a keyboard shortcut (i.e.
ctrl+shift+leftclick) which would work just like shift-click (save as...) just
assuming the user clicks "OK" without changing anything in the file requester -
so the user is never asked for the file name.
Useful, if you i.e. want to download a large collection of images or documents
linked from a page. By the first file you select target directory as usually
(shift-click) and then just shift-ctrl-click on all the rest, in order, adding
them to download manager queue and saving them to the target directory without
any additional questions from the browser side.

(or should I submit this as a separate bug?)
*** Bug 172317 has been marked as a duplicate of this bug. ***
I decided to also post my reworked suggestion here into my original bug.
It was posted into related bugs bug 115176 #150, bug 173982 #4, and now here 
in bug 23207.

I worked out a complete suggestion for the Save as ... file naming feature, and 
I feel it would be THE almost complete solution for the problem.

The solution would be very easy. It's unnecessary to argue if we need <title> or
original file name or other kind of formats. 
LET THE USER CHOOSE, what he/she wants as Save as... filename, we just predefine
some typical filenames for the user.

Solution:
We just need a downdrop menu in Save as window, where we list those file name
variants, what users would mostly like (and/or was setup in the Preferences
options).
Of course the user could change these predefined filename types.
The default file naming option should be also configured in the Preferences.

If we think about the problem, we will see, we would be need something like a 
template system for the filenames. I would recommend ASP-like template tags, 
like <%this_is_a_tag%>. In the Preferences we could create filename templates, 
and we could add as many predefined filename template types as we would like.

Some interesting predefined template tags could be added, like:
- <%original%>  - original file name (without extension)
- <%ext%>    - extension of original file name
- <%Page_Title%>   - full Page Title of the page we want to save (chars must be 
converted to allowed filename chars)
- <%Link_Text%>   - text on the link, which was clicked using e.g. Save Link
Target As...
- <%Path_translated%>.html  - so saving from URL
http://www.codeweavers.com/technology/wine/download.php, would be translated to 
www_codeweavers_com_technology_wine_download_php.html filename. The full URL, in
one name (incorrect characters are converted to valid characters).
- <%counter%> - this will be a counter which will increase if there is already
the same filename with numbering. 
E.g. <%original%>_<%counter%>.<%ext%>. So if we have file_2.zip, it will 
suggest file_3.zip.
- <%yyyy%> - year (like 2002)
- <%mm%> - month (like 04)
- <%dd%> - day (like 21)
- <%TT%> - time hour (like 08)
- <%MM%> - time minute (like 53)
For the time related tags, we could also use the standard C time formatting
characters like <%Y%> (like in strftime), to represent the year as decimal
number (for example: 1989), etc.

Some template formats of the most common types, which was discussed:
1) <%original%>.<%ext%>   => original file name format, what is used in Netscape
v4.x
2) <%Page_Title%>.html   => format used to save using page title in Internet 
Explorer (CodeWeavers - Technology - Wine - Download.html if we use the example 
URL used above)
3) <%Link_Text%>.html   => get text of link, if was clicked using Save Link
Target As...
4) <%original%>_<%yyyy%>-<%mm%>-<%dd%>_<%HH%>-<%MM%>.<%ext%>  => this will result
the format: filename_2002-06-12_16-46.html
5) If we have a cgi generated page (we have parameters in the URL, so at least 
a `?' character), the <%Page_Title%>.html can be suggested.

Templates above can be added, deleted, modified in Preferences/Navigator/Save_as,
or Preferences/Navigator/Downloads.
One type of them can be selected as default type (<%original%>.<%ext%> could be 
the default type).
Also we could assign default templates to several extensions, like 
<%Page_Title%>.html for the .cgi .pl .dll types. <%original%>.<%ext%> could
be also assigned to .zip .tar .gz .rar .r?? .arj, etc.
These predefined file name types, could be selected by the user from the 
downdrop menu in the Save as... window.

Example: on following page after clicking Save as:
http://www.codeweavers.com/technology/wine/download.php
In the downdrop menu, we could have the following predefined names:
1) download.php.html (much better just download.html if possible) - (using
template: <%original%>.<%ext%>)
2) CodeWeavers - Technology - Wine - Download.html - (using template:
<%Page_Title%>.html)
3) screenshots.html - if we clicked using Save Link Target As... on the 
screenshots menu item - (using template: <%Link_Text%>.html)
4) download_2.html - if download.html already exists - (using template:
<%original%>_<%counter%>.<%ext%>)
5) download_2002-10-14_10-46.html - (using template:
<%original%>_<%yyyy%>-<%mm%>-<%dd%>_<%HH%>-<%MM%>.<%ext%>)

The bottom line is: 
- we define several filename types, 
- we assign some template based filename types for several extensions,
- user can furthermore choose from several predefined filenames.

I not just hope, but I'm sure this solution would solve most filenaming problems 
and would satisfy almost everybody's needs, because it is as flexible and 
configurable as possible.

Best regards,
Webmaster33
Sorry from those, who got disturbed by my multiple comments. 
My 2nd post was required, because I reworked my original suggestion.
Well, the 3rd one was not needed, but I posted it to my thread
which I started right for such problems...

Sorry if my double post was disturbing...
QA Contact: sairuh → petersen
*** Bug 177285 has been marked as a duplicate of this bug. ***
Summary: Save as... extended features suggestions (images, stylesheets, etc, with page) + options to choose original filename or Page Title as filename → Options in Save As (location of saved images, choice of filenames)
what is the current status on this?
Assignee: law → nobody
QA Contact: chrispetersen → file-handling
Product: Core → Firefox
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.