"File a bug about them" link after editing a page on Doctor doesn't work

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
--
minor
RESOLVED FIXED
14 years ago
7 years ago

People

(Reporter: Ian Graham, Assigned: justdave)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

See steps below:  

Reproducible: Always
Steps to Reproduce:
Precondition:  Make sure you are logged out from Bugzilla, so that you will need
to login again to access.

1.  Select to edit a Bugzilla.org page (e.g.
http://doctor.mozilla.org/?file=mozilla-org/html/community/developer-forums.html ) 
2. Make changes, and press the 'Review results" button
3. On the review page (http://doctor.mozilla.org/doctor.cgi) press the 
   'file a bug about them' link (as I don't have CVS permissions).
4.  YOu now see the bugzilla login page. If you login and proceed, the bug entry
fails, complaining about the data passed to it.

This bug does not occur if you are already logged into bugzilla (and can bypass
the login page).  Workaround is to just back up an try again -- it will work, as
you're now properly logged in.
Ian: which bug form do you normally get when you file a new bug?  The guided one
that steps you through the steps to reproduce and expected results and so forth?
 If so, this is a regression from the Bugzilla upgrade.  We had a local hack to
make it work that probably got lost when we upgraded Bugzilla.
Blocks: 231927
Component: webmaster@mozilla.org → Server Operations
QA Contact: stolenclover → myk
Summary: "File a bug about them" link doesn't work if not already logged into Bugzilla → "File a bug about them" link doesn't work if not already logged into Bugzilla
(Reporter)

Comment 2

14 years ago
I usually go in via the bugzilla helper (it's just easier/faster, and I can
always re-set things later if something is mis-assigned).  So it sounds as if
this is probably a regression. Unfortunatley adding spam bugs seemed a bad way
to test it out :-O
Assignee: endico → myk
Is this still broken?  I thought there was a hack put in (on the Bugzilla end)
to work around this now...
yeah, it's still broken, and broken worse now.  Now it's broken if you're logged
in, too.  Complains that the format "default" doesn't exist.
Blocks: 274366
Component: Server Operations → Bugzilla: Other b.m.o Issues
Summary: "File a bug about them" link doesn't work if not already logged into Bugzilla → "File a bug about them" link after editing a page on Doctor doesn't work
Created attachment 168600 [details] [diff] [review]
force guided entry hack

Here's the original patch that forces the guided bug entry on people that don't
have canconfirm privs...
Assignee: myk → justdave
Status: NEW → ASSIGNED
Which is supposed to allow it to override the guided mode with the normal one if
you pass &format=__default__

However, it's now generating an error that "default" doesn't exist, and I don't
know why.  Can anyone help? :)

Comment 7

14 years ago
Hi,
Can we leave it the way it is?
I like the Advanced form better.
It works for me.
*** Bug 274898 has been marked as a duplicate of this bug. ***
*** Bug 278084 has been marked as a duplicate of this bug. ***
Created attachment 171321 [details] [diff] [review]
Fixed force guided entry hack

Problem was that GerFormat() uses CGI methods to retrieve CGI parameters and
your hack uses and modifies only the deprecated %FORM hash. This new patch uses
CGI methods. I briefly tested it locally and it seems to do the trick.
Thanks, Teemu!

This has been applied to b.m.o, and it seems to work!

This should also force folks without canconfirm into the guided entry page as well.
No longer blocks: 231927
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
*** Bug 274466 has been marked as a duplicate of this bug. ***
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.