Last Comment Bug 234680 - Uninstall should give the option to remove profile data
: Uninstall should give the option to remove profile data
Status: RESOLVED DUPLICATE of bug 398434
: privacy
Product: Firefox
Classification: Client Software
Component: Installer (show other bugs)
: unspecified
: All All
: -- enhancement with 33 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 301526 323788 323825 323893 329096 330884 351904 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-17 10:22 PST by thinksimilar
Modified: 2008-05-01 02:12 PDT (History)
30 users (show)
chofmann: blocking‑aviary1.0-
chofmann: blocking‑aviary1.0-
benjamin: blocking‑aviary1.5-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description thinksimilar 2004-02-17 10:22:10 PST
User-Agent:       
Build Identifier: Firefox 0.8

When uninstalling Firefox, preferences and previously-downloaded skins and components are still 
saved, even after selecting yes to "Are you sure you want to completely remove Mozilla Firefox (.8) 
and all of its components?" and "Not all files were uninstalled from the installation directory: 
C:\Program Files\Mozilla Firefox\ Do you want to completely delete this directory?"

Reproducible: Always
Steps to Reproduce:
1. Install Firefox 0.8, add new skins and change various user preferences.
2. Uninstall Firefox, selecting "yes" when asked if one wants to completely remove everything.
3. After uninstalling, completely remove /Documents and Settings/User/Application Data/Mozilla 
and /Program Files/[Firefox Directory]
4. Restart
5. Reinstall Firefox in either the same directory as before OR a new one
6. Run Firefox
Actual Results:  
Found old skins and preferences still present.

Expected Results:  
Removed all saved preferences and skins, giving me a fresh installation.
Comment 1 Bill Mason 2004-02-17 10:37:08 PST
That information is stored in your profile, not in the Firefox install directory.

If you don't want that stuff with a fresh install, start a new profile.
Comment 2 thinksimilar 2004-02-17 17:47:46 PST
Shouldn't there at least be an uninstaller option to remove such information for
people who either want a clean wipe of all of that info (since the text of the
uninstaller implies that it's removing EVERTHING) or people who, Allah forbid,
don't plan to use the application again and want every trace of it gone?

(In reply to comment #1)
> That information is stored in your profile, not in the Firefox install directory.
> 
> If you don't want that stuff with a fresh install, start a new profile.

Comment 3 Simon Paquet [:sipaq] 2004-03-04 05:51:37 PST
Re-summarizing per comment 2.
Confirming for developer review.
Comment 4 MechCommanderRei 2004-07-19 15:26:14 PDT
I believe that, as an issue of honesty and good PR on an individual-user 
basis, the uninstaller should ask the user whether they want to delete the 
profile (probably briefly explaining what it contains). Leaving it behind 
takes up HD space, and confuses/scares/PO's the heck out of people who try and 
fail to fix profile-based bugs by uninstall-reinstall.
Comment 5 Jeff Walden [:Waldo] (remove +bmo to email) 2004-08-16 19:49:19 PDT
If the user uninstalls to delete his personal data, it's a privacy issue.
Comment 6 privacy 2004-08-17 06:55:17 PDT
Uninstaller should also remove old Firefox <0.8 profile directory /Documents and
Settings/User/Application Data/phoenix as if I remember correctly 0.9.x
installer doesn't remove old Phoenix profiles after copying.


Comment 7 Daniel Ross 2004-10-07 18:47:56 PDT
I believe this should block. The reason for this is, a very large majority of
Firefox issues boil down to "uninstall, delete your profile, and start afresh."
However, deleting your profile is a very scary process; you have to go into
areas of your hard drive that Windows usually keeps well hidden from you, often
using %code-y looking variables%, and then manually delete something. This
scares base users stiff.

It would be an ENORMOUS help to those of us who will be providing technical
support for the hoarde of new users we expect at 1.0 if this process could be
simplified and de-scarified by rendering it down to a checkbox in the uninstall
dialogue. I would go as far as to say it would drastically reduce the number of
users who will decide "Firefox is buggy, back to IE" the first time something
goes wrong. 
Comment 8 Daniel Ross 2004-10-07 18:48:16 PDT
I believe this should block. The reason for this is, a very large majority of
Firefox issues boil down to "uninstall, delete your profile, and start afresh."
However, deleting your profile is a very scary process; you have to go into
areas of your hard drive that Windows usually keeps well hidden from you, often
using %code-y looking variables%, and then manually delete something. This
scares base users stiff.

It would be an ENORMOUS help to those of us who will be providing technical
support for the hoarde of new users we expect at 1.0 if this process could be
simplified and de-scarified by rendering it down to a checkbox in the uninstall
dialogue. I would go as far as to say it would drastically reduce the number of
users who will decide "Firefox is buggy, back to IE" the first time something
goes wrong. 
Comment 9 Daniel Ross 2004-10-07 18:49:18 PDT
Gah, sorry for the bugspam, had a rollicking Bugzilla error AND accidentally +ed
instead of ?ing.
Comment 10 Radek 'sysKin' Czyz 2004-10-07 19:14:33 PDT
I fully support blocking flag.
It's common sense that any application cleans after itself. Moreover, Firefox is
an application that requireas a "clean start" from time to time (sad fact but a
fact) and just about everyone will assume that it can be done by
uninstall/reinstall. Another fact which you might not like (you might want users
to know about %appdata%), but still a fact.

Removal of profile manager shortcut from installation makes this bug much more
importnat, since right now, there is completely no way to create a new profile
using any UI - hell, there is no indication that profiles exist at all.

Doesn't seem to be much work either, by the way.
Comment 11 chris hofmann 2004-10-11 20:31:55 PDT
we have always errored on the side of not removing data in cases where the user
might not understand the impact of checking a "remove your user profile?" check
box.   I'd think we would need to make this kind of change in a beta release
where we could get testing and feedback.  An independent utility could be built
that would find and destroy firefox profiles and that program could eventually
be integrated into the installer. some of the old seamonkey profile clean up
code might be a place to start.  any volenteers?
Comment 12 Worcester12345 2004-10-13 13:59:34 PDT
target milestone?
Comment 13 Jeff Walden [:Waldo] (remove +bmo to email) 2004-10-13 14:25:58 PDT
(In reply to comment #12)
> target milestone?

Target milestone is set when a developer decides he's going to fix it, assigns
the bug to himself (marks it ASSIGNED), and then sets it.  Ben hasn't marked
this ASSIGNED yet, so the target milestone isn't yet set.

Please don't spam.
Comment 14 Martin Gregory 2004-10-13 15:07:09 PDT
I don't think the person was asking "what target milestone has been set?"

Blind Freddy can see that it's not set yet.

I think that they were asking "What does Ben (or his delegate) have in mind for
this bug?  Will it be assigned soon because it will be fixed in the next
release, or will it sit unassigned for longer 'cause it's not a priority?".

I didn't find this question to be SPAM.   I signed up to this bug because I'm
interested in what other people are interested in it as well.   If someone else
is wondering what Ben's priority for this bug is, that's interesting information
for me too ... it back's up my nagging feeling of "is this one going to be
assigned?".

Comment 15 Aaron P 2004-10-13 20:24:50 PDT
For reference, here is a semi-related (non-dup) bug 264209 - "Installer should
provide options if an old profile is found". 
Comment 16 Hypnotoad86 2005-05-17 16:17:05 PDT
I recently installed a nightly trunk to see what is coming soon in the next
versions (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050516 Firefox/1.0+).  This replaced the general 1.0.3 version I was
using before.  I wanted to uninstall the nightly trunk and revert to official
1.0.4 when I noticed it was released.

Now whenever I load older versions of firefox, i get an about:blank browser
screen and cannot use the browser in any way.  I feel this is related to the
above bug.
Comment 17 Aaron P 2005-06-24 10:30:28 PDT
To stick with existing behavior, this field should probably default to
unchecked. This is due to the fact that many users glaze over any options when
(un)installing software, and it is better to be safe than sorry when it comes to
dataloss.

A. The simplest form of this checkbox would be: 
"Uninstall profile [ ]"

However, I believe that the "profile" is an ambiguous term for many users and
needs to be explained. 

B. Something like this would be better:
"Remove profile settings (including bookmarks, themes, and extensions) [ ]"

C. Another option is to use a simple phrase on the checkbox, but have a small
paragraph below that checkbox explaining what a profile is and when it
should/n't be removed. Unfortunately, statements like this are usually ignored
by users and generally clutter the UI more than anything else.
Comment 18 Worcester12345 2005-06-24 13:51:18 PDT
(In reply to comment #17)

> B. Something like this would be better:
> "Remove profile settings (including bookmarks, themes, and extensions) [ ]"


How about:
"Remove:
bookmarks[ ]
themes[ ]
extensions[ ]"
Comment 19 Jaime Mitchell (use bugmail@jaimem.org.uk for email) 2005-07-21 08:42:18 PDT
*** Bug 301526 has been marked as a duplicate of this bug. ***
Comment 20 VanillaMozilla 2005-09-02 13:14:52 PDT
(In reply to comment #18)
> How about:
> "Remove:
> bookmarks[ ]
> themes[ ]
> extensions[ ]"

Right.  And don't forget about passwords and other user data.  What about
prefs.js and user.js?  

You have to target the deletion or you will have an even bigger problem.  You
can't just go removing the whole profile, including bookmarks, or you will have
a repeat of the bookmarks debacle, only much worse.

Also, don't forget that this could delete user files, possibly leading to
catastrophic data loss.  See bug 302087.  How about combining this fix with bug
278230 (which is about Profile Manager deleting user files, and which should be
reopened)?  If you carefully target the deletions, this will automatically
protect users.

This bug fix would solve an enormous number of user support problems.  It's been
open 1 1/2 years.  I don't understand why it's not blocking.
Comment 21 flock31070 2005-11-21 14:56:44 PST
Flock does this...
Comment 22 privacy 2005-12-03 15:05:36 PST
> You have to target the deletion or you will have an even bigger problem.  You
> can't just go removing the whole profile, including bookmarks, or you willhave
> a repeat of the bookmarks debacle, only much worse.

I think that the take all or nothing approach would be better.
You want to delete the profile:
a)When you stop using Firefox and don't want to leave stuff floating around.
b)The profile is screwed up, In this case, there is no point to try target every deletion. But if you want to do targeted deletion then options to save Bookmarks and passwords should be enough.

I would like to see something like this:

--Mozilla Firefox Uninstaller-------------------
|                                              | 
| |-Profile Deletion-------------------------| |   
| |                                          | |  
| | Profile contains following information:  | |
| | Bookmarks, History, Form Information,    | |
| | Passwords, Cookies, Cache, Extensions,   | |
| | Themes and Preferences.                  | |
| |                                          | |
| |  Make sure that you have backed up       | |
| |  any information you wish to retain      | |       
| |  before you delete profile!              | |  
| |                                          | |
| |  Available Profiles       Last Accessed  | |
| | |--------------------------------------| | |
| | |Administrator/Profile#1  Date         | | |
| | |WinUser1/Profile#1       Date         | | |
| | |winUser1/Profile#2       Date         | | |  
| | |                                      | | |
| | |--------------------------------------| | | 
| |                                          | |
| |                                 [Delete] | | 
| |                                          | |
| |------------------------------------------| |
|                                              |
|                                       [Next] |
-----------------------------------------------|

---------------------------------------------------------------------
| Are you sure you want completely delete selected Firefox Profiles |
| (Bookmarks, History, Form Information, Passwords,                 |  
| ,Cookies Cache, Extensions, Themes ,Preferences)                  |
|                        [Yes] [No]                                 |
---------------------------------------------------------------------
Comment 23 Dave Townsend [:mossop] 2006-01-18 04:29:02 PST
*** Bug 323825 has been marked as a duplicate of this bug. ***
Comment 24 Dave Townsend [:mossop] 2006-01-18 05:38:17 PST
*** Bug 323788 has been marked as a duplicate of this bug. ***
Comment 25 Dave Townsend [:mossop] 2006-01-18 07:42:20 PST
*** Bug 323893 has been marked as a duplicate of this bug. ***
Comment 26 Dave Townsend [:mossop] 2006-01-18 07:49:37 PST
Had a quick look through this and a few key questions aren't answered here. Should this option remove all profiles or just the current? And what about other users on the system, quite often the user uninstalling firefox may well not be able to access their profiles making it impossible to remove them.
Comment 27 Steve England [:stevee] 2006-03-02 06:38:53 PST
*** Bug 329096 has been marked as a duplicate of this bug. ***
Comment 28 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2006-03-02 06:51:42 PST
I've been thinking about this and I don't think it's a good idea. The installer didn't create the profile, so the uninstaller shouldn't remove it. Besides which removing the current user's profile(s) means that the activity of the uninstaller is non-determinite. WONTFIX.
Comment 29 elfguy 2006-03-02 14:58:44 PST
Adding a checkbox (that's off by default) to the uninstaller that deletes the profiles directory can't possibly be a huge development job, yet would solve so many support issues. So many people get issues with Firefox and the first thing they try or are even told to do is uninstall / reinstall, yet the vast majority of cases this solves nothing because the issue is in the profile, and it's a pain for anyone to figure out where the profile is and delete it. I don't see why this would be not implemented on technical reasons.
Comment 30 Worcester12345 2006-03-03 07:16:00 PST
(In reply to comment #29)
> Adding a checkbox (that's off by default) to the uninstaller that deletes the
> profiles directory can't possibly be a huge development job, yet would solve so
> many support issues. So many people get issues with Firefox and the first thing
> they try or are even told to do is uninstall / reinstall, yet the vast majority
> of cases this solves nothing because the issue is in the profile, and it's a
> pain for anyone to figure out where the profile is and delete it. I don't see
> why this would be not implemented on technical reasons.
> 
I have suggested in the past that there should be a profile verifying utility to make sure everything is proper. Whether this utility be part of the program or a standalone item is up for question. There is no doubt that profile corruption is an issue, and not many can answer the question of what a proper profile should look like.
Comment 31 Jesse Ruderman 2006-03-21 17:19:29 PST
*** Bug 330884 has been marked as a duplicate of this bug. ***
Comment 32 Simon Bünzli 2006-03-21 20:34:13 PST
How can this bug be blocking Firefox 2 and WONTFIX?

(In reply to comment #28)
> I've been thinking about this and I don't think it's a good idea. The installer
> didn't create the profile, so the uninstaller shouldn't remove it. Besides
> which removing the current user's profile(s) means that the activity of the
> uninstaller is non-determinite. WONTFIX.

"non-determinite"? Sure the installer didn't create the profile. Sure there could be more than one profile. Sure they could be in diverse locations. Sure there could be profiles under other user accounts.

But, as I've already said in bug 258301 comment #12: we should give the user the option to do a clean uninstallation. Leaving about 50 MB of cached data behind isn't really nice (what if every application did this)?

Of course this shouldn't happen per default, but what are you going to suggest to a user wanting a CLEAN reinstallation? To find a folder which is per default nicely hidden by Windows Explorer and delete that folder by hand? [annoyed] What again do we have an uninstaller for? [/annoyed]

I kindly ask to discuss this issue in the newsgroups before WONTFIXING this bug again.
Comment 33 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2006-03-22 04:25:54 PST
Feel free to open a thread on mozilla.dev.apps.firefox. I am willing to spend time listening to arguments there, though I haven't seen anything yet that overrides my concerns for a determinite installer, as well as providing a checkbox that users might click thinking it does something it doesn't do.

The uninstaller is primarily there to uninstall the application. It is not there to uninstall user data. For the moment I will stick by my module-owner decision. Please do not reopen this bug.
Comment 34 Jonadab the Unsightly One (Nathan Eady) 2006-03-22 04:33:50 PST
> Leaving about 50 MB of cached data behind isn't really nice 
> (what if every application did this)?

In Windows, most applications do leave any personal data behind on uninstall.  Microsoft Office, for instance, does.  In fact, I cannot think of a single major Windows application that on uninstall goes through and cleans all that out.  It wouldn't even be (directly) possible to do so if some users had used the "make my files private" checkbox.

On Unix, there is no single uninstall paradigm across different distributions, but for those with which I'm familiar (rpm, ports and packages, deb, portage), it is not normal for any user data or even configuration data (in /etc) to be removed when the application is uninstalled.  The general thinking is that if you ever install again the users will want such things.

In summary, it is NOT normal for application uninstallers to remove personal data from user accounts.

Cleaning out just the profile of the _current_ user (the one doing the uninstall) would only make sense on systems where the user normally runs things like web browsers all the time with the same privileges required to do the uninstall, cheifly, Win95/98/Me.  (Okay, some users on *nix and many on WinXP run as root/admin all the time (I do so myself at home), but this is *widely* disrecommended, for good reasons, and Firefox should not actively encourage it.)  Those systems have all entered (or gone past) the twilight of Extended Support, so it seems silly to do something just for them now.

For the uninstaller, I don't think it makes sense to do any more than _perhaps_ include a paragraph someplace, explaining that users might still have profile data in their accounts.

However, as far as the Firefox user support issue, Firefox *should* provide an easy way for the current user to delete the current user's own profiles, and it *should* be accessible when Firefox is started with the -safe-mode switch, as well as when it's started normally.  I would suggest opening a separate bug for that, and referencing the number here, because I don't think it belongs in the uninstaller component.
Comment 35 nullmailbox 2006-03-22 07:01:55 PST
The fact is, she is 100% correct, after reading the article I went to my Windows 2000 Pro machine and went to tools > Options > Passwords > View Saved Passwords > Passwords Never Saved and there were a list of sites that I did not want passwords saved for. I then chose Clear Private Data and went back into the password manager. The list was still there. Lastly, I created a new user account, went into Password manager; guess what…the list was still there. Not only is the list not cleared with private data, it is also shared between user accounts on the same machine.
Comment 36 Greg Campbell 2006-03-22 09:03:23 PST
A better proposition would probably be this:

1. Uninstall application; profile remains.
2. Reinstall application.
3. First run for each user: application detects existing profile(s); gives user option of using the old profile or starting fresh.

Probably should open a new bug for this one (or find one that already exists).
Comment 37 Worcester12345 2006-03-22 10:55:09 PST
(In reply to comment #36)
> A better proposition would probably be this:
> 
> 1. Uninstall application; profile remains.
> 2. Reinstall application.
> 3. First run for each user: application detects existing profile(s); gives user
> option of using the old profile or starting fresh.
> 
> Probably should open a new bug for this one (or find one that already exists).
> 


Don't forget that when first installing, it creates the profile FOR YOU!
Comment 38 Mihai Bazon 2006-03-28 11:59:18 PST
I think this is not an uninstaller problem, but not an installer problem either (see bug #264209).

I think Firefox/Mozilla should simply check the profile when started and detect if the last time that profile was used it was with an older browser version, in which case the end-user should be provided with these options:

1: remove the old profile and create a brand new one, or
2: backup (copy?) the old profile and try to use it with the new version
Comment 39 Worcester12345 2006-05-30 13:59:48 PDT
How and why did this one go from blocking 2.0 to a wont fix? 
Comment 40 Joey Minta 2006-09-12 13:37:23 PDT
*** Bug 351904 has been marked as a duplicate of this bug. ***
Comment 41 Hermann Schwab 2006-12-18 12:50:12 PST
(In reply to comment #39)
> How and why did this one go from blocking 2.0 to a wont fix? 

https://bugzilla.mozilla.org/show_activity.cgi?id=234680
View Bug Activity: comment 28 and comment 33

Comment 42 Worcester12345 2007-02-13 09:28:11 PST
comment 28 says it doesn't create the profile for you...


It doesn't?
Comment 43 Majken Connor [:Kensie] 2007-08-20 21:06:13 PDT
^^ I believe the app creates a profile on first run, if one doesn't already exist.
Comment 44 Worcester12345 2007-10-16 07:21:03 PDT
Maybe Mozilla Corporation should make a profile tool for this and other purposes such as profile creation, deletion, confirmation/fixing, etc.
Comment 45 AndrewM 2007-12-05 10:03:42 PST
This has actually been FIXED in bug 398434, shouldn't this bug be duped to that one?
Comment 46 Jaime Mitchell (use bugmail@jaimem.org.uk for email) 2007-12-15 12:35:09 PST

*** This bug has been marked as a duplicate of bug 398434 ***

Note You need to log in before you can comment on or make changes to this bug.