Auto-mark as read when replying

RESOLVED DUPLICATE of bug 534853

Status

--
enhancement
RESOLVED DUPLICATE of bug 534853
15 years ago
9 years ago

People

(Reporter: manuel.schmitt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 7.23  [de]
Build Identifier: 0.5 20040326

I would appreciate a feature as follows:

When replying to emails you see in the preview-window and when replying, the 
message should be auto-marked as read.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Errm- if you want to reply to a message, you'll need to select it anyway. And
unless you have set a very high value for "Mark message read after x seconds",
the message will get marked read very soon (in most cases, sooner than you can
write a complete reply). Or did I misunderstand anything?

Comment 2

15 years ago
No response yet. Please give further information or I will resolve this bug as
worksforme in, say, 30 days.
(Reporter)

Comment 3

15 years ago
Sorry, forgot the topic.

Yes and no, you partially misunderstand something ;) When having that option
you're referring activated ("Mark message read after x seconds"), then
everything should be fine.

But in many situations, you do not have this option activated (in order to
prevent that mails get marked as read occasionally). Then users would like to
see that emails that have been replied or forwarded (which is a sign for that
the email was actually read) will become auto-marked-as-read. I think an
additional option in preferences for that would be fine and should not be too
much difficult to implement, or am I wrong?

Comment 4

14 years ago
The desired behavior described by Manuel is how several other MUAs work and is
therefore expected behavior, in addition to being nice.

Comment 5

14 years ago
(In reply to comment #4)
> The desired behavior described by Manuel is how several other MUAs work and is
> therefore expected behavior, in addition to being nice.

Agreed.

Comment 6

13 years ago
*** Bug 323757 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PC → All
Summary: ENHANCEMENT: Auto-mark as read when replying → Auto-mark as read when replying
Version: unspecified → Trunk
QA Contact: preferences

Comment 7

12 years ago
Anyway, if, because that's the way you want it, you work without the preview pane, then when you select mail in the thread pane and click 'reply', you don't actually show it except in the edit window. Then, although it has been replied, and therefore read (in the edit window), it is not marked as read. After a user who does this pointed it out in Mozine Thunderbird support, I realised there should at least be an option or preference (default=true?) to mark replied mail as read.

I don't think this is comparable with Ctrl-U to read the source.

What about auto-reply by filter and template? I don't think I'd do it in that case since it hasn't been read but I assume (haven't tried it) that it is marked as 'replied'. However, if distinguishing that situation was too tricky but the user had an option/pref then they would at least be able to choose which way to jump.

Comment 8

12 years ago
I agree this is an important feature.

I like to set it so it doesn't mark them as read until I specifically do so or reply to the message.
Duplicate of this bug: 394094

Comment 10

12 years ago
The actual behaviour means that if I see a message I want to reply to, I click
on Reply, but then I have to go back later (if I remember) to the proper
message list, locate the message (if I can find it), and manually set it as
Read. It's annoying. Having a way to mark it as read as soon as I hit Reply
would make me much more productive. 

I fully understand that there should be scenarios where marking automatically a
reply as read is undesirable, but I can 100% guarantee that this feature is
very valuable. If it is made available as an option configurable somewhere,
even if it is hidden, it is okey for me, as far as there are means to achieve
this thing.

Comment 11

12 years ago
Another nice feature (related to this) would be to automatically close the message window if the message we are replying to has been open previously. 

Should I open another request for feature for this? Or is it possible to do it now (or with an add-on)? I couldn't find it proposed. 

Comment 12

12 years ago
I created a workaround using the add-on Mouse Gestures. I created Javascript custom gestures to do the Mark as Read and the Reply / Reply All at once. 

But again, I'd think this should be an option (as closing the open message if it is open when replying). 

thanks,
Duplicate of this bug: 416086

Comment 14

11 years ago
My 2 cents: I can't see why somebody is opposing to such an obvious feature. Currently, this feature is missing and 99% of users is getting the negative effect. I have set the "mark as read" delay to 900 seconds because I don't want my messages to be marked as read if I have not read them, but still I have to manually mark them as read after replying to each message. It's indeed something that the software should do for me. Try managing 40-60 emails per day, you'll see how much useful the feature could have been. You usually first read and the  n reply, but when you are following a thread you directly hit reply. It's one of those small bits that make you stand up happy from the chair, and not frustrated.

I propose that a message is marked as read if the editing session (in editor window) ends up in a "Save message" operation or in a "Send message" operation.

In my opinion there shouldn't even be an option for this, as it is a MUA expected behaviour. But I can understand that in order to preserve the current behaviour the new correct one could be implemented as an option.

Sorry for the angry comment, just tried to show the user's point of view
Assignee: mscott → nobody

Comment 15

11 years ago
I also think that this would be a good option.

I user the preview pane to glance at messages, but I've set the mark message as read option to 18000 seconds so that it doesn't mark it as read if I just leave it to deal with it later.

Often I will reply from the preview pane and I think that it's wrong that I then have to go back and mark it as read after replying.
Duplicate of this bug: 521811

Comment 17

9 years ago
I hope someone fixes this bug!
It makes it easier to get Outlook users to change to Thunderbird.

Comment 18

9 years ago
This is one of the most annoying issues an ex-Outlook user (me!) faces.

Comment 19

9 years ago
For the record, there is an add-on for that. 

I use Change Quote and Reply Format 0.6.4 which not only marks messages as read after replying to them, but also is able to close the message window after hitting reply. Nice. And on top of it, it is able to put a proper heading to the reply (sender, recipients, date, CCs). 

With this add-on (and a couple of others) I was able to do anything I did in Outlook (so long ago) and much more. Happy camper here. Anyway, I still think that these basic features should be part of the product, not add-ons.

Comment 20

9 years ago
ChangeQuote is pretty nice - it will also let you reply in the same format as the original message - plaintext > plaintext, html > html.

And I agree, most of these features should be core code - but then again, flexibility is the main reason I'm using Mozilla products in the first place...

:)
Duplicate of this bug: 504251
bug 534853 already has a patch, so duping forward
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 534853
You need to log in before you can comment on or make changes to this bug.