Email tooltip when headers completely collapsed is not working

RESOLVED DUPLICATE of bug 251279

Status

--
minor
RESOLVED DUPLICATE of bug 251279
15 years ago
5 years ago

People

(Reporter: wd, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040425 Firefox/0.8
Build Identifier: version 0.6b (20040426)

When hovering the mouse over a newsgroup poster's name, a tooltip should appear
displaying the poster's email address.    This is no longer working.

Reproducible: Always
Steps to Reproduce:
1.Read a newsgroup message
2.Collapse the headers, so it just shows Subject: From: and Date
3.Hover mouse over poster's email address

Actual Results:  
no tooltip

Expected Results:  
tooltip with poster's email address displayed

This appears to only appear with Thunderbird builds.   I have tried the
equivalent Mozilla builds (both trunk and branch), and the tooltips display
properly.

Also, this is limited to Newsgroup messages.   The very same tooltip works fine
for email messages.

Comment 1

15 years ago
Still occuring in the 0.6 release and on Linux as well.  OS should be changed to
ALL.
(Reporter)

Updated

15 years ago
OS: Windows 2000 → All

Comment 2

15 years ago
Tooltips worked fine for me with TB0.5/Windows/Email, but in 0.6 they no longer
work. Windowa 2000 SP4.

Comment 3

14 years ago
See bug 279290 -- in 1.0, at least, the From: addresses are not being shown as 
"only display names" (if that preference is turned on); the pref only applies to 
the To: -- and in Newsgroups, there are no "To" headers.

The tooltip is only supposed to display if the mail address is not shown in the 
header.  

Reporter (WD), does this correspond to what you're seeing?
(Reporter)

Comment 4

14 years ago
I'm not sure what you mean.   I think my original report pretty clearly
describes the issue.

Comment 5

14 years ago
I meant:
1) you don't expect a tooltip on the Newsgroup header, do you?
2) is the displayed From: header a full header -- WD <wd@pobox.com> -- or is it
   a compact one -- WD -- and, if it's the former, why do you expect a tooltip?
   Tooltips are only supposed to be shown for compact headers.

As it turns out, bug 279290 has been marked WontFix because the From: header is 
not *supposed* to be compacted, "by design."  Therefore, there should not be a 
tooltip.

Comment 6

14 years ago
(In reply to comment #5)
> I meant:
> 1) you don't expect a tooltip on the Newsgroup header, do you?
> 2) is the displayed From: header a full header -- WD <wd@pobox.com> -- or is it 
>    a compact one -- WD -- and, if it's the former, why do you expect a tooltip?
>    Tooltips are only supposed to be shown for compact headers.
> 
> As it turns out, bug 279290 has been marked WontFix because the From: header is 
> not *supposed* to be compacted, "by design."  Therefore, there should not be a 
> tooltip.

Then there realy is a bug.  It is that COMPACTING is taking place. By opening
the header pane I see a big difference in the display of FROM: were the full
display is <display name> sendername@somewhere.not while the closed pane said
FROM: display name.

That to me fits your declaration of compacting and violates the  "WontFix
because the From: header is not *supposed* to be compacted, *by design.*" 

Comment 7

14 years ago
(In reply to comment #6)
> Then there realy is a bug.  It is that COMPACTING is taking place. By opening
> the header pane I see a big difference in the display of FROM: were the full
> display is <display name> sendername@somewhere.not while the closed pane said
> FROM: display name.

By "closed pane", you mean when the envelope panel is collapsed (aka "brief 
headers")?  Yes, a message displayed with brief headers compacts the From: 
address -- AND, I see a tooltip for that compacted address.  So: still no bug.

If you are seeing a compacted From: header when the envelope panel is *not* 
collapsed, check the source of the message and verify that the From: header 
actually contains an email address.

Comment 8

14 years ago
(In reply to comment #7)
> (In reply to comment #6)
> > Then there realy is a bug.  It is that COMPACTING is taking place. By opening
> > the header pane I see a big difference in the display of FROM: were the full
> > display is <display name> sendername@somewhere.not while the closed pane said
> > FROM: display name.
> 
> By "closed pane", you mean when the envelope panel is collapsed (aka "brief 
> headers")?  Yes, a message displayed with brief headers compacts the From: 
> address -- AND, I see a tooltip for that compacted address.  So: still no bug.
This is still a bug for me.

I never see an email address show up in a tooltip when hovering over the "From"
link.

When viewing an email (either in the preview pane or in a separate window), I
have the headers "collapsed".  i.e. I see the Subject, From and Time on a single
line above the message.  Hovering over the From link, never shows a tooltip with
their email address.  Never.  The sender does have a valid email address.  While
this isn't specific to this bug, if the sender does NOT have an email address,
then maybe the tooltip should show "No email address" or something similar.

Thunderbird 1.0.2 (Windows & Linux)
(Reporter)

Comment 9

14 years ago
> So: still no bug.

This absolutely *is* a bug.   Re-read the original report.

- Mozilla behaves properly...  this is Thunderbird-specific.
- It is a regression that occurred sometime between Thunderbird 0.5 and 0.6b.

Comment 10

14 years ago
changing summary - this has nothing to do with news per se - it has to do with
the collapsed header mode. I agree that this works in mozilla.
Summary: Email tooltip for newsgroup / NNTP messages is not working → Email tooltip when headers completely collapsed is not working

Comment 11

13 years ago

*** This bug has been marked as a duplicate of 251279 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.