Delete key does not delete messages on MAC

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
14 years ago
7 years ago

People

(Reporter: Cameron Smith, Assigned: Bienvenu)

Tracking

({fixed1.8.1, verified1.8.1.3})

unspecified
PowerPC
Mac OS X
fixed1.8.1, verified1.8.1.3
Dependency tree / graph
Bug Flags:
blocking-thunderbird2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040505 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040505 Camino/0.7+

See summary.  Clicking the delete icon in the toolbar works, but pressing the
delete key does nothing.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Updated

14 years ago
Whiteboard: dupme

Comment 1

14 years ago
Hmm... the backspace key (which says 'delete' on the mac keyboard) works, but
the delete key (next to the home and end key) doesn't work.  This is
inconsistent with Apple mail.  Is this the intended behaviour?

Comment 2

14 years ago
The delete key didn't work on Linux but now it does on the v0.7+ 20040731 nightly.

Please close this bug if it is fixed on the Mac.

Comment 3

14 years ago
This is Seamonkey bug 57510 -- Scott, is that the bug you wanted this duped to, 
or could the fix be TB-only?

Comment 4

14 years ago
I don't remember anymore if that's the bug I was thinking of :)

Comment 5

14 years ago
*** Bug 259299 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

13 years ago
I have this bug too, running version 1.0 under XP. The 0.9 version perfectly.
Now when I download emails then want to delete a couple, I can't. I have to
close Thunderbird, start it then I can delete. I'm not sure if this happens
under Linux, I have to try it out this week.

Comment 7

13 years ago
Just to reinforce this one. I cannot delete messages from my mailbox using the
key marked 'Delete' on my keyboard (this is the one grouped with Insert, Home,
End etc.) the 'Backspace' key works fine.

This is with Thunderbird version 1.0 (20041206)

I'm using a Logitech 'Elite' USB keyboard plugged into a Mac Mini running OS X
(10.3.8) all of the other normal keys seem to work fine in the Mac context.

All in all, I prefer T-bird to Mail. I can't wait for the next version.

BY

Comment 8

13 years ago
For as long as I can remember, the "del" key next to 'home' and 'end' has never
deleted messages in Mozilla for the Mac.  What's odd is that the del key does
delete bookmarks in the Bookmark Manager, but the 'delete' key doesn't.

So I can verify that this problem still exists with Mozilla 1.7.5 on OS X 10.3.8.

Comment 9

13 years ago
Windows 2k pro sp4 ande all patches.  TB 1.0.5.  If i hold down the delete key
and hold it down..only about 10 messages get deleted then the delete operation
simply stops.  This issue is NOT present in seamonkey.  I can hold down delete
in a folder of 500 items and it iwll delete all of them..thunderbird will not.
(Assignee)

Comment 10

13 years ago
William, have you tried a Thunderbird 1.1a build? Several bugs in this area have
been fixed. Re mac issues, that sounds like a toolkit issue.

Comment 11

13 years ago
No I have not...but i will once it is released GA.

Comment 12

13 years ago
I just gave 1.1a2 (Version 1.0+ 20050712) a whirl on Mac OS 10.3 and it does not
fix this bug.
(Assignee)

Comment 13

13 years ago
is your bug "If i hold down the delete key and hold it down..only about 10
messages get deleted..." or just that the delete key isn't bound to the delete
operation? I don't know anything about the latter, but some bugs that might have
caused the former have been fixed.

Comment 14

13 years ago
(In reply to comment #13)
> is your bug "If i hold down the delete key and hold it down..only about 10
> messages get deleted..." or just that the delete key isn't bound to the delete
> operation? I don't know anything about the latter, but some bugs that might have
> caused the former have been fixed.the delete operation only repeats for about
10 messages when the delete key is held down..then it simply quots.

Comment 15

13 years ago
Message #12
>> I just gave 1.1a2 (Version 1.0+ 20050712) a
>> whirl on Mac OS 10.3 and it does not
>> fix this bug.

Message #13
> is your bug "If i hold down the delete
> key and hold it down..only about 10
> messages get deleted..." or just that
> the delete key isn't bound to the delete
> operation? I don't know anything about
> the latter, but some bugs that might have
> caused the former have been fixed.


I only tested the original bug...that the delete key doesn't delete messages. 
The other bug (deleting ~10 messages) was tacked on in comment #9 should really
be treated as a different bug.  I did not test if that is resolved.

Comment 16

13 years ago
mscott - dup to bug 57510?

(In reply to comment #14)
> (In reply to comment #13)
> > is your bug "If i hold down the delete key and hold it down..only about 10
> > messages get deleted..." or just that the delete key isn't bound to the delete
> > operation? I don't know anything about the latter, but some bugs that might have
> > caused the former have been fixed.the delete operation only repeats for about
> 10 messages when the delete key is held down..then it simply quots.

see Bug 265343  (happens to me at the second quick delete)


another weird mac delete bug - Bug 242723

Updated

13 years ago
Summary: Delete key does not delete messages → Delete key does not delete messages on MAC

Comment 17

12 years ago
*** Bug 328863 has been marked as a duplicate of this bug. ***

Comment 18

12 years ago
sorry about posting a dupe bug.  I can confirm this on new Intel Mac, thunderbird 1.5.0.1, OS X 10.4.5.  The 'backspace' delete key works, but the 'delete' key next to the 'end' key does not work.

I also tried the 'unofficial' universal binary for Thunderbird (1.5.0.2) and that has the same problem.

Comment 19

12 years ago
Note that there is a patch in progress for this problem, for the suite, 
at bug 57510.

Comment 20

12 years ago
The Seamonkey patch I believe is trunk-only (will be in SM 1.5).  Patch author stated the patch was Seamonkey-only, so it needs to be ported to get to TB.
(Assignee)

Comment 21

12 years ago
I'll try to get to this for TB.
Assignee: mscott → bienvenu

Comment 22

12 years ago
I just Switched to Mac last week (Intel Mac Mini with 10.4.6) and Swedish Apple Wirered Keyboard. The first annoyance I found related to MacOS was that I now needed to delete emails i TB (1.5.0.4) by pressing the <DELETE> rather than pressing the delete button (The one below the help button).
Today I googled and found out that emails is delete by pressing the Backspace button, I don't see the logic in that, since the <DELETE> button works both in The Windozeee and Linux version.

This Bug need some immediate love by you guys, with hopes to see a fix in 1.5.0.5 :D

Best Regards
Patrik

Comment 23

12 years ago
Scott and David, this is killing me. Any chance you can get this in for 2.0?
Flags: blocking-thunderbird2?

Comment 24

12 years ago
If there's been no progress since comment #21, please let me know and I'll go ahead and give porting over the Suite patch a go. Just switched to Thunderbird on the Mac this morning, and WOW, this bug is a huge usability oversight... gotta get this fixed.

Comment 25

12 years ago
Tim, thanks!!!!!
(Assignee)

Comment 26

12 years ago
Tim, that would be great. This fell off my radar, unfortunately.

Comment 27

12 years ago
Tim can you work on this? Thanks!
Flags: blocking-thunderbird2? → blocking-thunderbird2+

Comment 28

12 years ago
Created attachment 238082 [details] [diff] [review]
First crack at porting the suite patch over to thunderbird

Please keep in mind that I'm not too knowledgeable about the inner workings of Thunderbird, and this patch was mainly just an attempt to try to port over what had already been done on the Suite side of things. That said, there were several discrepancies that hopefully have been accounted for in the proper files. I've compiled my own build with this patch for PPC 10.4, and it seems to work fine. At the very least, hopefully this can be a jumping off point for someone more experienced to pick-up from.
Attachment #238082 - Flags: review?(bienvenu)
(Assignee)

Comment 29

12 years ago
Comment on attachment 238082 [details] [diff] [review]
First crack at porting the suite patch over to thunderbird

thx very much, Tim. This looks good. I'll try it on my Mac just to be sure, and then check it in if there are no problems.
Attachment #238082 - Flags: review?(bienvenu) → review+
(Assignee)

Comment 30

12 years ago
fixed on trunk and branch - Asa, can you try tomorrow's build and verify that the delete key works for you now? Thx! And thx again to Tim. 
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Comment 31

12 years ago
this patch broke shift-delete on windows, see:

http://forums.mozillazine.org/viewtopic.php?t=463069&sid=a487ab6a58f6f70e87d774e4c6e2e507

It also caused a regression in the compose window on the branch so adding that bug as a dependency.
Depends on: 352527
(Assignee)

Comment 32

12 years ago
re shift delete, I'm not sure, but I think the issue is that TB doesn't seem to be using the platformMailnewsOverlay.xul files it defines - I couldn't find references to them in the jar files.
(Assignee)

Comment 33

12 years ago
Created attachment 238225 [details] [diff] [review]
fix shift delete regression

not sure this doesn't regress the original bug, but I don't think it will.
Attachment #238225 - Flags: superreview?(mscott)
(Assignee)

Comment 34

12 years ago
Tim, can you make sure this most recent patch doesn't break the original fix on the Mac? I just backed out the mailWindowOverlay.xul changes because they depend on files we don't use...

Comment 35

12 years ago
I'll check it out. It'll take about 30 mins to recompile.
(Assignee)

Comment 36

12 years ago
you just need to rebuild from mozilla/mail - no real recompile needed :-)

Comment 37

12 years ago
Comment on attachment 238225 [details] [diff] [review]
fix shift delete regression

This patch broke the fix for the Delete key on the Mac.
Attachment #238225 - Flags: superreview?(mscott) → superreview-

Comment 38

12 years ago
Created attachment 238255 [details] [diff] [review]
Should fix regression (I hope) as well as keep fix for Delete key

David, unfortunately that patch caused the Delete key to stop working. I've taken the general "idea" of the one you created and I think successfully made it so that the regression will still be taken care of. I've tested this on mine and Delete and Shift+Delete work fine like my original. Don't have a means of compiling a windows build though, so I'm unsure as to whether or not the regression is 100% taken care of.

Thanks.
Attachment #238225 - Attachment is obsolete: true
Attachment #238255 - Flags: review?(bienvenu)
(Assignee)

Comment 39

12 years ago
thx, Tim, I'll try this out on Windows as soon as I can after I finish debugging some pop3 code.
(Assignee)

Comment 40

12 years ago
Comment on attachment 238255 [details] [diff] [review]
Should fix regression (I hope) as well as keep fix for Delete key

yup, works for me on windows, thx. I'll try it on 2.0 as well...
Attachment #238255 - Flags: review?(bienvenu) → review+
(Assignee)

Comment 41

12 years ago
Comment on attachment 238255 [details] [diff] [review]
Should fix regression (I hope) as well as keep fix for Delete key

yup, works for me on windows, thx. I'll try it on 2.0 as well...
(Assignee)

Comment 42

12 years ago
ok, I landed Tim's patch on the trunk and branch.

Updated

12 years ago
Depends on: 355169
verified fixed on the branch using the Tbird candidate build, version 2.0.0.0 (20070326). Adding branch verified keyword. Verified on a PPC mac running 10.4.9.
Keywords: verified1.8.1.3

Comment 44

11 years ago
What about SeaMonkey?  Bug 57510 is for the "suite", and it was fixed in June 2006, but I'm using SeaMonkey 1.1 and it's not fixed. What is the equivalent to this bug for SeaMonkey?

Updated

10 years ago
Duplicate of this bug: 242723
You need to log in before you can comment on or make changes to this bug.