all navigation keys (tab, arrows, enter) delete messages in advanced search results

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: wsmwk, Assigned: Bienvenu)

Tracking

(4 keywords)

Trunk
x86
Windows XP
dataloss, fixed1.8.1, regression, verified1.8.1.3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
1. advanced search, choose folder with several messages you don't care about, like trash
2. search for subject " "
3. click any message
4. hit any navigation key

message deleted

after step 4
5. click in subject search input area
6. hit any navication key

message deleted

reproducible: always

20060911 works fine
fails:
version 3 alpha 1 (20060926)
version 3 alpha 1 (20061002)
(Assignee)

Comment 1

12 years ago
It would be really interesting if the 9/18 build worked, and the 9/19 build didn't - then the fix for bug 350030 would be a likely suspect.
(Assignee)

Comment 2

12 years ago
this broke from checkins on 9/12 - the 9/12 build works, the 9/13 build is broken.   The leading suspect would be this patch that I checked in - https://bugzilla.mozilla.org/show_bug.cgi?id=242864

Updated

12 years ago
Blocks: 242864
Keywords: regression
(Assignee)

Comment 3

12 years ago
Created attachment 241011 [details] [diff] [review]
proposed fix

I don't know why if you can't indent #ifdefs, you don't get syntax errors, but this seems to fix the problem.
Assignee: mscott → bienvenu
Status: NEW → ASSIGNED
Attachment #241011 - Flags: superreview?(mscott)

Comment 4

12 years ago
Comment on attachment 241011 [details] [diff] [review]
proposed fix

yeah, you can't have white space before (or after for that matter) a xul pre-processor define. I've never thought to understand why :).
Attachment #241011 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 5

12 years ago
Comment on attachment 241011 [details] [diff] [review]
proposed fix

Arrow keys worked before this fix (they're only used to navigated radio buttons).

This same problem exists in the 1.8.1 branch: bug 348263.
Attachment #241011 - Flags: approval1.8.1?

Updated

12 years ago
Summary: all nagivation keys (tab, arrows, enter) delete messages in advanced search results → all navigation keys (tab, arrows, enter) delete messages in advanced search results
(Assignee)

Comment 6

12 years ago
the 1.8.1 branch doesn't have this exact problem (cursor keys don't delete messages) but it does have the whitespace issue, so I'll check the fix in for that.
(Assignee)

Comment 7

12 years ago
fix checked in on 1.8.1 branch 
Keywords: fixed1.8.1

Comment 8

12 years ago
Comment on attachment 241011 [details] [diff] [review]
proposed fix

this is fixed on the 1.8.1 branch already. Clearing the 1.8.1 approval flag.
Attachment #241011 - Flags: approval1.8.1? → approval-thunderbird2+

Comment 9

12 years ago
*** Bug 353477 has been marked as a duplicate of this bug. ***
verified using a Windows Thunderbird candidate build, version 2.0.0.0 (20070326). I followed the STR in Wayne's initial report, and no emails were deleted. Adding keyword.
Keywords: verified1.8.1.3
You need to log in before you can comment on or make changes to this bug.