Remove Expand/Collapse UI (was: Bookmark contextmenu should not have "expand" when right clicking on folders)

RESOLVED FIXED in Firefox1.5

Status

()

Firefox
Bookmarks & History
P2
normal
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: José Jeria, Assigned: mano)

Tracking

({fixed1.8, useless-UI})

unspecified
Firefox1.5
fixed1.8, useless-UI
Points:
---
Bug Flags:
blocking-aviary1.0 -
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

14 years ago
On the bookmark menu, the option "Expand" in the contextmenu doesnt make sence
on folders, since folders are expanded automatically. Suite bug 86649 is a bit
like this one, but for folders on the personal toolbar.

Steps to reproduce:
1. Click on the Bookmarks menu
2. Right click a folder
3. Option "Expand" is available even though the folder is expanded automatically

Comment 1

14 years ago
--> All/All
--> minor
Severity: normal → minor
OS: Windows XP → All
Hardware: PC → All
it doesn't for me... extensions?
ohhh, bah. never mind, bookmarks menu, not toolbar menus

Comment 4

14 years ago
Same thing happens when you right click on a folder on the Bookmarks Toolbar.
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> Same thing happens when you right click on a folder on the Bookmarks Toolbar.

That would be Bug 232649.

Comment 6

14 years ago
In this case, also "Open" that is shown when right-clicking a bookmark (not a
bookmark folder) should be removed, since this can be done by a simple left click!

Comment 7

14 years ago
(In reply to comment #0)
"since folders are expanded automatically".

Note that open folders can be closed by a click on the right cursor key.
But I agree that they are not needed because they can be opened again with a
click on the left mouse button.
Also "Open" that is shown in the right-click menu of bookmarks (not bookmarks
folder) is not needed.


Further on "Expand", "Collapse" and "Open" are shown in the right-click menus of
the Bookmarks Manager and the Bookmarks frame.
But there these items are also not needed, because there is the +/- icon to open
and close folders and links can be opened with a (or a double?) left click.

So I think "Expand", "Collapse" and "Open" should also be removed there!

Comment 8

14 years ago
(In reply to comment #7)
> (In reply to comment #0)
> "since folders are expanded automatically".
> Note that open folders can be closed by a click on the right cursor key.
> But I agree that they are not needed because they can be opened again with a
> click on the left mouse button.
> Also "Open" that is shown in the right-click menu of bookmarks (not bookmarks
> folder) is not needed.
> Further on "Expand", "Collapse" and "Open" are shown in the right-click 
menus of
> the Bookmarks Manager and the Bookmarks frame.
> But there these items are also not needed, because there is the +/- icon to 
open
> and close folders and links can be opened with a (or a double?) left click.
> So I think "Expand", "Collapse" and "Open" should also be removed there!


There is one distinct difference here between the Expand and Collapse options 
and the Open option.  The Open option works, while the Expand and Collapse 
options don't.  This could be an argument to leave the Open option.  It is an 
important difference.  Besides, to remove any confusion from people moving 
from IE to Firefox, it should be left there.

I still think Expand and Collapse should be removed, because not only are they 
redundant, but they are non-functional when used along with the default 
behavior of the browser (which is to AUTOMATICALLY Expand and Collapse).

I can't think of any reason for leaving them in by default, though there MIGHT 
be some LEGACY reasoning to leave them in the program code, just in case 
someone wants to call their functionality within an extension.

Comment 9

14 years ago
(In reply to comment #8)

> The Open option works, while the Expand and Collapse 
> options don't.  This could be an argument to leave the Open option.  It is an 
> important difference.  Besides, to remove any confusion from people moving 
> from IE to Firefox, it should be left there.

I think users who are intelligent enough to switch to Firefox don't have any
problems with such redundant menu items ...

I think there are 2 solutions:

1. remove "Open", "Expand" and "Collapse"
or
2. make "Expand" and "Collapse" working

Every other solution would be inconsequent:
If it's possible to open links but not expand folders that contain links with
the context menu, it would be inconsequent...

Comment 10

14 years ago
(In reply to comment #7)

With "frame" I mean sidebar, sorry.

Comment 11

14 years ago
Before worrying about context menu, please make the Bookmarks manager in
Windows, work correctly, with the basic Windows ingredients:
1. Left panel and right panel should be coordinated, like in any file manager:
when you click on a folder on the left panel it should be brought up on the
first line of the right panel.
2. The left panel is supposed (my guess) to display only with folders, not leafs
(bookmarks): when there are no subfolders, there should be no +- icon attached
to the folder.
3. Only when this works correctly, take care of the context menus if necessary,
but not before.

Comment 12

14 years ago
(In reply to comment #11)
> Before worrying about context menu, please make the Bookmarks manager in
> Windows, work correctly, with the basic Windows ingredients:

I think the bookmarks manager is comfortable enough. It's not as often used as a
file-manager!

(So I think correct context menus should have higher priority. In my oppionen
the basic structure of the bookmarks manager is OK.)

Comment 13

14 years ago
This needs to be fixed (it used to work, and it seems like it does open but then
immediately closes the menu) or removed. High-visibility UI that doesn't work is
the kind of thing we should clean up for 1.0
Flags: blocking-aviary1.0?
Keywords: useless-UI

Comment 14

14 years ago
-> vlad

Vlad, I talked this over with Asa and we agreed that we should leave
Expand/Collapse in the bookmarks manager and in the sidebar context menus (where
it works, and where it's mildly more useful...it's standard on windows to have
the default action in the ctxt menu, for accessibility reasons), but to remove
it from the bookmarks toolbar context menu.
Assignee: p_ch → vladimir
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Priority: -- → P4
Bookmarks toolbar and also bookmarks menu context menus, right?
Status: NEW → ASSIGNED

Comment 16

14 years ago
(In reply to comment #15)
> Bookmarks toolbar and also bookmarks menu context menus, right?

Sure. I think both context menus should be kept equal. And in both context menus
collapse and expand do not work.
Created attachment 155041 [details] [diff] [review]
bookmarks-ctx-hide-useless-items-0.patch

Hides the Expand and possibly Open items, if the popup node is a something that
we think is either a menu or toolbar item.
Why is it in the sidebar/tree for "accessibility reasons" ? ... the sidebar/tree
lists are trees, so standard keyboard navigation and access tool apis apply... 

If we remove it from one place, we should remove it from all, especially if the
function is going to be broken (makes for easier testing). 
(In reply to comment #18)
> Why is it in the sidebar/tree for "accessibility reasons" ? ... the sidebar/tree
> lists are trees, so standard keyboard navigation and access tool apis apply... 
> 
> If we remove it from one place, we should remove it from all, especially if the
> function is going to be broken (makes for easier testing). 

It's not broken in the sidebar/tree; it actually does something there (expands
the item).  I agree though, I don't understand what the purpose of having a
right-click expand is; I'd be happy to just nuke it altogether.

Comment 20

14 years ago
p4 priority - not a blocker. if a fully reviewed patch materializes, please
nominate for aviary approval. 
Flags: blocking-aviary1.0+ → blocking-aviary1.0-
*** Bug 262644 has been marked as a duplicate of this bug. ***
should Expand for livemarks (live bookmarks) also be removed? (doesn't seem to
do anything.)
(In reply to comment #22)
> should Expand for livemarks (live bookmarks) also be removed? (doesn't seem to
> do anything.)

This was bug 262644, which was marked duplicate of this bug. So hopefully the
fix to this one will fix both.
*** Bug 268690 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 25

13 years ago
*** Bug 297710 has been marked as a duplicate of this bug. ***
Created attachment 186548 [details] [diff] [review]
Bookmarks (expand only) Patch V1

This patch deals with the Expand/Collapse menu item only, which is what this
bug is about. The Open item should be treated separately, and IMO it doesn't do
any harm.
This eliminates the Expand/Collapse item when right-clicking on any folder
(including live bookmark folders) on the Bookmarks Menu or Bookmarks Toolbar.
We need to remove this UI (expand/collapse) everywhere, for 1.5.
Flags: blocking1.8b5?
Summary: Bookmark contextmenu should not have "expand" when right clicking on folders → Remove Expand/Collapse UI (was: Bookmark contextmenu should not have "expand" when right clicking on folders)
Created attachment 196732 [details] [diff] [review]
patch (no l10n impact)
Assignee: vladimir → bugs.mano
Attachment #155041 - Attachment is obsolete: true
Attachment #186548 - Attachment is obsolete: true
Attachment #196732 - Flags: review?(mconnor)

Updated

13 years ago
Attachment #196732 - Flags: review?(mconnor) → review+
Severity: minor → normal
Priority: P4 → P2
Target Milestone: --- → Firefox1.5
Trunk:
mozilla/browser/components/bookmarks/content/bookmarks.js 1.108
mozilla/browser/components/bookmarks/content/bookmarksManager.xul 1.30
mozilla/browser/components/bookmarks/content/bookmarksPanel.xu 1.20
mozilla/browser/components/bookmarks/content/bookmarksTree.xml 1.69
mozilla/browser/base/content/browser-sets.inc 1.58
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Flags: blocking1.8b5? → blocking1.8b5+

Comment 30

13 years ago
Comment on attachment 196732 [details] [diff] [review]
patch (no l10n impact)

Per bug meeting - approved for 1.8b5 branch.
Attachment #196732 - Flags: approval1.8b5? → approval1.8b5+
1.8 Branch:
mozilla/browser/base/content/browser-sets.inc 1.51.2.7
mozilla/browser/components/bookmarks/content/bookmarks.js 1.104.2.4
mozilla/browser/components/bookmarks/content/bookmarksManager.xul 1.29.4.1
mozilla/browser/components/bookmarks/content/bookmarksPanel.xul 1.18.10.2
mozilla/browser/components/bookmarks/content/bookmarksTree.xml 1.68.2.1
Keywords: fixed1.8

Comment 32

13 years ago
It became inconvenient. It was not possible to edit it though two windows were 
opened. 
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.