Java applet doesn't work properly

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: cleanthes, Assigned: mikepinkerton)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040517 Camino/0.8b
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040517 Camino/0.8b

If you move contact points in the lower panel, the pictures in the upper panel
change.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Confirmed using Camino/2004051715 (v0.8b). It WFM using Mozilla-Mac/1.7b.
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Ever confirmed: true

Comment 2

15 years ago
Confirmed with Camino 2004101808. WFM with Firefox build 20041019 and Mozilla
1.7.3 [Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3)
Gecko/20040910]

In Firefox and Mozilla Suite, mousing over a contact point causes a white circle
to appear, and dragging that point changes the orientation of the letter above it.

Camino does weird things: First, the white circle never appears; second, you
can't drag anything, and third, only the first and fourth screens respond to any
clicking (the only reaction, though, is to flash / redraw the applet).
Like bug 172089, installing a recent version of the Java Embedding Plugin (bug
197813 / http://javaplugin.sourceforge.net/) seems to make this applet behave
properly in Camino (in addition to enabling Java 1.4.x, the JE Plugin's author
has fixed a number of bugs in the old Mozilla plugin).

20041019 (0.8+) nightly, OS X 10.3.5, Apple Java 1.4.2 Update 2

Why the applet works properly in Firefox and Mozilla without JEP is beyond me,
though :)

Comment 4

15 years ago
Confirming that using the Java embed plugin the webpage with the java aplet
works fine.

Using 20041130 NB on 10.3.6 with java embed plugin.

Updated

14 years ago
Blocks: 224615
Fixed by bundling the Java Embedding Plugin with Camino (nightly builds 20050729
and later), bug 301076.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.