Closed Bug 244658 Opened 18 years ago Closed 13 years ago

Cannot use Unicode keyboard layouts in Location Bar in some situations

Categories

(Camino Graveyard :: Location Bar & Autocomplete, defect, P2)

PowerPC
macOS
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bugmail, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: intl)

Attachments

(1 file)

Unicode keyboard layouts such as U.S. Extended and Unicode Hex Input are
disabled when the Location Bar has focus using Camino/0.8b. The layouts are
available when any other part of the application has focus, such as the Search
field or the content pane.

These layouts should be available throughout the app.
Oops, wait a second, this isn't always true by a long shot. Tried this again and
it worked fine.

Here's what I did prior to encountering this condition.

1. Enabled U.S. Extended using the Keyboard Layout menu after launching Camino
2. Typed 'ren stimpy torrent' into the Search field and hit return (yes, now you
know my horrible secret life as a cartoon downloader)
3. Observed the Layout menu icon change back to a U.S. flag; accessed that menu
and noticed U.S. Extended and Unicode Hex Input were disabled.

Couldn't reproduce on subsequent attempts, though. Will keep trying.
Well, there's definitely some sequence of events that disabled Unicode keyboard
layouts. In this screen capture, the content pane has been given focus, and the
layouts are disabled. They remain enabled for the Location Bar and Search
field.
I can't currently reproduce the disabled layout problem with Greg's steps in the
20050117 (0.8+) unofficial NB, 10.3.7.

However, Camino/the search and location fields and the browser window all seem
to have trouble remembering what the selected keyboard layout was...essentially
each keeps resetting to US, although switching back from another Camino window
recalls the correct layout some of the time.  This may be an OS bug, though,
because I find lots of apps seem to forget also. 
Ah, I see the persistent selection bug is bug 152721.  Greg, can you still
reproduce the disabled layouts at all, or should this bug now be closed WFM?
Gah, never mind, I just saw it in the search field.  I have no idea what
sequence of steps produced it, though.  It seems that setting the location field
to US Extended and then switching to the search field leaves the layouts
disabled.  Clicking into the browser window and back into the search field fixes
it until clicking in the location field again.  It seemed not to be doing that
before.

(But now having US Extended selected in one of location/search/browser search
seems to disable the Unicode layouts in the other two).

Just a warning to anyone else: it's really sporadic, so be persistent in
attempts to reproduce.

Sorry for all the noise. :(
*** Bug 244714 has been marked as a duplicate of this bug. ***
It seems that:
1. Cocoa and Gecko have two separate notions of what the current keyboard layout
   is, and
2. the keyboard layout for the content area gets reset sometimes (perhaps gecko
   tries to choose a layout that matches the page charset or something).
3. sometimes the Unicode input layouts get disabled (this always happens when
   I do a google search from the toolbar). Clicking in the content
   re-enables them.
Priority: -- → P2
Target Milestone: --- → Camino1.0
I've just noticed that when you get in the state where the Unicode layouts appear to be disabled, using the keyboard shorcut (cmd-space to toggle the last-used layout, or cmd-opt-space to cycle through all of the layouts) actually lets you select and use your disabled Unicode layout (in some, but not all, cases this will also cause the flag/checkmark to get out of sync with the layout being used.  Fun fun!)
Flags: camino1.0?
Moving the IME bugs to 1.1 :-(
Target Milestone: Camino1.0 → Camino1.1
Flags: camino1.0? → camino1.0-
Moving IME-related bugs to Camino 1.2 :(
Target Milestone: Camino1.1 → Camino1.2
Mass un-setting milestone per 1.6 roadmap.

Filter on RemoveRedonkulousBuglist to remove bugspam.

Developers: if you have a patch in hand for one of these bugs, you may pull the bug back to 1.6 *at that point*.
Target Milestone: Camino1.6 → ---
Duplicate of this bug: 385694
Assignee: mikepinkerton → nobody
QA Contact: location.bar
Summary: Cannot use Unicode keyboard layouts in Location Bar → Cannot use Unicode keyboard layouts in Location Bar in some situations
This also WFM on 10.5, even on branch.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.