POP: Can't recover from an incorrect password

VERIFIED DUPLICATE of bug 26355

Status

P3
major
VERIFIED DUPLICATE of bug 26355
19 years ago
10 years ago

People

(Reporter: morse, Assigned: mscott)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
Go to mail and press get-messages.  Dialog appears asking for password.  Enter
incorrect one.  Second dialog appears reporting the error and asks for password
again.  Enter another password, good or bad, it doesn't matter.  After clicking
ok, the throbber spins forever.  Attempting to close the mail window after
finally giving up results in a crash with the stack trace shown below.

Note that there are really two bugs here.  First is the fact that we couldn't
log in.  Second is the crash if attempting to close a window when the throbber
is throbbing.  I would suggest looking at the second bug first, because once the
first bug is fixed it will not be possible to demonstrate the second one.

Here's the stack trace.

StripeTimer::Notify(nsITimer * 0x02eb6030) line 185 + 13 bytes
TimerImpl::Fire(unsigned long 24665567) line 317
TimerImpl::ProcessTimeouts(unsigned long 24665567) line 191
FireTimeout(HWND__ * 0x00000000, unsigned int 275, unsigned int 22181, unsigned
long 24665567) line 105 + 9 bytes
USER32! 77e712a4()
nsAppShellService::Run(nsAppShellService * const 0x00c9ced0) line 466
main1(int 1, char * * 0x00c24ec0) line 598 + 32 bytes
main(int 1, char * * 0x00c24ec0) line 691 + 13 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77f1ba3c()

Updated

19 years ago
QA Contact: lchiang → esther

Comment 1

19 years ago
POP or IMAP?  For IMAP, we have bug
http://bugzilla.mozilla.org/show_bug.cgi?id=16676.

The crash about closing the window while the throbber is throbbing may be the
same as bug http://bugzilla.mozilla.org/show_bug.cgi?id=24385.

If the canceling is broken on POP, then we should turn this bug into that.
(Reporter)

Comment 2

19 years ago
Nope, it's pop.  Also symptoms are different from what's reported in the imap
case of bug  16676.  In that case you couldn't dismiss the dialog.  I can
dismiss it, I just can't log in.  And I only have the problem if the password I
entered the first time is a bad one (I can log in successfully if I enter a good
password the first time).

As far as the crash, it does sound like 24385.  And here I have a stack trace
which is something that 24385 didn't have.  I'll put a reference in 24385 to see
this trace.
(Reporter)

Updated

19 years ago
Blocks: 7530

Comment 3

19 years ago
since the crash part of this bug looks like it's layout, and not mail news, i
thought it made sense to leave that bug there (even though it's the same
crash).  maybe leave this one here for the login problem.
(Reporter)

Comment 4

19 years ago
I agree.  I put a reference in the crash bug back to this one so that whomever
works on that can see the stack trace.  This bug, however, should deal solely
with the login problem from now on.

Updated

19 years ago
Severity: normal → major
Summary: Can't recover from an incorrect password → POP: Can't recover from an incorrect password

Comment 5

19 years ago
*** Bug 24608 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

19 years ago
Summary: POP: Can't recover from an incorrect password → [beta1] POP: Can't recover from an incorrect password
(Reporter)

Comment 6

19 years ago
Oops, I just realized that I'm supposed to be adding the [beta1] notation to the 
keywords field and not the summary line.  Correcting this.
Keywords: beta1
Summary: [beta1] POP: Can't recover from an incorrect password → POP: Can't recover from an incorrect password
(Assignee)

Updated

19 years ago
Target Milestone: M14

Comment 7

19 years ago
Putting on the PDT+ radar for beta1.
Whiteboard: [PDT+]

Comment 8

19 years ago
*** Bug 25508 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

19 years ago
Turns out jefft had the same bug assigned to him by alecf and he fixed it before
I did.


*** This bug has been marked as a duplicate of 26355 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 10

19 years ago
Marking verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.