Closed Bug 8979 Opened 21 years ago Closed 19 years ago

Broken <input type=image> should get replaced by alt text

Categories

(Core :: Layout, enhancement, P3)

enhancement

Tracking

()

RESOLVED WORKSFORME
Future

People

(Reporter: ian, Assigned: alexsavulov)

References

(Blocks 1 open bug, )

Details

(Keywords: testcase, Whiteboard: [Hixie-P3])

Broken <image type=image> elements should be replaced by their the contents
of their alt attributes, just like broken <img> elements. See bug 1994.
Blocks: html4.01
Depends on: 1994
Whiteboard: [TESTCASE]
I am making this bug dependant on bug 1994 for the alt text generation
algorithm. In other words, this bug is tracking whether broken <input
type=image> elements are inline or replaced, *not* whether they get the
correct alt text.
Assignee: ekrock → pollmann
Eric, this needs to work the same as it does for IMG elements. You and I can
talk about how it works for IMG elements
QA Contact: petersen → py8ieh=bugzilla
[taking over QA Contact since this is an 'alt' related bug]
See also bug 5624.
After careful consideration, I've decided that I probably won't get this bug in
for M12.  Currently I have nearly 50 bugs scheduled for M13, so there is a
possibility that this bug may need to be moved out farther still.
Target Milestone: M13 → M17
Moving to M17. The handling of broken images is a lower priority than almost
everything else on pollmann's plate.
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
Blocks: 24778
Rescheduling
Status: NEW → ASSIGNED
Target Milestone: M17 → M21
Depends on: 34981
As per Eric Krock in bug 40623, nominating nsbeta2, reccomend nsbeta2 6/22. 
Whatever we're going to do for missing images should be in for nsbeta2.
See bug 34981 for a spec. Once Matthew has given it his seal of approval, I 
will attach the final spec to this bug.
Keywords: nsbeta2
Whiteboard: [TESTCASE]
Marking nsbeta2-.
Whiteboard: [nsbeta2-]
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration.
Target Milestone: M21 → Future
Spec is fully given in bug 41924.
Depends on: alttext
Keywords: nsbeta2mozilla1.1
Whiteboard: [nsbeta2-]
Depends on: 75185
No longer depends on: 1994
Whiteboard: [Hixie-P3]
No longer depends on: alttext
Blocks: alttext
I don't know if I should file a new bug on this, but I think the problem is somewhat related...If the imagem in a input field is broken, at least here I am seeing the alt text. But, if I click on the alt text, as if I were clicking on the image, nothing is sent about the input field in the request. If the image is there, the "imageName.x" and "imageName.y" are sent all right.This is not what happens with IE or Konqueror, for instance, where the image input information is sent, even if the image is broken.
Bulk reassigning Eric Pollmann's remaining form submission bugs to Alex.
Assignee: pollmann → alexsavulov
Status: ASSIGNED → NEW
it works for me.

i recall that there was made a fix that fixed ALT text displaying for images
generaly. (m.attinasi knows about that one)

Marking WORKSFORME
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.