bookmark sidebar scroll state is not (session) persistent

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
14 years ago
5 years ago

People

(Reporter: David Reff, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Reopening the Bookmarks Sidebar after closing it returns you to top of Bookmarks
list, instead of to the folder you were last accessing.

Reproducible: Always
Steps to Reproduce:
1. Open the Bookmarks Sidebar.
2. Open a folder at least one screen-height down the list.
3. Click on a Bookmark in that folder.
4. Close the Bookmarks Sidebar.
5. Re-open the Bookmarks Sidebar.

Actual Results:  
You won't be where you were a moment ago -- you'll be back to the top each time.
So you have to manually scroll down to access additional Bookmarks in the same
folder you started in. 

Expected Results:  
Remember where were last time you had the Bookmarks Sidebar open. Which allows
you to access additional Bookmarks in the same folder without scrolling down to
find your spot each time.

No/default theme installed. (I term this a Major Feature because I use and rely
on it constantly during my work day.) 

Great work in general, folks! The tabs are a breath of fresh air. Thank you!
This is by design, so it would be an enhancement request to persist this instead.
Severity: major → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Reopening Bookmarks Sidebar after closing it returns you to top of Bookmarks list → Remember bookmark sidebar state when sidebar is closed
(Reporter)

Comment 2

14 years ago
IE remembers where were last time you had the Favorites sidebar open. Which allows
you to access additional Favorites in the same folder without scrolling down to
find your spot each time.

How is Firefox's approach easier for the user? It seems like a lot more work.
Would it be possible to add a user option whether to manage this the way IE
does, or along Mozilla's lines?

Thanks again!

Comment 3

14 years ago
Actually, it would be fine if Firefox would remember it across the sessions.
The actual behavior is annoying because the last bookmarks (and the most used)
are at the bottom of the sidebar.
It's surprising that nobody has noticed it.
I'm using Windows XP, then I think it applys to all oses.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
Duplicate of this bug: 335815
Summary: Remember bookmark sidebar state when sidebar is closed → Remember bookmark sidebar scroll state when sidebar is closed
still applies to Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020708 Firefox/3.0.0.0 ID:2008020708
Assignee: p_ch → nobody
Component: Bookmarks → Places
OS: Windows 98 → All
QA Contact: bookmarks → places
Summary: Remember bookmark sidebar scroll state when sidebar is closed → bookmark sidebar scroll state is not (session) persistent
Version: unspecified → Trunk

Comment 7

10 years ago
(In reply to comment #1)
> This is by design, so it would be an enhancement request to persist this
> instead.

You are absolutely incorrect in this statement.

This behavior is an obvious regression in the behavior of bookmarks side bar in firefox 2.0.

Before you make statements like this you should think and ask why someone would report as a bug in such detail like this.

I was going to report this as a bug today myself, but I see there is no need.

To any one from mozilla reviewing this, this may seem like a trivial ui regression but in fact with lots of bookmarks in folder hierarchies, this becomes extremely annoying to deal with.

I have put off upgrading because of this bug, but have just done so as support for 2.0 is dropping in a month.

Updated

10 years ago
Duplicate of this bug: 464034

Comment 9

9 years ago
I vote for this, but on my Mac, it would be an enhancement request.  My FF2 sidebar vertical position never showed any persistence.  And I wished for it every time I used it.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks

Updated

9 years ago
Duplicate of this bug: 533952
The front-end team has discussed this, and we will not be working on this enhancement.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.