Firefox -> Quit Firefox (or File -> Exit) does not display confirm dialog when multiple tabs are open.

RESOLVED DUPLICATE of bug 250983

Status

()

RESOLVED DUPLICATE of bug 250983
15 years ago
14 years ago

People

(Reporter: tkh212+bugzilla, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040804 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040804 Firefox/0.9.1+

When quitting Firefox using the "Quit Firefox" option on the Firefox menu (Mac),
or the "Exit" option on the File menu (Windows), it does not confirm that you
want to close windows that have multiple tabs open.

Reproducible: Always
Steps to Reproduce:
1. Open a new Firefox window
2. Open at least two tabs in that window
3. Repeat steps 1 and 2 (optional)
4. Select "Quit Firefox" from the Firefox menu (Mac) or "Exit" from the File
menu (Windows)

Actual Results:  
All open windows (and tabs within those windows) close without a confirmation
dialog.

Expected Results:  
For each open window, Firefox should have shown the confirmation dialog it shows
when closing a window with more than one tab open, asking the user if they
really want to close all of those tabs.

I have tested this in both Mac OS X and Windows.  Build ID for Windows client:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040804 Firefox/0.9.1+

This DOES behave as expected in Seamonkey 1.7.2 (Mozilla/5.0 (Macintosh; U; PPC
Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040803).

This may be related to bug 250983 - "Close Window" (ctrl-shift-w) does not
display confirm dialog when multiple tabs are open.

Comment 1

15 years ago
Reporter, what is your 'browser.tabs.warnOnClose' set to ? You can see it in
about:config . If the preference is true (the default), then you should get the
warning, otherwise not.

Comment 2

15 years ago
(In reply to comment #1)
> Reporter, what is your 'browser.tabs.warnOnClose' set to ? You can see it in
> about:config . If the preference is true (the default), then you should get the
> warning, otherwise not.

I also see this bug, and have browser.tabs.warnOnClose set to true. When closing
via the close buton you get the dialog, but not when you exit the browser via
/File/Exit
(Reporter)

Comment 3

15 years ago
(In reply to comment #1)
> Reporter, what is your 'browser.tabs.warnOnClose' set to ? You can see it in
> about:config . If the preference is true (the default), then you should get the
> warning, otherwise not.

I have browser.tabs.warnOnClose set to true, the default setting.

(In reply to comment #2)
> I also see this bug, and have browser.tabs.warnOnClose set to true. When closing
> via the close buton you get the dialog, but not when you exit the browser via
> /File/Exit

Yes, I forgot to mention that I DO see the warning if I use the close button in
the title bar.  I was very happy to see this feature added as a Windows user,
but on a Macintosh I usually use the Quit function (cmd-Q) to close the app and
its windows (since closing every window of an app doesn't close the app on a
Mac), and I eventually realized it wasn't warning me when I did so.

Comment 4

15 years ago
again, in Mozilla, this works properly - File > Exit presents a warning dialog
if multiple tabs are open.

Bug 241152 is also something to consider..
(Reporter)

Comment 5

15 years ago
I want to emphasize that I especially think this issue is important on Mac's,
because unlike on Windows or Linux, applications stay open on a Mac even after
you close all of their windows.  So, as a shortcut, many people (including
myself) just hit cmd-q (Quit Firefox) where, on Windows or Linux, we normally
would have just closed the window.  Afterall, why close the window and then quit
when you can do both at once?  This is how I originally picked up on this,
because I was mostly using Windows or Linux until about a month ago, and was
used to being warned when closing windows with multiple tabs.  Remember that on
Windows or Linux, closing the window is essentially the same as quitting the
application (if it was the only open window).  In my opinion, the lack of this
warning on cmd-q for a Mac defeats the purpose of having a warning on closing
windows with multiple tabs open.

Comment 6

15 years ago
This problem is exasperated by the fact that cmd-W (close tab) and cmd-Q are
right next to each other. I find myself accidentally closing the whole
application when I just meant to close a single tab.

Comment 7

15 years ago
*** Bug 256356 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
win xp
Both file/close window and file/exit closes the application without
confirmation. You only get a confirmation dialog when you close firebox with the
close button or with Alt-F4

You have my vote :-)

Comment 9

14 years ago
This bug is similar to bug #220385 (but with a diferent point of view)
And looks like a duplicate of #250983

I'm moving my vote to the other bug
(Reporter)

Comment 10

14 years ago
(In reply to comment #9)
> This bug is similar to bug #220385 (but with a diferent point of view)
> And looks like a duplicate of #250983

Bug 220385 is for Seamonkey, not for Firefox, and it seems to be discussing the
opposite view, that the feature should not exist at all (even though it is
optional).

And I acknowledged from the beginning that this bug is probably related to bug
250983, since they both are about actions that should show the tab warning
dialog but don't.  However, I filed this bug because choosing "Quit" is not the
same action as choosing "Close Window", even though they both should show the
prompt.  If the fix for one will fix the other, than that's great, but I don't
know enough about the code base to make that determination.  This bug is for
"Quit", and bug 250983 is for "Close Window".

Updated

14 years ago
Depends on: 250983
dup of Bug 225829.

*** This bug has been marked as a duplicate of 250983 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
No longer depends on: 250983
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.