Closed Bug 250983 Opened 18 years ago Closed 17 years ago

"Close Window" (ctrl-shift-w) does not display confirm dialog when multiple tabs are open.

Categories

(Firefox :: Tabbed Browser, defect)

1.0 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox1.0

People

(Reporter: moixa, Assigned: leon.sha)

References

Details

(Keywords: fixed-aviary1.0)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.8


See bug 108973 for confirm dialog.
Bug 210639 reports and fixes this problem for mozilla. I still have it in
Firebird though.


Reproducible: Always
Steps to Reproduce:
1. Open new window with multiple tabs in it.
2. File->Close Window or Ctrl-Shift-W.


Actual Results:  
Window with all tabs closes.

Expected Results:  
Confirm dialog for closing window (as with pressing Alt-F4).
Add'l info: browser.tabs.warnOnClose is true and the confirm dialog comes when
pressing Alt-F4.
in Mozilla 1.7 this works properly, maybe the fix for Bug 210639 was not applied
to Firefox code?'

-> CONFIRMING
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'm seeing this behavior on Firefox Linux Official 0.9.1 Mozilla/5.0 (X11; U;
Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1 and on nightlies from
7/10 as well. Setting to All OSes.
OS: Windows 2000 → All
I also see this behavior on Mac OS X.
Build ID: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7)
Gecko/20040804 Firefox/0.9.1+

I filed a bug for a similar issue: bug 254401 - "Firefox -> Quit Firefox (or
File -> Exit) does not display confirm dialog when multiple tabs are open." 
These issues may be related.

CC'ing self.
Flags: blocking-aviary1.0?
Features should be consistent. Probably just a matter of running the two code
paths through the same function. 
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Confirmed to be very annoying, it really ought to get fixed.  What an obnoxious
bug!  I finally found a defense against losing form data to accidental window
closes, and now there's a common typo (word-erasing in all caps) which overrides it.
This bug is similar to bug #220385 (but with a diferent point of view)
This bug is similar to bug #220385 (but with a diferent point of view)
And bug #254401 have some more information
Also fixed bug 254401.
Assignee: bugs → leon.sha
Status: NEW → ASSIGNED
Attachment #159929 - Flags: review?(bugs)
Attachment #159929 - Flags: approval-aviary?
*** Bug 261335 has been marked as a duplicate of this bug. ***
Blocks: 225829
Blocks: 254401
Comment on attachment 159929 [details] [diff] [review]
Patch porting from 210639

please get reviews before requesting approval. thanks.
Attachment #159929 - Flags: approval-aviary?
Attachment #159929 - Flags: review?(bugs) → review?(mconnor)
found an extension who does that
http://gorgias.de/mfe/#tabwarning
Comment on attachment 159929 [details] [diff] [review]
Patch porting from 210639

ok, r=mconnor@steelgryphon.com
Attachment #159929 - Flags: review?(mconnor)
Attachment #159929 - Flags: review+
Attachment #159929 - Flags: approval-aviary?
Comment on attachment 159929 [details] [diff] [review]
Patch porting from 210639

a=asa for aviary checkin.
Attachment #159929 - Flags: approval-aviary? → approval-aviary+
Whiteboard: [have patch] - ready to land
need to get this in soon if we are going to take it.
Leon, do you have cvs access? I see a Leon Zhang has cvs access, but it doesn't
appear that Leon Sha has access. 
*** Bug 254401 has been marked as a duplicate of this bug. ***
*** Bug 263224 has been marked as a duplicate of this bug. ***
(In reply to comment #16)
> Leon, do you have cvs access? I see a Leon Zhang has cvs access, but it doesn't
> appear that Leon Sha has access. 

I do not have cvs access. So can anyone help to checkin this?
Whiteboard: [have patch] - ready to land → [have patch] - ready to land - need help landing
Checked in br & trunk.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Keywords: fixed-aviary1.0
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [have patch] - ready to land - need help landing
Target Milestone: --- → Firefox1.0
No longer blocks: 225829
*** Bug 225829 has been marked as a duplicate of this bug. ***
vrfy'd fixed with 200410150x-0.9+ builds on linux fc2 and mac os x 10.3.5.
Status: RESOLVED → VERIFIED
Version: unspecified → 1.0 Branch
*** Bug 264558 has been marked as a duplicate of this bug. ***
*** Bug 265918 has been marked as a duplicate of this bug. ***

No warning when there are only pinned tabs.

You need to log in before you can comment on or make changes to this bug.