Closed Bug 254687 Opened 20 years ago Closed 11 years ago

An option to place find toolbar at top of the page

Categories

(Toolkit :: Find Toolbar, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 869543

People

(Reporter: jaap, Unassigned)

References

Details

(Whiteboard: WONTFIX (->extension))

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040806 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040806 Firefox/0.9.1+

On the bottom like it now is most people will notice it because people expect
something to happen on the top half of the screen

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
It was moved from the top to the bottom deliberately.
(In reply to comment #1)
> It was moved from the top to the bottom deliberately.

I know it was moved, but I think it was a bad idea. People just do not notice
things on the bottom of the screen as well as on the top

This should belong in the "Find Toolbar / FastFind" component.
Assignee: bugs → firefox
Component: Toolbars → Find Toolbar / FastFind
QA Contact: bugzilla
Severity: normal → enhancement
I still think it should be standard at the top, but maybe a there should be a
preference to set it at the top or the bottom
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040806 Firefox/0.9.1+
> Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040806 Firefox/0.9.1+
> 
> On the bottom like it now is most people will notice it because people expect
> something to happen on the top half of the screen
> 
> Reproducible: Always
> Steps to Reproduce:
> 1.
> 2.
> 3.

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040806 Firefox/0.9.1+
> Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040806 Firefox/0.9.1+
> 
> On the bottom like it now is most people will notice it because people expect
> something to happen on the top half of the screen
> 
> Reproducible: Always
> Steps to Reproduce:
> 1.
> 2.
> 3.

(In reply to comment #4)
> I still think it should be standard at the top, but maybe a there should be a
> preference to set it at the top or the bottom

I agree with you Jaap A. Haitsma, it should be a preference...
When it first appeared for me, I tried to drag it to the top of the screen like
a movable toolbar, I think allowing that would be better than having another
Preferences option.
(In reply to comment #6)
> When it first appeared for me, I tried to drag it to the top of the screen like
> a movable toolbar, I think allowing that would be better than having another
> Preferences option.

That's just the interface.(A very nice one I have to say :-) What I meant with a
preference option is that Firefox saves the position in the preferences and that
of course means that there also have to be an interface to set it
The current position is definitely not obvious for people moving from browsers
with "find-as-popup-dialogue" UI (i.e. anyone except those using nightlies
leading up to 0.10.0 or bothered to read the full release notes).  If there's a
really good reason for putting it at the bottom as opposed to the top (I can't
read minds <g>), how about some sort of notification the first time cmd-/ctrl-f
is invoked that the find bar is at the bottom?
Marking OS -> all, Platform -> all.

Jaap: is it ok to rephrase your summary and ask for a find toolbar that's movable? 
OS: Linux → All
Hardware: PC → All
(In reply to comment #9)
> Marking OS -> all, Platform -> all.
> 
> Jaap: is it ok to rephrase your summary and ask for a find toolbar that's
movable? 

Yes, it is. As a standard I would then move it to the top, though. For the
reasons that were already mentioned 
(In reply to comment #1)
> It was moved from the top to the bottom deliberately.

Do you have a bug number what made this change?


As i see it now, there are two issues
1) default position should be on top [this bug]
2) position should be customizable [via dragging or pref].

How about we leave this bug to deal with issue 1). To evaluate that, we need to
have the arguments for having it at the bottom.

and someone files a new bug for 2) [after checking it's not been filed yet].

If someone files 2), can you please report back the new bug number? Thank you.

Updating summary. Old summary "find toolbar should be at top of the page"
Summary: find toolbar should be at top of the page → By default, the find toolbar should be at top of the page.
(In reply to comment #11)
> 
> Do you have a bug number what made this change?
> 
> 
> As i see it now, there are two issues
> 1) default position should be on top [this bug]
> 2) position should be customizable [via dragging or pref].
> 
> How about we leave this bug to deal with issue 1). To evaluate that, we need to
> have the arguments for having it at the bottom.
> 
> and someone files a new bug for 2) [after checking it's not been filed yet].
> 
> If someone files 2), can you please report back the new bug number? Thank you.
> 
bug #264545
Since the move was made deliberately, and movable toolbars would solve your
issue by allowing you to customize it as you wish, this is probably a dupe of
bug 172818.
"By default" variant is a wontfix, because they moved it from top to bottom
(because f.e. the page was jumping up and down).

The "pref" variant is not exactly the same as bug 172818, because the Find
Toolbar is not the same as a regular toolbar, but it probably depends on that.

->NEW and changing summary
Status: UNCONFIRMED → NEW
Depends on: 172818
Ever confirmed: true
Summary: By default, the find toolbar should be at top of the page. → An option to place find toolbar at top of the page
*** Bug 267234 has been marked as a duplicate of this bug. ***
*** Bug 268032 has been marked as a duplicate of this bug. ***
How about making the Find Toolbar moveable?  Certainly having it appear at the
top would be better than having it buried at the bottom of the window.  But
beyond that, anyone who despises these nonmovable "panes" like I do would
appreciate it if it one could "tear" it off and place it anywhere.  That way,
those people who like it glued to one side of the browser window can keep it
there, and those who prefer a floating Find box (like me) can have it that way.
 It REALLY should be a preference.
This seems like extension fodder to me.
Whiteboard: WONTFIX (->extension)
*** Bug 284696 has been marked as a duplicate of this bug. ***
The fact that Firefox's Find Bar is glued to the bottom of the window is why I'm still using Mozilla Suite.  I hate it at the bottom.  Why is the dev team so reluctant to allow moving/dragging of the Find Bar?  Seems like a no-brainer to me.
I have made a a workaround for this bug: http://forums.mozillazine.org/viewtopic.php?p=2282058

You need the userChrome.js extension to use it (1st page of thread).
QA Contact: fast.find
(In reply to comment #14)
> "By default" variant is a wontfix, because they moved it from top to bottom
> (because f.e. the page was jumping up and down).
>


I have previously concluded that we need to make the UI so that nothing that appears at the top shifts the page down, anyway.  It should just cover the portion of the page that it needs to appear over, not shift the whole page.  The only time it might be wise to shift the whole page is when you are scrolled all the way to the top, but I say even then it should do it.

This that I am mentioning would also fix the page shifting problem where the tab bar appears at the top after opening a second tab in the background (when Hide tab bar when only one tab is present is enabled).

By the way, that would be Bug 248715.
*** Bug 351404 has been marked as a duplicate of this bug. ***
Assignee: bross2 → nobody
Product: Firefox → Toolkit
Blocks: 565552
This is more or less a duplicate of bug 776708 since it won't be an option but the bar will be moved to the top.
No longer blocks: 565552
Status: NEW → RESOLVED
Closed: 11 years ago
No longer depends on: 172818
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.