Last Comment Bug 256065 - Add description field value to tooltips for bookmarks and/or folders
: Add description field value to tooltips for bookmarks and/or folders
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- enhancement with 12 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 300554 367262 412166 426182 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-18 14:43 PDT by Richard Corbin
Modified: 2013-03-19 08:53 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (1.27 KB, patch)
2007-12-08 07:27 PST, Bill Gianopoulos [:WG9s]
no flags Details | Diff | Splinter Review
patch v2 (1.55 KB, patch)
2007-12-08 08:34 PST, Bill Gianopoulos [:WG9s]
no flags Details | Diff | Splinter Review
patch v2a (1.55 KB, patch)
2007-12-08 08:37 PST, Bill Gianopoulos [:WG9s]
no flags Details | Diff | Splinter Review
patch v3 (1.55 KB, patch)
2007-12-08 08:40 PST, Bill Gianopoulos [:WG9s]
no flags Details | Diff | Splinter Review

Description Richard Corbin 2004-08-18 14:43:46 PDT
When hovering/selecting a folder/bookmark in the "Bookmarks" menu, the
folder/bookmark's description (entered via "Bookmarks > Manage Bookmarks")
should be displayed as a tooltip.

If no description entered then show 'No description' as the tooltip (or nothing
at all).

NOTE - Wasn't sure whether the component for this was 'bookmarks' or 'menus'.
Please change if necessary.
Comment 1 slamdunk 2004-12-27 02:30:02 PST
The tooltip / bubble should show both bookmark url and description.
-slamdunk
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-01-04 16:27:34 PST
The bookmarks toolbar currently shows the name and the URL. I don't think it
would be a very good idea to deviate from that. Besides, the description would
probably be too long in most cases anyways.
Comment 3 slamdunk 2005-01-04 17:47:27 PST
(In reply to comment #2)
> The bookmarks toolbar currently shows the name and the URL. I don't think it
> would be a very good idea to deviate from that. Besides, the description would
> probably be too long in most cases anyways.

I'm using 1.0 (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0) and I haven't seen any Tooltip/bubble appear when I
mouse-hover over any bookmark-item. IE shows a URL when you hover over
bookmark-link. The Manage-Bookmark screen shows both the URL and the Description.

This is regarding 'Menu->Bookmarks' not 'Menu->Manage Bookmarks'
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-01-04 17:53:30 PST
(In reply to comment #3)
> I'm using 1.0 (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
> Gecko/20041107 Firefox/1.0) and I haven't seen any Tooltip/bubble appear when I
> mouse-hover over any bookmark-item.

I'm talking about the Bookmarks *Toolbar*, which you may or may not use.

> This is regarding 'Menu->Bookmarks' not 'Menu->Manage Bookmarks'

I know what this is about. I'm just saying that it should stay consistent. Most
people don't even have descriptions for their bookmarks. Using the name like the
toolbar currently does would be best IMO.
Comment 5 slamdunk 2005-01-04 18:17:33 PST
(In reply to comment #4)
The current bookmark is simple as it shows only the title. Like you said maybe
this is best as bubble might add complexity and confuse the average user. But if
there is a way to add the bubble functionality through about:config then that
would be good. The advanced users who really want it can enable it through
about:config.

Right now nobody care about 'description' because there it is displayed only in
manage-bookmarks which people rarely use. If it was shown in bubble then some
people would have used it. Description field can be used to write down short
personal note related to particular bookmark. Might be useful for people who do
research etc using internet.
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-01-04 19:43:25 PST
Wait a minute, now you're asking for a bubble? This bug report was about adding
a tool tip.
Comment 7 slamdunk 2005-01-04 22:23:37 PST
(In reply to comment #6)
Tooltip and Bubble are same things except Bubble would allow multiline whereas
tooltip is restricted to displaying one single line. Using bubble would add
scalability.
Comment 8 Serge Gautherie (:sgautherie) 2005-02-01 06:17:20 PST
Note that this FF bug is the same (duplicate !?) as bug 135962 for MAS.
Comment 9 Phil Ringnalda (:philor, back in August) 2006-06-18 20:02:54 PDT
*** Bug 300554 has been marked as a duplicate of this bug. ***
Comment 10 Mike Connor [:mconnor] 2006-08-27 05:18:35 PDT
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
Comment 11 Ria Klaassen (not reading all bugmail) 2007-01-17 12:30:56 PST
*** Bug 367262 has been marked as a duplicate of this bug. ***
Comment 12 Jon B 2007-01-17 12:39:01 PST
(In reply to comment #2)
> The bookmarks toolbar currently shows the name and the URL.

It should also display the description when you hover over items on the bookmarks toolbar.
Comment 13 Bill Gianopoulos [:WG9s] 2007-12-08 07:27:03 PST
Created attachment 292224 [details] [diff] [review]
patch v1

This seems to fix the issue for me.
Comment 14 Bill Gianopoulos [:WG9s] 2007-12-08 07:48:16 PST
(In reply to comment #13)
> Created an attachment (id=292224) [details]
> patch v1
> 
> This seems to fix the issue for me.
> 

This code can be greatly simplified if the only 2 possibilities here are folders and URL items. 
Comment 15 Bill Gianopoulos [:WG9s] 2007-12-08 08:34:29 PST
Created attachment 292228 [details] [diff] [review]
patch v2

More correct and simplified patch.
Comment 16 Bill Gianopoulos [:WG9s] 2007-12-08 08:37:21 PST
Created attachment 292229 [details] [diff] [review]
patch v2a

Fix comment typo.
Comment 17 Bill Gianopoulos [:WG9s] 2007-12-08 08:40:23 PST
Created attachment 292230 [details] [diff] [review]
patch v3

One more try.  Make variable name conform to standard.
Comment 18 Bill Gianopoulos [:WG9s] 2008-01-13 04:58:17 PST
Comment on attachment 292230 [details] [diff] [review]
patch v3

Upon re-reading the summary on this bug, it seems to be about adding tooltips for all items in the bookmarks menus using the item description as the tooptip.  My patch is about using the description field for bookmark folders as tooltip in the bookmark toolbar.  Not exactly the same thing.

I filed bug 412166 on my issue and moved my patch there.
Comment 19 Phil Ringnalda (:philor, back in August) 2008-03-31 12:38:43 PDT
*** Bug 426182 has been marked as a duplicate of this bug. ***
Comment 20 Marco Bonardo [::mak] 2009-03-24 06:08:47 PDT
so i'm changing this to generally cover a "add description to bookmarks", the details of where and how can be defined here.
Bill since this can be more generic i'm duping your new bug to this, and if you want to continue here you're welcome to do so.
Comment 21 Marco Bonardo [::mak] 2009-03-24 06:09:05 PDT
*** Bug 412166 has been marked as a duplicate of this bug. ***
Comment 22 Gervase Markham [:gerv] 2009-11-26 06:24:34 PST
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Comment 23 Mike Conley (:mconley) - (Needinfo me!) 2013-03-19 08:53:58 PDT
The front-end team has decided not to fix this bug.

Note You need to log in before you can comment on or make changes to this bug.