Closed Bug 257037 Opened 18 years ago Closed 5 years ago

Per Subscription Check Intervals for RSS feeds

Categories

(MailNews Core :: Feed Reader, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1312813

People

(Reporter: adrianmoisey, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: perf, Whiteboard: [patchlove][has draft patch])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.2) Gecko/20040816 Firefox/0.9.1+
Build Identifier: version 0.7+ (20040826)

You cant set different feeds to refresh on different intervals. IE. I only want
my feeds from blog sites to refresh every 2 hours (cause i want to save
bandwidth) But I want to be able to get feeds from news sites to check every 10
minutes

Reproducible: Always
Steps to Reproduce:
*** Bug 260992 has been marked as a duplicate of this bug. ***
confirm rfe
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Summary: RSS refreshing feeds → Per Subscription Check Intervals for RSS feeds
Confirming my request for enhancment to allow different refresh intervals for
RSS Feeds on a per feed basis.
*** Bug 268057 has been marked as a duplicate of this bug. ***
Yes please.  I can't set it faster than 30 minutes without being banned from
Slashdot, but I can't keep up to date on some of the other feeds at a measly 30
minute refresh rate.
*** Bug 273321 has been marked as a duplicate of this bug. ***
I have a similar but not the same problem. Please check Bug 303526.

*** Bug 321364 has been marked as a duplicate of this bug. ***
QA Contact: rss
Assignee: mscott → nobody
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Assignee: nobody → alta88
Attachment #8411079 - Flags: ui-review?(bwinton)
Attachment #8411079 - Flags: review?(standard8)
Attachment #8411080 - Flags: review?(philip.chee)
This patch looks bigger than it is, while it would be nice for 31 perhaps strings could be done in 31 and then it could be advanced into 31, your call.

This patch:
1. enables per feed user defined check interval.
2. visual folderpane feedback of busy/error state; if at least 1 feed in a folder is busy/error, the icon shows.
3. some perf things; in addition to being able to spread updates around, tweak actively deleting dead objects and only doing things like flush and QI when needed and no more.
4. allows account 'pausing', visual feed back when account/feeds are paused/disabled for update.

Note: after applying the patch, a restart is required due to the longstanding account update pref change needing a restart to take effect bug.
Note2: if the test profile has been run after Bug 946279 is applied, do a find on 'feed.options' in about:config and reset that pref for accounts, then apply this patch.
Comment on attachment 8411080 [details] [diff] [review]
suitestrings.patch

I'm going to punt this to IanN as he's more familiar with newsblog.
Attachment #8411080 - Flags: review?(philip.chee) → review?(iann_bugzilla)
Comment on attachment 8411079 [details] [diff] [review]
feedUpdates.patch

IanN probably needs to see what bits are needed to port to SeaMonkey
Attachment #8411079 - Flags: review?
Attachment #8411079 - Flags: feedback?(iann_bugzilla)
the only things to port to suite, if wanted, are
1) there's a contextmenu in folderpane to pause an account.
2) favicons (from that patch) and icons for status in folderpane; the folderpanes are very different, i think.
3) due to folderpane diffs, subscribe dialog icons have an ifdef.
Flags: needinfo?(mkmelin+mozilla)
Attachment #8411079 - Flags: feedback?(mkmelin+mozilla)
Flags: needinfo?(mkmelin+mozilla)
Comment on attachment 8411079 [details] [diff] [review]
feedUpdates.patch

I'm not going to get to review this in the short term. I would suggest Magnus for the mail/ parts and probably Neil for mailnews/
Attachment #8411079 - Flags: review?(standard8)
Attachment #8411079 - Flags: review?(neil)
Attachment #8411079 - Flags: review?(mkmelin+mozilla)
Attachment #8411079 - Flags: review?
Attachment #8411079 - Flags: feedback?(mkmelin+mozilla)
(In reply to alta88 from comment #11)
> This patch looks bigger than it is, while it would be nice for 31 perhaps
> strings could be done in 31 and then it could be advanced into 31, your call.

Landing strings early is no longer acceptable. It confuses L10n (who can't test the feature as soon as they want to translate strings) and runs the risk of the review finding additional strings that would need changing on a frozen branch.

This may sound harsh, but I'd rather have a well-reviewed feature land in the next esr, rather than a rushed one into 31. That, of course, doesn't stop it being reviewed before Monday.
Comment on attachment 8411079 [details] [diff] [review]
feedUpdates.patch


since this won't make 31 with bug 946279 it will need migration code.
Attachment #8411079 - Flags: ui-review?(bwinton)
Attachment #8411079 - Flags: review?(neil)
Attachment #8411079 - Flags: review?(mkmelin+mozilla)
Attachment #8411079 - Flags: feedback?(iann_bugzilla)
Assignee: alta88 → nobody
Comment on attachment 8411080 [details] [diff] [review]
suitestrings.patch

Strings seem fine but would need to port bits of the main patch too.
Attachment #8411080 - Flags: review?(iann_bugzilla) → review+
I have noticed that there is an existing clash of accesskeys on the am-newsblog.xul page:
browseFolder.accesskey
useQuickMode.accesskey

both of which are "B"

Do you want to fix that here too?
Hardware: x86 → All
Version: unspecified → Trunk
Depends on: 1025548
What is happening with this bug?
Flags: needinfo?(alta88)
Flags: needinfo?(alta88)
Duplicate of this bug: 1227559
Blocks: 1227559
(In reply to Ian Neal from comment #21)
> What is happening with this bug?

it needs a new friend :)

changing to normal bug severity because hitting all the feeds on the same interval must impact overall performance and startup performance (bug 1227559 - although it seems unlikely bug 257037 alone is enough)
Severity: enhancement → normal
Keywords: perf
Whiteboard: [patchlove][has draft patch]
Bug 1312813 should cover this.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1312813
You need to log in before you can comment on or make changes to this bug.