support paste command in FAYT mode

RESOLVED FIXED in seamonkey2.1a3

Status

SeaMonkey
Find In Page
--
enhancement
RESOLVED FIXED
13 years ago
7 years ago

People

(Reporter: Sekundes, Unassigned)

Tracking

({helpwanted})

Trunk
seamonkey2.1a3
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: SeaMonkey Only. This is fixed on Fx.)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040817
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040817

In Opera, it's possible to paste the copied string in the clipboard to FAYT mode.
This could be achieved by using the alternative Ctrl + F; however, it's sloooow. :)
FAYT is simply the replacement of Ctrl + F in my life.
It's of high use when you've to find the foreign characters as we've no idea to
type it.

Reproducible: Always
Steps to Reproduce:
1. Type / or ' to enable FAYT mode.
2. Ctrl + V. (Make sure you've copied *sth*)
Actual Results:  
Nothing happened.

Expected Results:  
Paste command should work in FAYT mode.

Comment 1

13 years ago
Firefox already has this with the find toolbar. I'm not interested in
reinventing the wheel with old FAYT. People might even be pretty confused by it
when there's no find textfield.
Assignee: aaronleventhal → nobody

Updated

13 years ago
Blocks: 254301

Comment 2

13 years ago
*** Bug 263871 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
Aaron, Firefox's Find toolbar isn't focused if you hit ' or /.  It's only
focused if you hit Ctrl+F.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → aaronleventhal
QA Contact: keyboard.fayt
*** Bug 314380 has been marked as a duplicate of this bug. ***
No longer blocks: 254301
This bug is fixed on Fx. But not so SeaMonkey. Because SeaMonkey isn't using editor widget for FAYT. It's causes from many bugs. We should port Find Toolbar from Firefox to SaeMonkey. This is bug 97023.
Depends on: 97023
OS: Windows 2000 → All
Hardware: PC → All
Whiteboard: SeaMonkey Only. This is fixed on Fx.

Updated

12 years ago
Assignee: aaronleventhal → nobody
Component: Keyboard: Find as you Type → General
Keywords: helpwanted
Product: Core → Mozilla Application Suite
(Assignee)

Updated

12 years ago
Product: Core → SeaMonkey

Updated

12 years ago
Component: General → Keyboard: Find as you Type
Product: Mozilla Application Suite → Core

Comment 6

7 years ago
FIXED BY bug 97023.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1a3
You need to log in before you can comment on or make changes to this bug.