'Open in tabs' command does not respect close multiple tabs warning

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
RESOLVED WONTFIX
13 years ago
9 years ago

People

(Reporter: Thomas Rutter, Assigned: vlad)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040906 Firefox/1.0 PR (NOT FINAL)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040906 Firefox/1.0 PR (NOT FINAL)

"Open in tabs" in bookmarks closes all existing tabs without warning, even if
multiple tabs are open and you have "Warn when closing multiple tabs" turned on
in the Firefox configuration.

Middle-clicking on a folder in the bookmarks toolbar will do an "Open in tabs".
 It is very easy to accidentally middle-click on one of these, because I usually
middle-click bookmarks.  Contrary to what you would expect, middle-clicking a
folder in the bookmarks doesn't open them in new tabs but closes all existing
tabs and replaces them.

Reproducible: Always
Steps to Reproduce:
1. Go to Tools > Options > Advanced > Browsing and make sure "Warn when closing
multiple tabs" is turned on.
2. Middle click a folder in your bookmarks.


Actual Results:  
All my open tabs are gone and replaced with new tabs for the folder entries

Expected Results:  
Display warning first (or open the new tabs *in addition to* the current tabs).

Classifying this as a bug rather than enhancement since the "Warn when closing
multiple tabs" feature is broken here.

Comment 1

13 years ago
You can load additional tabs by going to about:config and setting
browser.tabs.loadFolderAndReplace to 'false'.

Probably not a bug, since there is functionality to prevent this and you're not
closing a tab.  It wouldn't make sense for the close tab warning to fire here. 
By that logic, it should fire every time to go to a new URL in a tab.

*** This bug has been marked as a duplicate of 241305 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

13 years ago
Not a duplicate of bug #241305 - this bug is in regard to the new "Warn when
closing multiple tabs" option in the Options UI.  Bug #241305 came before that
option existed.

This bug points out that since that the new "Warn when closing multiple tabs"
option was added, Firefox doesn't warn when closing multiple tabs when doing an
'open in tabs'.

(Reply to Comment #1)
> It wouldn't make sense for the close tab warning to fire here. 
> By that logic, it should fire every time to go to a new URL in a tab.

The option in the Options UI says "Warn when closing multiple tabs".  As it
stands now the warning should be shown when, and only when, more than one tab
will be closed at the same time due to an action taken.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WONTFIX
oops.  Didn't mean to submit without that.

This is not critical/severe enough to warrant a warning dialog.  As far as I'm
concerned, we're already pushing the boundaries on dialogs, and we're on the
verge of making all warning dialogs useless through overuse.

This has been discussed to death, and will not be changed.
Notice also that this technically doesn't close the currently-open tabs, but
only loads new URLs into them. You can then hit "back" on each of the
previously-existing tabs to return to where you were before.
(That's my experience, anyway).
(Reporter)

Comment 6

13 years ago
> This has been discussed to death, and will not be changed.

Could you please point me in the direction of where this was discussed?  Then I
will know what has already been discussed and whether to continue the discussion
elsewhere.

> Notice also that this technically doesn't close the currently-open tabs, but
> only loads new URLs into them. You can then hit "back" on each of the
> previously-existing tabs to return to where you were before.

Consider this: you have 15 tabs open.  You accidentally right click on a folder
in your bookmarks.  All the 15 tabs are closed and replaced with two (2) tabs. 
There's no 'back' button for the other 13 tabs, and in my experience it's when
you have that many tabs open that this truly becomes a problem.
Thomas - You're right, of course. Given this information, I now share your view
that this should be fixed.
See also bug 173406 and bug 246094.
(Reporter)

Comment 9

13 years ago
(In reply to comment #8)
> See also bug 173406 and bug 246094.

Thanks for links.  I wasn't aware of the "browser.tabs.loadFolderAndReplace"
preference.

Unfortunately what I still haven't been able to find is a link to where this
issue has been discussed previously, so that I may see the arguments that were
raised for and against it and why it was refused.  Do you have a link?
(Reporter)

Updated

13 years ago
Summary: 'Open in tabs' command clears all existing tabs without warning → 'Open in tabs' command does not respect close multiple tabs warning
Warning dialogs are not something we really really want, of course.  The bug on
CHimera-style smart replace is a far better solution, and does much more to
prevent dataloss than any warning dialog ever will.  We're already doing a worse
job of holding the line on dialog abuse than I'd like to see.

Warning dialogs should be reserved for extreme cases, as overuse tends to lead
to users ignoring ALL dialogs.  This is an established UI principle (see
Apple/GNOME/Windows HIGs).
(Reporter)

Comment 11

13 years ago
(In reply to comment #10)
> We're already doing a worse
> job of holding the line on dialog abuse than I'd like to see.

What do you think about the "Warn when closing multiple tabs" option?  Currently
this is not fulfilling its stated purpose.  Given that the goal as you state is
to remove warning dialogs whereever possible, then surely the "Warn when closing
multiple tabs" feature must be removed.  What concerns me in this bug is the
inconsistency of having a "Warn when closing multiple tabs" feature that doesn't
work in this circumstance.  Is removing this altogether on the agenda?

Sorry to keep adding to this dead bug, but I still haven't seen where this bug
was discussed previously.
actually, you're right, in that _this_ particular case that it hasn't been
discussed.  The behaviour itself has been discussed to death.  Its still not the
right solution for the problem of going from X to Y open tabs, where X is
greater than Y.

The warning we have for closing windows and Close Other Tabs is mostly useless
for me, I wasn't happy about that, but we caved.  This is different because
there's a viable alternative (smart replace) that addresses the single case
where there is the potential for dataloss.  Just because we haven't implemented
it yet doesn't justify a warning dialog.
(Reporter)

Comment 13

13 years ago
Those wishing to know why this is WONTFIXed may refer to bug #175124 which
describes another method for solving this problem that does not involve any
warning dialog.

Comment 14

13 years ago
(In reply to comment #11)
> Sorry to keep adding to this dead bug, but I still haven't seen where this bug
> was discussed previously.

This bug is discussed in bug 241305 for example.

Comment 15

13 years ago
(In reply to comment #12)
> The warning we have for closing windows and Close Other Tabs is mostly useless
> for me, I wasn't happy about that, but we caved.  This is different because
> there's a viable alternative (smart replace) that addresses the single case
> where there is the potential for dataloss.  Just because we haven't implemented
> it yet doesn't justify a warning dialog.

About the « Warn when closing multiple tabs » checkbox. I'm not sure but I think
this feature is used to avoid users from closing Firefox when multiple tabs are
opened. I remember reporting these bugs months ago and the only way to solve the
problem was to add a warning dialog or use the SessionSaver extension. As this
extension is bugged and hasn't been updated since march 2004, there's no way a
user can get its tabs back when Firefox is closed.

In this very special case, the only solution was to use a warning dialog. Only a
SessionSaver-like feature or extension could solve the problem.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks

Comment 17

9 years ago
There is a big discussion and argument going on resulting in making
browser.tabs.loadFolderAndReplace obsoleted !!!

I do not want to go to the core of the argument "should open in tabs" overwrite
existing open tabs or append. Both sides are valid and legitimate uses.

Make one option a default - that would make supporters of one argument happy.
Keep browser.tabs.loadFolderAndReplace working so supporters of another
argument can be happy too.

This may be silly but a lot of people are very unhappy with your arbitrary
decision to go one way and lock out everybody else who do not agree with your
choice. I am one of them and this alone may make me to stop using FF.

I cannot believe what I am writing here but in 2008 a community driven project
behaves like Stalin in 1938. Get a grip, please.
You need to log in before you can comment on or make changes to this bug.