If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

middle clicking a bookmarks folder should append tabs by default

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Jean-Marc M., Assigned: mano)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.6 StumbleUpon/1.79
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.6 StumbleUpon/1.79

I think closing opened tabs is a bad design issue, please read the « Bookmark
folders open in tabs should open in new tabs? »
(http://forums.mozillazine.org/viewtopic.php?t=53860) post for more information.
Middle clicking a bookmarks folder from the bookmarks manager should open folder
bookmarks in new tabs and shouldn't close the opened tabs first, then open the
folder bookmarks in new tabs. There's no reason it should behave like it does.

Reproducible: Always
Steps to Reproduce:
1. Open a few tabs
2. Middle click a folder that contains a few bookmarks from the bookmarks manager
3. Opened tabs are closed and folder ones are opened

Actual Results:  
All opened tabs are closed and folder ones are opened.

Expected Results:  
The software should have opened the folder tabs in new tabs, not over the opened
ones.
I think this could be called a dupe of bug 173406.
(Reporter)

Comment 2

14 years ago
Bug 173406 :
« The default for this pref should be "replace" IMO. »

We disagree with the replace default behaviour, that's why we decided to post a
bug report. When a user middle clicks a folder, it doesn't expect its tabs being
closed, it expects the folder bookmarks being opened in new tabs. Like the «
append » behaviour described in the 173406 bug report.

They also talked about adding an option to change the folder middle click
behaviour, however it seems it has never been added to the « Tools > Options »
dialog. For the end-user, the only solution is to « patch » the default prefs file :
« browser.tabs.loadFolderAndReplace set to false does append »

I'm not sure end-users expect to make their hands dirty to change some options.

So I think this bug report is not a duplicate of bug 173406, we just want
Firefox to make its default folder middle click behaviour, more logicial and
user-friendly.

Comment 3

14 years ago
First time i ran into this I was totally confused to see my existing tabs be
replaced with the new ones i opened. I also think that its more user-friendly to
append them. 

It would be interesting to hear why replacing is considered to be better for the
average user.
this would be more consistent with middle clicking on bookmarks, but I
personally find appending annoying, since I rarely choose to open five websites
if I'm already reading a couple and don't want to close them.  maybe my mind
needs more tracks to agree with this bug.

Confirming, let pch decide this one.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Middle clicking a bookmarks folder closes tabs to open the folder ones → middle clicking a bookmarks folder should append tabs by default
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> this would be more consistent with middle clicking on bookmarks, but I
> personally find appending annoying, since I rarely choose to open five websites
> if I'm already reading a couple and don't want to close them.  maybe my mind
> needs more tracks to agree with this bug.
> 
> Confirming, let pch decide this one.

Yes but I really think that we should think about users, not us. Moreover this
time it's different that bug 208399 as there's no way for the user to restore
its tabs. There's no undo.

So at least the user should get a confirmation dialog :
« All your opened tabs are about to bo closed... »

I don't think a solution would be to implement an undo feature as I believe
replacing tabs is not a suitable default behaviour. No user would ever expect it
s tabs being closed when middle-clicking a folder.

I decided to replied to Mike as I read its discussion about bug 208399. Moreover
a few minutes ago I made the mistake to middle-click a folder and 10 of my
opened tabs were closed, no way to restore them. Damn.
implementing a sane back/forward process when a group of tabs is opened makes
more sense than always append.  A lot of users (myself included) use open in
tabs to surf through groups of sites.  I have about three folders of links that
I use this with regularly, and rather than close eight tabs, then middle-click,
I middle-click.  Usability gain is huge in that scenario.  Making it possible to
hit back and go back to the previous tab group is the solution to the potential
dataloss situation here.  Making everyone have to perform continuous cleanup of
tabs is not a better default, we just need to fix the issue whereby you lose
your previous pages.
(Reporter)

Comment 7

14 years ago
(In reply to comment #6)
> Making everyone have to perform continuous cleanup of
> tabs is not a better default, we just need to fix the issue whereby you lose
> your previous pages.

How do you intend to fix the issue ? I think there a few solutions. The undo
feature could be improved to undo the middle click folder operation : restore
all closed tabs. But I think users should be able to choose the default middle
click folder behaviour : replace or append. And a confirmation dialog should be
displayed the first time tabs are replaced if the default behaviour is replace.

The important thing is that there should always be a confirmation dialog the
first time a special operation is done, this way users know how the application
behave. Firefox developers know how the application behave but users don't.
Using confirmation dialogs allow developers to help the users how the
application works, it even helps them to configure it without wondering why all
their tabs were closed and lost.
(Reporter)

Comment 8

14 years ago
I came up with a new idea while reading bug 175124. To sum things up, the middle
clicking folder feature should behave as the bookmark one. When you middle click
a bookmark, it opens a new tab, so when you middle click a folder, it should
open new tabs, not close the existing one nor replace them.
how's that a new idea?  if you append, it opens all of the links in new tabs. 
Isn't that what the original bug report was all about?

If we can just hit back to go back to the previous group of tabs, which is the
intuitive response (going back to the previous dataset) predating tabbed
browsing, we don't have dataloss issues.

Adding a dialog is never going to happen.  I'm not going to bother rehashing all
of the reasons why not, other than to say we've made a concerted effort to
remove as many dialogs, especially first-time dialogs, as possible.  If its not
intuitive to use, we have a design issue.  Its not like users read dialogs
anyway (read the studies that are out there)  Plus, we try to follow the GNOME
HIG in this regard, which we are all in agreement with.

I've given this a lot of thought since it was raised initially, and I stand by
my original thoughts on the matter.  We're not going to make this the default,
we're going to fix this the right way or not at all.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
*** Bug 248928 has been marked as a duplicate of this bug. ***

Comment 11

13 years ago
Sorry for duping this, I searched for "bookmark" instead of "bookmarks" :-\

(In reply to comment #9)

> If we can just hit back to go back to the previous group of tabs, which is the
> intuitive response (going back to the previous dataset) predating tabbed
> browsing, we don't have dataloss issues.
This is interesting, but I'm not sure this is the obvious thing to a new user:
in every other case the back button is tied to the current tab. If you open a
new tab you can't hit back to close it. If the user can't work out how do get
the data back, then it's dataloss.

> Adding a dialog is never going to happen.  I'm not going to bother rehashing all
> of the reasons why not, other than to say we've made a concerted effort to
> remove as many dialogs, especially first-time dialogs, as possible.
Agreed. However I am convinced append should be default.

> If its not intuitive to use, we have a design issue.
Well IMO it's not, and we do. I've been using tabbed browsing for a fairly long
time (pre-moz 1.0), *and* i've been hit by this in the past, and it *still* got
me yesterday. 
In *every* other case, middle click means open in new tab (except when it means
close tab). More importantly, it 's nondestructive. Maybe I'm thinking about it
the "wrong way", but I've developed the reflex that I left-click if I'm sick of
the current page, and middle click if I want to keep it.

The difference between my dupe bug and this one was I thought perhaps
left-clicking on "open in tabs" should replace (or work via the hidden pref),
and middle-clicking should append.
*** Bug 258224 has been marked as a duplicate of this bug. ***
*** Bug 259849 has been marked as a duplicate of this bug. ***
*** Bug 267280 has been marked as a duplicate of this bug. ***

Comment 15

13 years ago
*** Bug 267388 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
(In reply to comment #4)
> this would be more consistent with middle clicking on bookmarks, but I
> personally find appending annoying, since I rarely choose to open five websites
> if I'm already reading a couple and don't want to close them.

So you can left-click. I don't get it.

Comment 18

10 years ago
This has been fixed.  See bug 175124 comment 26.
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---

Updated

10 years ago
Assignee: p_ch → mano
Status: REOPENED → NEW

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.