needs minimize/restore/close tooltip for F11 mode

RESOLVED FIXED

Status

RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: sekundes, Assigned: Biesinger)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040910 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040910 Firefox/0.10

Needs minimize/restore/close tooltip for minimize/restore/close button in
fullscreen mode.
And I hope it can be fixed before Firefox localization string is freezed...

Reproducible: Always
Steps to Reproduce:
Over to firefox.
Assignee: general → firefox
Component: Browser-General → General
Product: Browser → Firefox
QA Contact: general → firefox.general
(Reporter)

Comment 2

14 years ago
ah, this is the bug for Mozilla, not Firefox.
The Firefox one I filed is bug 258823.
(Reporter)

Comment 3

14 years ago
ah, this is the bug for Mozilla, not Firefox.
The Firefox one I filed is bug 258823.
Component: General → Accessibility APIs
Product: Firefox → Browser
Assignee: firefox → guifeatures
Component: Accessibility APIs → XP Apps: GUI Features
QA Contact: firefox.general
Created attachment 159262 [details] [diff] [review]
patch
Assignee: guifeatures → cbiesinger
Status: UNCONFIRMED → ASSIGNED
Attachment #159262 - Flags: review?(neil.parkwaycc.co.uk)

Comment 5

14 years ago
Comment on attachment 159262 [details] [diff] [review]
patch

>         <toolbarbutton id="close-button" class="toolbarbutton-1"
>+                       tooltiptext="&closeWindow.label;"
>                        oncommand="window.close();"/>
While you're here could you fix this to use the version that prompts the user
to close all tabs?

>+<!ENTITY minimizeButton.tooltip       "Minimize">
>+<!ENTITY restoreButton.tooltip        "Restore">
It would be nice to have all three entities together.
(In reply to comment #5)
> >+<!ENTITY minimizeButton.tooltip       "Minimize">
> >+<!ENTITY restoreButton.tooltip        "Restore">
> It would be nice to have all three entities together.

the third entity is the one already used for file|close window... I don't really
want to move that; it's probably already grouped with menuitems around it
Attachment #159262 - Attachment is obsolete: true
Attachment #159262 - Flags: review?(neil.parkwaycc.co.uk) → review-
Created attachment 159435 [details] [diff] [review]
patch v2

puts minimize/restore texts near close window; asks when closing the window w/
multiple open tabs
Attachment #159435 - Flags: review?(neil.parkwaycc.co.uk)

Comment 8

14 years ago
Comment on attachment 159435 [details] [diff] [review]
patch v2

r+sr=me
Attachment #159435 - Flags: review?(neil.parkwaycc.co.uk) → review+
Checking in browser/resources/content/navigator.xul;
/cvsroot/mozilla/xpfe/browser/resources/content/navigator.xul,v  <--  navigator.xul
new revision: 1.422; previous revision: 1.421
done
Checking in browser/resources/locale/en-US/navigator.dtd;
/cvsroot/mozilla/xpfe/browser/resources/locale/en-US/navigator.dtd,v  <-- 
navigator.dtd
new revision: 1.176; previous revision: 1.175
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
*** Bug 189251 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.