Last Comment Bug 259609 - Different column layouts for different folders
: Different column layouts for different folders
Status: RESOLVED WORKSFORME
:
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: unspecified
: All All
: -- enhancement with 8 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 279281 401353 413970 449365 (view as bug list)
Depends on:
Blocks: 374551 472988
  Show dependency treegraph
 
Reported: 2004-09-15 10:31 PDT by Ryan
Modified: 2010-06-28 02:47 PDT (History)
18 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Ryan 2004-09-15 10:31:46 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

In Thunderbird I would like to be able to specify different columns to show for
each folder.  For example, I want the recipient column to be displayed in my
Sent folder, but not in my Inbox.  It's not shown by default, but if I enable
that column in my Sent folder it is also enabled in my Inbox and every other folder.

Reproducible: Always
Steps to Reproduce:
1. Go to Sent folder and enable the recipent column to display it.
2. Go to Inbox or any other folder and verify that the recipient column also
shows in that folder.
3. Don't want to show it in every folder, just my Sent folder so I can sort
messages that way.
Actual Results:  
see above.

Expected Results:  
The software should, and this is only a suggestion, keep track of display
settings on a folder-by-folder basis.
Comment 1 Mike Cowperthwaite 2004-10-07 10:07:50 PDT
Confirming this because I want this feature too.  Specifically, I only want a 
Junk column for mail Inbox, Junk and Trash folders; I only want a Read and Flag 
column for Inbox and News; and I want 'Sender' and 'Recipient' used for most 
Local Folders, but not for Inbox or Sent, etc.

Specific to the original report: There are, in effect, two column 
configurations: one for the Sent, Drafts and Templates folders and one for 
everything else.  However, the differences only apply to the Sender/Recipient 
columns: If 'Sender' is shown in Inbox, 'Recipient' will be shown in Sent, and 
vice versa.  Also, the column widths can vary between the two configurations.

Compare this to bug 234554, which asks for different column configurations only 
between Mail and News.  I think that solution is insufficient.
Comment 2 Ronald Killmer 2005-07-03 22:06:27 PDT
Netscape Communicator 4.xx had entries in prefs.js for each folder, box, and
group settings by using CSV to record col and their widths.

Comment 3 Karsten Düsterloh 2005-07-04 10:25:11 PDT
FWIW, Mnenhy's FolderStorage does this: <http://mnenhy.mozdev.org/folderstore.html>
Comment 4 Mike Cowperthwaite 2005-09-29 10:15:59 PDT
*** Bug 279281 has been marked as a duplicate of this bug. ***
Comment 5 Ronald Killmer 2006-02-09 15:08:02 PST
(In reply to comment #3)
> FWIW, Mnenhy's FolderStorage does this:
> <http://mnenhy.mozdev.org/folderstore.html>
> 
Nice to know. 

I believe this should be a function of the base application as Mike stated in comment #1.  The use of an extension for this is a short term work around in my view.
Comment 6 Phil Ringnalda (:philor) 2008-01-25 10:52:53 PST
*** Bug 413970 has been marked as a duplicate of this bug. ***
Comment 7 Wayne Mery (:wsmwk, NI for questions) 2008-04-08 11:41:53 PDT
nominating wanted-thunderbird3
see rationale comment 1
Comment 8 Wayne Mery (:wsmwk, NI for questions) 2009-01-10 10:08:15 PST
*** Bug 449365 has been marked as a duplicate of this bug. ***
Comment 9 Micah Gersten 2009-05-25 10:19:29 PDT
Ubuntu bug:
https://bugs.launchpad.net/bugs/56465
Comment 10 Andrew Sutherland [:asuth] 2009-05-26 01:09:14 PDT
Bug 474701 provides groundwork for this functionality in its "folder display layer" patch.
Comment 11 Wayne Mery (:wsmwk, NI for questions) 2009-06-15 20:20:50 PDT
*** Bug 401353 has been marked as a duplicate of this bug. ***
Comment 12 raoul bhatia 2009-07-28 11:31:14 PDT
for what i see, one can now select different columns on every folder, at least for imap accounts, on 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2pre) Gecko/20090727 Shredder/3.0b4pre ID:20090727034746
Comment 13 Andrew Sutherland [:asuth] 2009-07-28 13:05:20 PDT
Right you are, Raoul.  This is fixed on trunk, so WORKSFORME.
Comment 14 Ronald Killmer 2009-07-28 13:22:48 PDT
(In reply to comment #13)
> Right you are, Raoul.  This is fixed on trunk, so WORKSFORME.

Shouldn't this RFE be closed as Fixed and annotated with the Bug that landed the new feature. 

Also, for the record, the new feature works for News though it is not as flexible as NC4, which provided per-group col setting.

Note You need to log in before you can comment on or make changes to this bug.