Closed Bug 259993 Opened 17 years ago Closed 17 years ago

Messed up favicons on Bookmarks with Firefox 1.0 Preview Release

Categories

(Firefox :: Bookmarks & History, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: ghepeu, Assigned: vlad)

References

Details

(Keywords: fixed-aviary1.0)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

When a site has no favicons, firefox displays other sites' favicons instead of
"white sheet" icons. This problema occurs, for example, if I open in tabs all
the bookmarks I have in a folder, and then open on the same window others site
that haven't got favicons: site without favicon are associated to the favicon
previously used in the same tab.

For example: I open in tab all the 4 bookmarks in a folder so Firefox opens:

tab 1: site 1 <=> favicon 1
tab 2: site 2 <=> favicon 2
tab 3: site 3 <=> favicon 3
tab 4: site 4 <=> favicon 4

then, I open another bookmarks folder with 3 items, so I get:

tab 1: site A <=> favicon A
tab 2: site B <=> without favicon 
tab 3: site C <=> without favicon 
tab 4: closed

then on Bookmarks I have:

site 1 <=> favicon 1
site 2 <=> favicon 2
site 3 <=> favicon 3
site 4 <=> favicon 4

site A <=> favicon A
site B <=> favicon 2 (instead of white sheet icon)
site C <=> favicon 3 (instead of white sheet icon)


Reproducible: Always
Steps to Reproduce:
*** Bug 260043 has been marked as a duplicate of this bug. ***
Yep I'm getting the same problem.  What's more annoying is that on occasion
Firefox will replace a bookmark correct icon with an incorrect icon and there
seems to be no way to revert to the old one.

I have to backup my bookmarks file and restore it a lot to prevent this from
happening.
Same issue as Morac. In the screenshot, the first bookmark has the IMDB favicon
for some reason, and the second bookmark has the favicon of the third. This is
replicated in many places in my bookmarks. FF 1.0 PR on WinXP SP2.
I imagine it's really frustrating for the devs to have to deal with so many bugs
over such a little thing as favicons.  That said, it is a *very* visible
feature, that for 1.0 really needs to "just work" IMHO.  I've been bitten by
this one several times, and the only fix is to delete and recreate the bookmark.
 It's pretty annoying, so nominating to block 1.0 accordingly.
Flags: blocking-aviary1.0?
Fix.  The root of the bug comes from us not being able to adequately recognize
when new content is being loaded in a browser view other than the current (in
the progress listener), because of tabbrowser/browser split.  This is a
semi-bandaid; I'm hoping that eventually we can merge tabbrowser/browser and
have all these problems go away (i.e. have the progress listener be told
explicitly which sub-browser's progress is being changed, instead of it
assuming "the current one").
Comment on attachment 160193 [details] [diff] [review]
259993-favicon-open-tabs-fix-0.patch

r+a=ben@mozilla.org
Attachment #160193 - Flags: review?(bugs)
Attachment #160193 - Flags: review+
Attachment #160193 - Flags: approval-aviary+
in on aviary.
Status: NEW → RESOLVED
Closed: 17 years ago
Flags: blocking-aviary1.0?
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
I believe this may have caused Bug 262272.
I still have this problem with the latest version
If anyone is still suffering from this bug, and your bookmarks have messed up
favicons, it means you have to export your bookmark file and manually remove all
of the icon="*whatever*" references from it.

Restore the fixed bookmark file, and you should be fine. :)
I guess we should move to yet another new bug (maybe one for the
tabbrowser/browser merge work that Vlad mentioned?)

I can't make it happen reliably, but using Firefox 1.0 release and starting with
a new bookmark file, and then repeatedly messing with loading the BBC news main
page (http://news.bbc.co.uk/) and other sites (e.g. MozillaZine) in tabs
simultaneously, I can still get the wrong icon onto the BBC bookmark.

This "bandaid" fix has improved things, but the problem still exists.
For the record, bug 271359 is open for residual issues not fixed by the band-aid
fix done here
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.