Icon in location bar doesn't clear when visiting site without favicon

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: PikeUK, Assigned: vlad)

Tracking

({fixed-aviary1.0, regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20040929 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20040929 Firefox/0.10

If you visit a site with a favicon then visit somewhere that doesn't have one
e.g. about: the location bar icon will not clear when the second site is loaded.

Reproducible: Sometimes
Steps to Reproduce:
1. Load http://www.google.com/
2. Load about:

Actual Results:  
The Google favicon is shown in the location bar.

Expected Results:  
The location bar should have the default icon provided by your theme.

Regressed between 2004-09-28 and 2004-09-30, presumably due to the patch from
Bug 259993.
(Reporter)

Updated

14 years ago
Keywords: regression
Created attachment 160673 [details] [diff] [review]
262272-icon-doesnt-clear-regression-0.patch

Whoops.  This should be a much more robust way of clearing this; it sucks that
we have to do it in both places (tabbrowser's web progress only forwards to
browser.js's web progress for the current tab -- but if there's no tabbed
browser, then browser.js's web progress is hooked up directly!).
Attachment #160673 - Flags: review?(bugs)
Attachment #160673 - Flags: approval-aviary?
Attachment #160673 - Flags: review?(bugs) → review+
Attachment #160673 - Flags: approval-aviary? → approval-aviary+
Fixed on aviary.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED

Comment 3

14 years ago
*** Bug 262491 has been marked as a duplicate of this bug. ***
*** Bug 262490 has been marked as a duplicate of this bug. ***
*** Bug 264094 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Depends on: 267367
No longer depends on: 267367

Comment 6

13 years ago
*** Bug 263356 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.